aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2004-05-08 03:37:37 +0800
committersobomax <sobomax@FreeBSD.org>2004-05-08 03:37:37 +0800
commit1ce0c285bb733951f0e81065160e324b153ffdab (patch)
tree8a96605e62e339eb0f667a6e3a4881602971a2ac /textproc
parent05519765243fcce3c5c396ca9badd8118b9447dd (diff)
downloadfreebsd-ports-gnome-1ce0c285bb733951f0e81065160e324b153ffdab.tar.gz
freebsd-ports-gnome-1ce0c285bb733951f0e81065160e324b153ffdab.tar.zst
freebsd-ports-gnome-1ce0c285bb733951f0e81065160e324b153ffdab.zip
Add p5-Spreadsheet-WriteExcelXML 0.02, module for creating an Excel file in XML
format.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Spreadsheet-WriteExcelXML/Makefile27
-rw-r--r--textproc/p5-Spreadsheet-WriteExcelXML/distinfo2
-rw-r--r--textproc/p5-Spreadsheet-WriteExcelXML/pkg-descr14
-rw-r--r--textproc/p5-Spreadsheet-WriteExcelXML/pkg-plist11
5 files changed, 55 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index c00ed2027fb5..9fc238098ccc 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -282,6 +282,7 @@
SUBDIR += p5-Sort-PolySort
SUBDIR += p5-Spreadsheet-ParseExcel
SUBDIR += p5-Spreadsheet-WriteExcel
+ SUBDIR += p5-Spreadsheet-WriteExcelXML
SUBDIR += p5-String-Scanf
SUBDIR += p5-String-ShellQuote
SUBDIR += p5-String-ShowDiff
diff --git a/textproc/p5-Spreadsheet-WriteExcelXML/Makefile b/textproc/p5-Spreadsheet-WriteExcelXML/Makefile
new file mode 100644
index 000000000000..518af0bc239a
--- /dev/null
+++ b/textproc/p5-Spreadsheet-WriteExcelXML/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Spreadsheet::WriteExcelXML
+# Date created: 7 May 2004
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Spreadsheet-WriteExcelXML
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Spreadsheet
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Create an Excel file in XML format
+
+PERL_CONFIGURE= yes
+
+MAN3= Spreadsheet::WriteExcelXML.3 \
+ Spreadsheet::WriteExcelXML::Format.3 \
+ Spreadsheet::WriteExcelXML::Utility.3 \
+ Spreadsheet::WriteExcelXML::Workbook.3 \
+ Spreadsheet::WriteExcelXML::Worksheet.3 \
+ Spreadsheet::WriteExcelXML::XMLwriter.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Spreadsheet-WriteExcelXML/distinfo b/textproc/p5-Spreadsheet-WriteExcelXML/distinfo
new file mode 100644
index 000000000000..38ec3db16488
--- /dev/null
+++ b/textproc/p5-Spreadsheet-WriteExcelXML/distinfo
@@ -0,0 +1,2 @@
+MD5 (Spreadsheet-WriteExcelXML-0.02.tar.gz) = 9149404bc3fc87b2fae0571718faf1e8
+SIZE (Spreadsheet-WriteExcelXML-0.02.tar.gz) = 117060
diff --git a/textproc/p5-Spreadsheet-WriteExcelXML/pkg-descr b/textproc/p5-Spreadsheet-WriteExcelXML/pkg-descr
new file mode 100644
index 000000000000..744943c6b072
--- /dev/null
+++ b/textproc/p5-Spreadsheet-WriteExcelXML/pkg-descr
@@ -0,0 +1,14 @@
+The Spreadsheet::WriteExcelXML module can be used to create an
+Excel file in XML format. The Excel XML format is supported in
+Excel 2002 and 2003.
+
+Multiple worksheets can be added to a workbook and formatting
+can be applied to cells. Text, numbers, and formulas can be
+written to the cells. The module supports strings up to 32,767
+characters and the strings can be in UTF8 format.
+
+Spreadsheet::WriteExcelXML uses the same interface as
+Spreadsheet::WriteExcel.
+
+This module cannot, as yet, be used to write to an existing
+Excel XML file.
diff --git a/textproc/p5-Spreadsheet-WriteExcelXML/pkg-plist b/textproc/p5-Spreadsheet-WriteExcelXML/pkg-plist
new file mode 100644
index 000000000000..64f31254db18
--- /dev/null
+++ b/textproc/p5-Spreadsheet-WriteExcelXML/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Spreadsheet/WriteExcelXML.pm
+%%SITE_PERL%%/Spreadsheet/WriteExcelXML/Format.pm
+%%SITE_PERL%%/Spreadsheet/WriteExcelXML/Utility.pm
+%%SITE_PERL%%/Spreadsheet/WriteExcelXML/Workbook.pm
+%%SITE_PERL%%/Spreadsheet/WriteExcelXML/Worksheet.pm
+%%SITE_PERL%%/Spreadsheet/WriteExcelXML/XMLwriter.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Spreadsheet/WriteExcelXML/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Spreadsheet/WriteExcelXML
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Spreadsheet
+@dirrm %%SITE_PERL%%/Spreadsheet/WriteExcelXML
+@dirrm %%SITE_PERL%%/Spreadsheet