aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2018-02-12 14:49:48 +0800
committerpi <pi@FreeBSD.org>2018-02-12 14:49:48 +0800
commit1d5c24d7eb8f20374762474079915db653ed72d4 (patch)
tree4fe73fbb088e362b614506bd99fe88e4dbc94078 /textproc
parent2b5cdbbb1d59cf6eaab80904d59218b8d12af0e4 (diff)
downloadfreebsd-ports-gnome-1d5c24d7eb8f20374762474079915db653ed72d4.tar.gz
freebsd-ports-gnome-1d5c24d7eb8f20374762474079915db653ed72d4.tar.zst
freebsd-ports-gnome-1d5c24d7eb8f20374762474079915db653ed72d4.zip
New port: textproc/elasticsearch6
Elasticsearch aims to be a Distributed, RESTful, Search Engine built on top of Apache Lucene. WWW: https://www.elastic.co/ PR: 225836 Submitted by: w.schwarzenfeld@utanet.at
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/elasticsearch5/Makefile2
-rw-r--r--textproc/elasticsearch6/Makefile90
-rw-r--r--textproc/elasticsearch6/distinfo3
-rw-r--r--textproc/elasticsearch6/files/elasticsearch.in175
-rw-r--r--textproc/elasticsearch6/files/patch-config_elasticsearch.yml13
-rw-r--r--textproc/elasticsearch6/files/pkg-message.in6
-rw-r--r--textproc/elasticsearch6/pkg-descr4
-rw-r--r--textproc/elasticsearch6/pkg-plist104
9 files changed, 397 insertions, 1 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b189603d093f..4b38d7f4562d 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -165,6 +165,7 @@
SUBDIR += elasticsearch5
SUBDIR += elasticsearch5-search-guard
SUBDIR += elasticsearch5-x-pack
+ SUBDIR += elasticsearch6
SUBDIR += elixir-earmark
SUBDIR += elixir-ex_doc
SUBDIR += elixir-funnel
diff --git a/textproc/elasticsearch5/Makefile b/textproc/elasticsearch5/Makefile
index 51fb72d031d9..c6130b19adac 100644
--- a/textproc/elasticsearch5/Makefile
+++ b/textproc/elasticsearch5/Makefile
@@ -16,7 +16,7 @@ LICENSE= APACHE20
RUN_DEPENDS= bash>0:shells/bash
-CONFLICTS= elasticsearch-[0-9]* elasticsearch2-[0-9]*
+CONFLICTS= elasticsearch-[0-9]* elasticsearch2-[0-9]* elasticsearch6-[0-9]*
USES= cpe shebangfix
NO_ARCH= yes
diff --git a/textproc/elasticsearch6/Makefile b/textproc/elasticsearch6/Makefile
new file mode 100644
index 000000000000..05c282e4d7f1
--- /dev/null
+++ b/textproc/elasticsearch6/Makefile
@@ -0,0 +1,90 @@
+# Created by: Tom Judge <tj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= elasticsearch
+PORTVERSION= 6.0.1
+CATEGORIES= textproc java devel
+MASTER_SITES= https://artifacts.elastic.co/downloads/${PORTNAME}/ \
+ http://mirrors.rit.edu/zi/
+PKGNAMESUFFIX= 6
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Full-text search engine for Java
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= bash>0:shells/bash
+
+CONFLICTS= elasticsearch-[0-9]* elasticsearch2-[0-9]* elasticsearch5-[0-9]*
+
+USES= cpe shebangfix
+NO_ARCH= yes
+USE_JAVA= yes
+NO_BUILD= yes
+JAVA_VERSION= 1.8+
+USE_RC_SUBR= ${PORTNAME}
+SHEBANG_FILES= bin/elasticsearch-plugin \
+ bin/elasticsearch
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+LUCENEVER= 6.4.1
+CONFIG_FILES= elasticsearch.yml log4j2.properties jvm.options
+BINS= elasticsearch \
+ elasticsearch-plugin
+
+DOCS= LICENSE.txt \
+ NOTICE.txt \
+ README.textile
+
+SIGAR_ARCH= ${ARCH:S|i386|x86|}
+SEARCHUSER?= elasticsearch
+SEARCHGROUP?= ${SEARCHUSER}
+USERS= ${SEARCHUSER}
+GROUPS= ${SEARCHGROUP}
+ELASTIC_DBDIR= /var/db/elasticsearch
+ELASTIC_LOGDIR= /var/log/elasticsearch
+
+SUB_LIST= SEARCHUSER=${SEARCHUSER} \
+ SEARCHGROUP=${SEARCHGROUP} \
+ PORTVERSION=${PORTVERSION}
+SUB_FILES= pkg-message
+PLIST_SUB+= SEARCHUSER=${SEARCHUSER} \
+ SEARCHGROUP=${SEARCHGROUP} \
+ LUCENEVER=${LUCENEVER} \
+ PORTVERSION=${PORTVERSION} \
+ ELASTIC_DBDIR=${ELASTIC_DBDIR} \
+ ELASTIC_LOGDIR=${ELASTIC_LOGDIR}
+
+post-patch:
+ ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/config/elasticsearch.yml
+ ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/bin/elasticsearch
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/elasticsearch
+.for f in ${CONFIG_FILES}
+ ${INSTALL} -m 440 ${WRKSRC}/config/${f} ${STAGEDIR}${ETCDIR}/${f}.sample
+.endfor
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin
+.for f in ${BINS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${f} ${STAGEDIR}${PREFIX}/lib/elasticsearch/bin
+.endfor
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib
+ (cd ${WRKSRC}/lib && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/elasticsearch/lib/ "-name *\.jar")
+
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/modules
+ (cd ${WRKSRC}/modules && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/elasticsearch/modules/)
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/elasticsearch
+ @${MKDIR} ${STAGEDIR}${ELASTIC_DBDIR} ${STAGEDIR}${ELASTIC_LOGDIR}
+ cd ${STAGEDIR}${PREFIX}/bin && ${LN} -s ${PREFIX}/lib/elasticsearch/bin/elasticsearch-plugin elasticsearch-plugin
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/textproc/elasticsearch6/distinfo b/textproc/elasticsearch6/distinfo
new file mode 100644
index 000000000000..bfdd7f575058
--- /dev/null
+++ b/textproc/elasticsearch6/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518385033
+SHA256 (elasticsearch-6.0.1.tar.gz) = efaf32aba41e1b7fd086639c0f062c39e1f28b360a78d5c2b8deed797a4c5c57
+SIZE (elasticsearch-6.0.1.tar.gz) = 28026460
diff --git a/textproc/elasticsearch6/files/elasticsearch.in b/textproc/elasticsearch6/files/elasticsearch.in
new file mode 100644
index 000000000000..f6a2496c82bd
--- /dev/null
+++ b/textproc/elasticsearch6/files/elasticsearch.in
@@ -0,0 +1,175 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: elasticsearch
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following line to /etc/rc.conf to enable elasticsearch:
+#
+# elasticsearch_enable="YES"
+#
+# elasticsearch_user (username): Set to elasticsearch by default.
+# Set it to required username.
+# elasticsearch_group (group): Set to elasticsearch by default.
+# Set it to required group.
+# elasticsearch_config (path): Set to /usr/local/etc/elasticsearch/elasticsearch.yml by default.
+# Set it to the config file location.
+# elasticsearch_tmp (path): Set to /var/tmp/elasticsearch by default.
+# Set it to the path to be used for temp files.
+#
+. /etc/rc.subr
+
+name=elasticsearch
+rcvar=elasticsearch_enable
+
+load_rc_config ${name}
+
+: ${elasticsearch_enable:="NO"}
+: ${elasticsearch_user:=%%SEARCHUSER%%}
+: ${elasticsearch_group:=%%SEARCHGROUP%%}
+: ${elasticsearch_config:="%%PREFIX%%/etc/elasticsearch"}
+: ${elasticsearch_tmp:="/var/tmp/elasticsearch"}
+
+required_files="${elasticsearch_config}/elasticsearch.yml"
+_pidprefix="/var/run/elasticsearch"
+pidfile="${_pidprefix}.pid"
+
+extra_commands="console status"
+console_cmd="elasticsearch_console"
+start_precmd="elasticsearch_precmd"
+status_cmd="elasticsearch_status"
+stop_cmd="elasticsearch_stop"
+command="%%PREFIX%%/lib/elasticsearch/bin/elasticsearch"
+command_args="-d --pidfile=${pidfile}"
+
+elasticsearch_precmd()
+{
+ touch ${pidfile}
+ chown ${elasticsearch_user}:${elasticsearch_group} ${pidfile}
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 ${elasticsearch_tmp}
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 /var/db/elasticsearch
+ /usr/bin/install -d -o ${elasticsearch_user} -g ${elasticsearch_group} -m 750 /var/log/elasticsearch
+}
+
+elasticsearch_console()
+{
+ command_args=""
+ run_rc_command "start"
+}
+
+
+elasticsearch_stop()
+{
+ rc_pid=$(elasticsearch_check_pidfile $pidfile)
+
+ if [ -z "$rc_pid" ]; then
+ [ -n "$rc_fast" ] && return 0
+ echo "${name} not running? (check $pidfile)."
+ return 1
+ fi
+
+ echo "Stopping ${name}."
+ kill ${rc_pid} 2> /dev/null
+}
+
+elasticsearch_status()
+{
+ rc_pid=$(elasticsearch_check_pidfile $pidfile)
+
+ if [ -z "$rc_pid" ]; then
+ [ -n "$rc_fast" ] && return 0
+ echo "${name} not running? (check $pidfile)."
+ return 1
+ fi
+ echo "${name} is running as pid ${rc_pid}."
+}
+
+elasticsearch_check_pidfile()
+{
+ _pidfile=$1
+ if [ -z "$_pidfile" ]; then
+ err 3 'USAGE: elasticsearch_check_pidfile pidfile'
+ fi
+ if [ ! -f $_pidfile ]; then
+ debug "pid file ($_pidfile): not readable."
+ return
+ fi
+ read _pid _junk < $_pidfile
+ if [ -z "$_pid" ]; then
+ debug "pid file ($_pidfile): no pid in file."
+ return
+ fi
+ if [ -n "`%%LOCALBASE%%/bin/jps -l | grep -e "^$_pid"`" ]; then
+ echo -n $_pid
+ fi
+}
+if [ -n "$2" ]; then
+ profile="$2"
+ if [ "x${elasticsearch_profiles}" != "x" ]; then
+ pidfile="${_pidprefix}.${profile}.pid"
+ command_args="-d --pidfile=${pidfile}"
+ eval elasticsearch_config="\${elasticsearch_${profile}_config:-}"
+ if [ "x${elasticsearch_config}" = "x" ]; then
+ echo "You must define a configuration (elasticsearch_${profile}_config)"
+ exit 1
+ fi
+ required_files="${elasticsearch_config}/elasticsearch.yml"
+ required_files="${elasticsearch_config}/jvm.options"
+ eval elasticsearch_enable="\${elasticsearch_${profile}_enable:-${elasticsearch_enable}}"
+ eval elasticsearch_tmp="\${elasticsearch_${profile}_args:-${elasticsearch_tmp}}"
+ else
+ echo "$0: extra argument ignored"
+ fi
+else
+ if [ "x${elasticsearch_profiles}" != "x" -a "x$1" != "x" ]; then
+ for profile in ${elasticsearch_profiles}; do
+ eval _enable="\${elasticsearch_${profile}_enable}"
+ case "x${_enable:-${elasticsearch_enable}}" in
+ x|x[Nn][Oo]|x[Nn][Oo][Nn][Ee])
+ continue
+ ;;
+ x[Yy][Ee][Ss])
+ ;;
+ *)
+ if test -z "$_enable"; then
+ _var=elasticsearch_enable
+ else
+ _var=elasticsearch_"${profile}"_enable
+ fi
+ echo "Bad value" \
+ "'${_enable:-${elasticsearch_enable}}'" \
+ "for ${_var}. " \
+ "Profile ${profile} skipped."
+ continue
+ ;;
+ esac
+ echo "===> elasticsearch profile: ${profile}"
+ /usr/local/etc/rc.d/elasticsearch $1 ${profile}
+ retcode="$?"
+ if [ "0${retcode}" -ne 0 ]; then
+ failed="${profile} (${retcode}) ${failed:-}"
+ else
+ success="${profile} ${success:-}"
+ fi
+ done
+ exit 0
+ fi
+fi
+
+if [ "x${elasticsearch_mem_min}" != "x" ]; then
+ echo "The elasticsearch_mem_min variable is no longer supported please set this in %%PREFIX%%/etc/jvm.options"
+ exit 1;
+fi
+if [ "x${elasticsearch_mem_max}" != "x" ]; then
+ echo "The elasticsearch_mem_max variable is no longer supported please set this in %%PREFIX%%/etc/jvm.options"
+ exit 1;
+fi
+if [ "x${elasticsearch_props}" != "x" ]; then
+ echo "The elasticsearch_props variable is no longer supported please set this in %%PREFIX%%/etc/jvm.options"
+ exit 1;
+fi
+
+run_rc_command "$1"
diff --git a/textproc/elasticsearch6/files/patch-config_elasticsearch.yml b/textproc/elasticsearch6/files/patch-config_elasticsearch.yml
new file mode 100644
index 000000000000..d44fa1d5a675
--- /dev/null
+++ b/textproc/elasticsearch6/files/patch-config_elasticsearch.yml
@@ -0,0 +1,13 @@
+--- config/elasticsearch.yml.orig 2018-02-06 00:13:22 UTC
++++ config/elasticsearch.yml
+@@ -35,6 +35,10 @@
+ # Path to log files:
+ #
+ #path.logs: /path/to/logs
++path.logs: /var/log/elasticsearch
++#
++# Path to scripts dir:
++path.scripts: /usr/local/libexec/elasticsearch
+ #
+ # ----------------------------------- Memory -----------------------------------
+ #
diff --git a/textproc/elasticsearch6/files/pkg-message.in b/textproc/elasticsearch6/files/pkg-message.in
new file mode 100644
index 000000000000..e7f3aecf52b8
--- /dev/null
+++ b/textproc/elasticsearch6/files/pkg-message.in
@@ -0,0 +1,6 @@
+======================================================================
+
+Please see %%ETCDIR%% for sample versions of
+elasticsearch.yml and logging.yml.
+
+======================================================================
diff --git a/textproc/elasticsearch6/pkg-descr b/textproc/elasticsearch6/pkg-descr
new file mode 100644
index 000000000000..9f2f48bd8302
--- /dev/null
+++ b/textproc/elasticsearch6/pkg-descr
@@ -0,0 +1,4 @@
+Elasticsearch aims to be a Distributed, RESTful, Search Engine built on top of
+Apache Lucene.
+
+WWW: https://www.elastic.co/
diff --git a/textproc/elasticsearch6/pkg-plist b/textproc/elasticsearch6/pkg-plist
new file mode 100644
index 000000000000..c2c14636015e
--- /dev/null
+++ b/textproc/elasticsearch6/pkg-plist
@@ -0,0 +1,104 @@
+@sample(%%SEARCHUSER%%,%%SEARCHGROUP%%,440) %%ETCDIR%%/elasticsearch.yml.sample
+@sample(%%SEARCHUSER%%,%%SEARCHGROUP%%,440) %%ETCDIR%%/log4j2.properties.sample
+@sample(%%SEARCHUSER%%,%%SEARCHGROUP%%,440) %%ETCDIR%%/jvm.options.sample
+bin/%%SEARCHUSER%%-plugin
+lib/%%SEARCHUSER%%/bin/%%SEARCHUSER%%
+lib/%%SEARCHUSER%%/bin/%%SEARCHUSER%%-plugin
+lib/%%SEARCHUSER%%/lib/HdrHistogram-2.1.9.jar
+lib/%%SEARCHUSER%%/lib/%%SEARCHUSER%%-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/lib/hppc-0.7.1.jar
+lib/%%SEARCHUSER%%/lib/jackson-core-2.8.6.jar
+lib/%%SEARCHUSER%%/lib/jackson-dataformat-cbor-2.8.6.jar
+lib/%%SEARCHUSER%%/lib/jackson-dataformat-smile-2.8.6.jar
+lib/%%SEARCHUSER%%/lib/jackson-dataformat-yaml-2.8.6.jar
+lib/%%SEARCHUSER%%/lib/java-version-checker-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/lib/jna-4.4.0-1.jar
+lib/%%SEARCHUSER%%/lib/joda-time-2.9.5.jar
+lib/%%SEARCHUSER%%/lib/jopt-simple-5.0.2.jar
+lib/%%SEARCHUSER%%/lib/jts-1.13.jar
+lib/%%SEARCHUSER%%/lib/log4j-1.2-api-2.9.1.jar
+lib/%%SEARCHUSER%%/lib/log4j-api-2.9.1.jar
+lib/%%SEARCHUSER%%/lib/log4j-core-2.9.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-analyzers-common-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-backward-codecs-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-core-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-grouping-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-highlighter-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-join-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-memory-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-misc-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-queries-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-queryparser-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-sandbox-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-spatial-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-spatial-extras-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-spatial3d-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/lucene-suggest-7.0.1.jar
+lib/%%SEARCHUSER%%/lib/plugin-cli-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/lib/securesm-1.2.jar
+lib/%%SEARCHUSER%%/lib/snakeyaml-1.15.jar
+lib/%%SEARCHUSER%%/lib/spatial4j-0.6.jar
+lib/%%SEARCHUSER%%/lib/t-digest-3.0.jar
+lib/%%SEARCHUSER%%/modules/aggs-matrix-stats/aggs-matrix-stats-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/modules/aggs-matrix-stats/plugin-descriptor.properties
+lib/%%SEARCHUSER%%/modules/analysis-common/analysis-common-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/modules/analysis-common/plugin-descriptor.properties
+lib/%%SEARCHUSER%%/modules/ingest-common/ingest-common-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/modules/ingest-common/jcodings-1.0.12.jar
+lib/%%SEARCHUSER%%/modules/ingest-common/joni-2.1.6.jar
+lib/%%SEARCHUSER%%/modules/ingest-common/plugin-descriptor.properties
+lib/%%SEARCHUSER%%/modules/lang-expression/antlr4-runtime-4.5.1-1.jar
+lib/%%SEARCHUSER%%/modules/lang-expression/asm-5.0.4.jar
+lib/%%SEARCHUSER%%/modules/lang-expression/asm-commons-5.0.4.jar
+lib/%%SEARCHUSER%%/modules/lang-expression/asm-tree-5.0.4.jar
+lib/%%SEARCHUSER%%/modules/lang-expression/lang-expression-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/modules/lang-expression/lucene-expressions-7.0.1.jar
+lib/%%SEARCHUSER%%/modules/lang-expression/plugin-descriptor.properties
+lib/%%SEARCHUSER%%/modules/lang-expression/plugin-security.policy
+lib/%%SEARCHUSER%%/modules/lang-mustache/compiler-0.9.3.jar
+lib/%%SEARCHUSER%%/modules/lang-mustache/lang-mustache-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/modules/lang-mustache/plugin-descriptor.properties
+lib/%%SEARCHUSER%%/modules/lang-mustache/plugin-security.policy
+lib/%%SEARCHUSER%%/modules/lang-painless/antlr4-runtime-4.5.1-1.jar
+lib/%%SEARCHUSER%%/modules/lang-painless/asm-debug-all-5.1.jar
+lib/%%SEARCHUSER%%/modules/lang-painless/lang-painless-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/modules/lang-painless/plugin-descriptor.properties
+lib/%%SEARCHUSER%%/modules/lang-painless/plugin-security.policy
+lib/%%SEARCHUSER%%/modules/parent-join/parent-join-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/modules/parent-join/plugin-descriptor.properties
+lib/%%SEARCHUSER%%/modules/percolator/percolator-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/modules/percolator/plugin-descriptor.properties
+lib/%%SEARCHUSER%%/modules/reindex/commons-codec-1.10.jar
+lib/%%SEARCHUSER%%/modules/reindex/commons-logging-1.1.3.jar
+lib/%%SEARCHUSER%%/modules/reindex/%%SEARCHUSER%%-rest-client-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/modules/reindex/httpasyncclient-4.1.2.jar
+lib/%%SEARCHUSER%%/modules/reindex/httpclient-4.5.2.jar
+lib/%%SEARCHUSER%%/modules/reindex/httpcore-4.4.5.jar
+lib/%%SEARCHUSER%%/modules/reindex/httpcore-nio-4.4.5.jar
+lib/%%SEARCHUSER%%/modules/reindex/plugin-descriptor.properties
+lib/%%SEARCHUSER%%/modules/reindex/plugin-security.policy
+lib/%%SEARCHUSER%%/modules/reindex/reindex-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/modules/repository-url/plugin-descriptor.properties
+lib/%%SEARCHUSER%%/modules/repository-url/plugin-security.policy
+lib/%%SEARCHUSER%%/modules/repository-url/repository-url-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/modules/transport-netty4/netty-buffer-4.1.13.Final.jar
+lib/%%SEARCHUSER%%/modules/transport-netty4/netty-codec-4.1.13.Final.jar
+lib/%%SEARCHUSER%%/modules/transport-netty4/netty-codec-http-4.1.13.Final.jar
+lib/%%SEARCHUSER%%/modules/transport-netty4/netty-common-4.1.13.Final.jar
+lib/%%SEARCHUSER%%/modules/transport-netty4/netty-handler-4.1.13.Final.jar
+lib/%%SEARCHUSER%%/modules/transport-netty4/netty-resolver-4.1.13.Final.jar
+lib/%%SEARCHUSER%%/modules/transport-netty4/netty-transport-4.1.13.Final.jar
+lib/%%SEARCHUSER%%/modules/transport-netty4/plugin-descriptor.properties
+lib/%%SEARCHUSER%%/modules/transport-netty4/plugin-security.policy
+lib/%%SEARCHUSER%%/modules/transport-netty4/transport-netty4-%%PORTVERSION%%.jar
+lib/%%SEARCHUSER%%/modules/tribe/plugin-descriptor.properties
+lib/%%SEARCHUSER%%/modules/tribe/tribe-%%PORTVERSION%%.jar
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/NOTICE.txt
+%%PORTDOCS%%%%DOCSDIR%%/README.textile
+@dir lib/%%SEARCHUSER%%/plugins
+@dir libexec/%%SEARCHUSER%%
+@dir(%%SEARCHUSER%%,%%SEARCHGROUP%%,750) %%ELASTIC_LOGDIR%%
+@dir(%%SEARCHUSER%%,%%SEARCHGROUP%%,750) %%ELASTIC_DBDIR%%
+@postunexec if [ -d %%ELASTIC_LOGDIR%% ]; then echo "You should remove %%ELASTIC_LOGDIR%% if you don't need it any more."; fi
+@postunexec if [ -d %%ELASTIC_DBDIR%% ]; then echo "You should remove %%ELASTIC_DBDIR%% if you don't need it any more."; fi