aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-09-09 03:26:54 +0800
committerantoine <antoine@FreeBSD.org>2014-09-09 03:26:54 +0800
commit27230edb2a52ae00fc365871efa05febc1acbcf1 (patch)
tree42c0ff0dbb600631a0478cca2ad673399a800239 /textproc
parentda5a9fb109d1fbb9c7da127a93a9ba0c0b0e210d (diff)
downloadfreebsd-ports-gnome-27230edb2a52ae00fc365871efa05febc1acbcf1.tar.gz
freebsd-ports-gnome-27230edb2a52ae00fc365871efa05febc1acbcf1.tar.zst
freebsd-ports-gnome-27230edb2a52ae00fc365871efa05febc1acbcf1.zip
- Allow staging as a regular user
- USES=python
Diffstat (limited to 'textproc')
-rw-r--r--textproc/cwtext/Makefile9
-rw-r--r--textproc/cwtext/files/patch-makefile13
2 files changed, 8 insertions, 14 deletions
diff --git a/textproc/cwtext/Makefile b/textproc/cwtext/Makefile
index 82f77c3680fc..ea38ceb7ee8d 100644
--- a/textproc/cwtext/Makefile
+++ b/textproc/cwtext/Makefile
@@ -9,8 +9,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}%20${PORTVERSION}
MAINTAINER= db@FreeBSD.org
COMMENT= Morse Code Generator
-USE_PYTHON= yes
-USES= gmake
+USES= gmake python
MAKEFILE= makefile
ALL_TARGET= ALL
@@ -18,12 +17,8 @@ LICENSE= GPLv2
OPTIONS_DEFINE= DOCS
-post-patch:
- @${REINPLACE_CMD} -e "s,%%STAGEDIR%%,${STAGEDIR},g" \
- ${WRKSRC}/makefile
-
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/textproc/cwtext/files/patch-makefile b/textproc/cwtext/files/patch-makefile
index 174799770a62..764547207fbb 100644
--- a/textproc/cwtext/files/patch-makefile
+++ b/textproc/cwtext/files/patch-makefile
@@ -1,18 +1,17 @@
---- makefile.orig 2004-12-16 07:15:22.000000000 -0500
-+++ makefile 2013-12-30 18:06:28.000000000 -0500
-@@ -1,11 +1,10 @@
+--- makefile.orig 2004-12-16 12:15:22 UTC
++++ makefile
+@@ -1,11 +1,9 @@
-PREFIX=/usr/local
-
ALL: cwtext cwpcm cwmm
-+STAGEDIR=%%STAGEDIR%%
install: ALL
- install -sc cwtext ${PREFIX}/bin
- install -sc cwpcm ${PREFIX}/bin
- install -sc cwmm ${PREFIX}/bin
-+ install -s -o root -g wheel -m 555 cwtext ${STAGEDIR}${PREFIX}/bin
-+ install -s -o root -g wheel -m 555 cwpcm ${STAGEDIR}${PREFIX}/bin
-+ install -s -o root -g wheel -m 555 cwmm ${STAGEDIR}${PREFIX}/bin
++ $(BSD_INSTALL_PROGRAM) cwtext ${DESTDIR}${PREFIX}/bin
++ $(BSD_INSTALL_PROGRAM) cwpcm ${DESTDIR}${PREFIX}/bin
++ $(BSD_INSTALL_PROGRAM) cwmm ${DESTDIR}${PREFIX}/bin
cwmm: cwmm.o morse.o
${CC} ${CFLAGS} -o cwmm $^