aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-02-14 03:39:51 +0800
committeryuri <yuri@FreeBSD.org>2018-02-14 03:39:51 +0800
commit2b54e3380793a8f6016b5e3c26d7ed90432c8a0b (patch)
tree258cc4052a03acc43838595dc9fb1c6d13ca9e42 /textproc
parent77b6891496d92985ec50035be3e92c95fc4115ba (diff)
downloadfreebsd-ports-gnome-2b54e3380793a8f6016b5e3c26d7ed90432c8a0b.tar.gz
freebsd-ports-gnome-2b54e3380793a8f6016b5e3c26d7ed90432c8a0b.tar.zst
freebsd-ports-gnome-2b54e3380793a8f6016b5e3c26d7ed90432c8a0b.zip
New port: textproc/py-python-bidi: Pure python implementation of the BiDi layout algorithm
See https://github.com/MeirKriheli/python-bidi Approved by: tcberner (mentor)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-python-bidi/Makefile19
-rw-r--r--textproc/py-python-bidi/distinfo3
-rw-r--r--textproc/py-python-bidi/pkg-descr4
4 files changed, 27 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4b38d7f4562d..ac80283ec44b 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1340,6 +1340,7 @@
SUBDIR += py-pystache
SUBDIR += py-pystemmer
SUBDIR += py-python-augeas
+ SUBDIR += py-python-bidi
SUBDIR += py-python-docx
SUBDIR += py-python-gettext
SUBDIR += py-python-slugify
diff --git a/textproc/py-python-bidi/Makefile b/textproc/py-python-bidi/Makefile
new file mode 100644
index 000000000000..18fe6db294cf
--- /dev/null
+++ b/textproc/py-python-bidi/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= python-bidi
+DISTVERSION= 0.4.0
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Pure python implementation of the BiDi layout algorithm
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= python
+USE_PYTHON= distutils autoplist concurrent
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-python-bidi/distinfo b/textproc/py-python-bidi/distinfo
new file mode 100644
index 000000000000..4afb28ef820e
--- /dev/null
+++ b/textproc/py-python-bidi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518519741
+SHA256 (python-bidi-0.4.0.tar.gz) = 1a1b3dbee4a0b307c91a465ba4caa8baaaa178151acd20de50ba24f9385f7e13
+SIZE (python-bidi-0.4.0.tar.gz) = 38566
diff --git a/textproc/py-python-bidi/pkg-descr b/textproc/py-python-bidi/pkg-descr
new file mode 100644
index 000000000000..4e27cb04e19b
--- /dev/null
+++ b/textproc/py-python-bidi/pkg-descr
@@ -0,0 +1,4 @@
+Bi-directional (BiDi) layout implementation in pure python.
+It contains library and command line utility pybidi.
+
+WWW: https://github.com/MeirKriheli/python-bidi