aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2012-10-10 07:33:12 +0800
committercy <cy@FreeBSD.org>2012-10-10 07:33:12 +0800
commit2bca5fe2700a6abada4da75364d76133c5eadb09 (patch)
tree63ab8ca866490166bd662bc13255bb82c75f38ee /textproc
parent355a33adf8747b2dd71fe357a9b493ac6191131b (diff)
downloadfreebsd-ports-gnome-2bca5fe2700a6abada4da75364d76133c5eadb09.tar.gz
freebsd-ports-gnome-2bca5fe2700a6abada4da75364d76133c5eadb09.tar.zst
freebsd-ports-gnome-2bca5fe2700a6abada4da75364d76133c5eadb09.zip
Allow textproc/libtextcat and textproc/libexttextcat to coexist on the same
system. Reviewed by: thierry, crees, bapt Approved by: bapt (using his portmgr and office hats), thierry
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libexttextcat/Makefile11
-rw-r--r--textproc/libexttextcat/pkg-plist6
-rw-r--r--textproc/libtextcat/Makefile12
3 files changed, 19 insertions, 10 deletions
diff --git a/textproc/libexttextcat/Makefile b/textproc/libexttextcat/Makefile
index d9cf059102e5..76e49734386d 100644
--- a/textproc/libexttextcat/Makefile
+++ b/textproc/libexttextcat/Makefile
@@ -2,6 +2,7 @@
PORTNAME= libexttextcat
PORTVERSION= 3.3.1
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://dev-www.libreoffice.org/src/libexttextcat/
@@ -10,8 +11,6 @@ COMMENT= Language guessing by N-Gram-Based Text Categorization
LICENSE= BSD
-CONFLICTS_INSTALL= libtextcat*
-
USE_XZ= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -20,15 +19,21 @@ USE_LDCONFIG= yes
PORTDOCS= README README.libtextcat TODO
-OPTIONS_DEFINE= COMPAT_TEXTCAT DOCS
+OPTIONS_DEFINE= COMPAT_TEXTCAT DOCS
COMPAT_TEXTCAT_DESC= Install libtextcat compatible files
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCOMPAT_TEXTCAT}
+.if exists(${PREFIX}/lib/libtextcat.a)
+CONFLICTS_INSTALL= libtextcat*
+.endif
PLIST_SUB+= TEXTCAT=''
+PLIST_SUB+= EXEEXT=''
.else
PLIST_SUB+= TEXTCAT='@comment '
+PLIST_SUB+= EXEEXT='x'
+MAKE_ARGS= EXEEXT=x
.endif
post-install:
diff --git a/textproc/libexttextcat/pkg-plist b/textproc/libexttextcat/pkg-plist
index 95f455c9c123..085445465df7 100644
--- a/textproc/libexttextcat/pkg-plist
+++ b/textproc/libexttextcat/pkg-plist
@@ -1,4 +1,4 @@
-bin/createfp
+bin/createfp%%EXEEXT%%
include/libexttextcat/common.h
include/libexttextcat/constants.h
include/libexttextcat/exttextcat-version.h
@@ -174,6 +174,6 @@ share/vala/vapi/libexttextcat.vapi
%%DATADIR%%/zh-Hant.lm
%%DATADIR%%/zu.lm
@dirrm %%DATADIR%%
-@dirrm share/vala/vapi
-@dirrm share/vala/
+@dirrmtry share/vala/vapi
+@dirrmtry share/vala/
@dirrm include/libexttextcat
diff --git a/textproc/libtextcat/Makefile b/textproc/libtextcat/Makefile
index e58f0fd54709..c2a65d414dd6 100644
--- a/textproc/libtextcat/Makefile
+++ b/textproc/libtextcat/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libtextcat
PORTVERSION= 2.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= textproc
MASTER_SITES= http://software.wise-guys.nl/download/
@@ -17,14 +17,18 @@ COMMENT= Language guessing by N-Gram-Based Text Categorization
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/LICENSE
-CONFLICTS_INSTALL= libexttextcat*
-
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
PORTDOCS= LICENSE README TODO
+.include <bsd.port.pre.mk>
+
+.if exists($(PREFIX)/lib/libtextcat.a)
+CONFLICTS_INSTALL= libexttextcat*
+.endif
+
post-install:
${INSTALL_DATA} ${WRKSRC}/src/textcat.h ${PREFIX}/include/
${MKDIR} ${DATADIR}/LM
@@ -44,4 +48,4 @@ regression-test:
../src/testtextcat conf.txt < $$t ; \
done)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>