aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-06-09 14:10:04 +0800
committerknu <knu@FreeBSD.org>2002-06-09 14:10:04 +0800
commit2ea456aee9279ce30500a808b270a61acdfb7adc (patch)
treec9c68c2f10de61dfb81dc8df206997f10080c162 /textproc
parent7a12d7c6b501c907cc1f29ca45463df3377ac76c (diff)
downloadfreebsd-ports-gnome-2ea456aee9279ce30500a808b270a61acdfb7adc.tar.gz
freebsd-ports-gnome-2ea456aee9279ce30500a808b270a61acdfb7adc.tar.zst
freebsd-ports-gnome-2ea456aee9279ce30500a808b270a61acdfb7adc.zip
devel/ruby-racc-runtime has been replaced with lang/ruby16-shim-ruby18.
Reported by: make index
Diffstat (limited to 'textproc')
-rw-r--r--textproc/ruby-xmlscan-old/Makefile9
-rw-r--r--textproc/ruby-xmlscan/Makefile9
2 files changed, 14 insertions, 4 deletions
diff --git a/textproc/ruby-xmlscan-old/Makefile b/textproc/ruby-xmlscan-old/Makefile
index 7b4170cfe394..5ed1ec80747e 100644
--- a/textproc/ruby-xmlscan-old/Makefile
+++ b/textproc/ruby-xmlscan-old/Makefile
@@ -15,10 +15,15 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= racc:${PORTSDIR}/devel/ruby-racc
-RUN_DEPENDS= ${RUBY_SITELIBDIR}/racc/parser.rb:${PORTSDIR}/devel/ruby-racc-runtime
USE_RUBY= yes
+.include <bsd.port.pre.mk>
+
+.if ${RUBY_VER} < 1.7
+RUN_DEPENDS+= ${RUBY_SITELIBDIR}/racc/parser.rb:${PORTSDIR}/lang/ruby16-shim-ruby18
+.endif
+
do-build:
cd ${WRKSRC}; racc -v -g -c -o xmldtd.rb xmldtd.ry
@@ -29,4 +34,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/${PORTNAME}/ja/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/ruby-xmlscan/Makefile b/textproc/ruby-xmlscan/Makefile
index 7b4170cfe394..5ed1ec80747e 100644
--- a/textproc/ruby-xmlscan/Makefile
+++ b/textproc/ruby-xmlscan/Makefile
@@ -15,10 +15,15 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= racc:${PORTSDIR}/devel/ruby-racc
-RUN_DEPENDS= ${RUBY_SITELIBDIR}/racc/parser.rb:${PORTSDIR}/devel/ruby-racc-runtime
USE_RUBY= yes
+.include <bsd.port.pre.mk>
+
+.if ${RUBY_VER} < 1.7
+RUN_DEPENDS+= ${RUBY_SITELIBDIR}/racc/parser.rb:${PORTSDIR}/lang/ruby16-shim-ruby18
+.endif
+
do-build:
cd ${WRKSRC}; racc -v -g -c -o xmldtd.rb xmldtd.ry
@@ -29,4 +34,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/${PORTNAME}/ja/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>