aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2017-03-02 02:57:31 +0800
committermatthew <matthew@FreeBSD.org>2017-03-02 02:57:31 +0800
commit323f6e166d2bea3b51deefcbcb7f5405fc7104c9 (patch)
tree34c765ba0d1db20ddb9fc7625262b19456c6cbd7 /textproc
parentebf42dcc76dcbbe297a12db7bf5ac80a890b722c (diff)
downloadfreebsd-ports-gnome-323f6e166d2bea3b51deefcbcb7f5405fc7104c9.tar.gz
freebsd-ports-gnome-323f6e166d2bea3b51deefcbcb7f5405fc7104c9.tar.zst
freebsd-ports-gnome-323f6e166d2bea3b51deefcbcb7f5405fc7104c9.zip
A Python slugify application that handles unicode
WWW: https://github.com/un33k/python-slugify
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-python-slugify/Makefile21
-rw-r--r--textproc/py-python-slugify/distinfo3
-rw-r--r--textproc/py-python-slugify/pkg-descr3
4 files changed, 28 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 47dc0d6ce72f..c86bcc7de59e 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1301,6 +1301,7 @@
SUBDIR += py-python-augeas
SUBDIR += py-python-docx
SUBDIR += py-python-gettext
+ SUBDIR += py-python-slugify
SUBDIR += py-pytidylib
SUBDIR += py-pyx12
SUBDIR += py-qrcode
diff --git a/textproc/py-python-slugify/Makefile b/textproc/py-python-slugify/Makefile
new file mode 100644
index 000000000000..6cfb44599be2
--- /dev/null
+++ b/textproc/py-python-slugify/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= python-slugify
+PORTVERSION= 1.2.1
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= Slugify application that handles unicode
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}unidecode>=0.04.16:converters/py-unidecode
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-python-slugify/distinfo b/textproc/py-python-slugify/distinfo
new file mode 100644
index 000000000000..7d3b5c6c9470
--- /dev/null
+++ b/textproc/py-python-slugify/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1488355541
+SHA256 (python-slugify-1.2.1.tar.gz) = 501182ec738cc8b743ae5c76c183f4427187ef016257f062b3fa594f60916e34
+SIZE (python-slugify-1.2.1.tar.gz) = 5327
diff --git a/textproc/py-python-slugify/pkg-descr b/textproc/py-python-slugify/pkg-descr
new file mode 100644
index 000000000000..f1afb0295d0b
--- /dev/null
+++ b/textproc/py-python-slugify/pkg-descr
@@ -0,0 +1,3 @@
+A Python slugify application that handles unicode
+
+WWW: https://github.com/un33k/python-slugify