aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-21 00:36:24 +0800
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-05-21 00:36:24 +0800
commit332003a1603218ce033de93292182677459872f0 (patch)
tree2781cf6f03a41c4901b64c7e9ffa60f54366455a /textproc
parentf4a958e1852315659ccf2baae0688847ae4c6528 (diff)
downloadfreebsd-ports-gnome-332003a1603218ce033de93292182677459872f0.tar.gz
freebsd-ports-gnome-332003a1603218ce033de93292182677459872f0.tar.zst
freebsd-ports-gnome-332003a1603218ce033de93292182677459872f0.zip
textproc/topic: fix build with GCC-based architectures
Specifically specify signed char to fix build error on powerpc64. PR: 237555 Approved by: email@freebsd.hypermart.net (maintainer timeout), mat (mentor) Differential Revision: https://reviews.freebsd.org/D20285
Diffstat (limited to 'textproc')
-rw-r--r--textproc/topic/Makefile2
-rw-r--r--textproc/topic/files/patch-linenoise.c11
2 files changed, 11 insertions, 2 deletions
diff --git a/textproc/topic/Makefile b/textproc/topic/Makefile
index d4e59d5de81d..47d405ceb39b 100644
--- a/textproc/topic/Makefile
+++ b/textproc/topic/Makefile
@@ -11,8 +11,6 @@ COMMENT= Topic markup parser
LICENSE= BSD2CLAUSE
-BROKEN_powerpc64= Does not build: warning: comparison is always false due to limited range of data type
-
PLIST_FILES= bin/topic \
man/man1/topic.1.gz
do-install:
diff --git a/textproc/topic/files/patch-linenoise.c b/textproc/topic/files/patch-linenoise.c
new file mode 100644
index 000000000000..f0b692915f60
--- /dev/null
+++ b/textproc/topic/files/patch-linenoise.c
@@ -0,0 +1,11 @@
+--- linenoise.c.orig 2019-05-17 19:45:12 UTC
++++ linenoise.c
+@@ -749,7 +749,7 @@ static int linenoiseEdit(int stdin_fd, int stdout_fd,
+
+ if (write(l.ofd,prompt,l.plen) == -1) return -1;
+ while(1) {
+- char c;
++ signed char c;
+ int nread;
+ char seq[3];
+