aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-09-07 05:11:02 +0800
committermiwi <miwi@FreeBSD.org>2008-09-07 05:11:02 +0800
commit376ffbdd29c5f244d14d0a0462e79f06cd038df5 (patch)
treeeca74a2fb2ce9e5da12094094b5f772ca8507515 /textproc
parente7f3526572d69b92f2362b28f7a4ff5e64e5f853 (diff)
downloadfreebsd-ports-gnome-376ffbdd29c5f244d14d0a0462e79f06cd038df5.tar.gz
freebsd-ports-gnome-376ffbdd29c5f244d14d0a0462e79f06cd038df5.tar.zst
freebsd-ports-gnome-376ffbdd29c5f244d14d0a0462e79f06cd038df5.zip
- Added option to install contrib JARs with the port.
PR: 127147 Submitted by: Gerrit Beine <gerrit.beine@gmx.de> (maintainer)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/lucene/Makefile34
1 files changed, 32 insertions, 2 deletions
diff --git a/textproc/lucene/Makefile b/textproc/lucene/Makefile
index 7ef2bfcc558b..8a4ad20fdb2b 100644
--- a/textproc/lucene/Makefile
+++ b/textproc/lucene/Makefile
@@ -6,7 +6,7 @@
PORTNAME= lucene
PORTVERSION= 2.3.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc java devel
MASTER_SITES= ${MASTER_SITE_APACHE:S,%SUBDIR%,lucene/java,}
DISTNAME= lucene-${PORTVERSION}
@@ -18,12 +18,37 @@ NO_BUILD= yes
USE_JAVA= yes
JAVA_VERSION= 1.5+
-OPTIONS= DOCS "Install docs & examples" on
+OPTIONS= DOCS "Install docs & examples" on \
+ CONTRIB "Install contribs" off
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}-core-${PORTVERSION}.jar
+CONTRIBS= analyzers \
+ ant \
+ benchmark \
+ highlighter \
+ lucli \
+ memory \
+ misc \
+ queries \
+ regex \
+ similarity \
+ snowball \
+ spellchecker \
+ surround \
+ swing \
+ wikipedia \
+ wordnet \
+ xml-query-parser
+
.include <bsd.port.pre.mk>
+.if defined(WITH_CONTRIB)
+.for f in ${CONTRIBS}
+PLIST_FILES+=%%JAVAJARDIR%%/${PORTNAME}-${f}-${PORTVERSION}.jar
+.endfor
+.endif
+
.if defined(WITHOUT_DOCS) || !defined(WITH_DOCS)
NOPORTDOCS= yes
.endif
@@ -36,6 +61,11 @@ DEMODIR= src/demo/org/apache/lucene/demo
do-install:
@${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-core-${PORTVERSION}.jar ${JAVAJARDIR}
+.if defined(WITH_CONTRIB)
+ @${INSTALL_DATA} \
+ ${CONTRIBS:C,^(.*$,${WRKSRC}/contrib/\1/${PORTNAME}-\1-${PORTVERSION}.jar,} \
+ ${JAVADIR}
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/CHANGES.txt ${DOCSDIR}