aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2002-11-24 18:44:25 +0800
committeredwin <edwin@FreeBSD.org>2002-11-24 18:44:25 +0800
commit38cf2ed59e249b48f632ff19865ebaddb79c1c48 (patch)
tree681203b12e1c8d11f34af1ae6fbabfba65955970 /textproc
parentf585e67d742131b23fac86e66d28b2b4aeb098a1 (diff)
downloadfreebsd-ports-gnome-38cf2ed59e249b48f632ff19865ebaddb79c1c48.tar.gz
freebsd-ports-gnome-38cf2ed59e249b48f632ff19865ebaddb79c1c48.tar.zst
freebsd-ports-gnome-38cf2ed59e249b48f632ff19865ebaddb79c1c48.zip
New port: textproc/whitespace.el
Whitespace.el is an emacs mode which detects and cleans up whitespace in source code. PR: ports/44998 Submitted by: Volker Stolz <vs@foldr.org>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/whitespace.el/Makefile32
-rw-r--r--textproc/whitespace.el/distinfo1
-rw-r--r--textproc/whitespace.el/pkg-comment1
-rw-r--r--textproc/whitespace.el/pkg-descr4
-rw-r--r--textproc/whitespace.el/pkg-plist6
6 files changed, 45 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 820ad56cc9ad..468aa5aa87be 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -376,6 +376,7 @@
SUBDIR += unrtf
SUBDIR += urlview
SUBDIR += wdiff
+ SUBDIR += whitespace.el
SUBDIR += word2x
SUBDIR += wordnet
SUBDIR += wv
diff --git a/textproc/whitespace.el/Makefile b/textproc/whitespace.el/Makefile
new file mode 100644
index 000000000000..49e99e732131
--- /dev/null
+++ b/textproc/whitespace.el/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: whitespace.el
+# Date created: 6 November 2002
+# Whom: Volker Stolz <stolz@i2.informatik.rwth-aachen.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= whitespace.el
+PORTVERSION= 3.0
+CATEGORIES= textproc elisp
+MASTER_SITES= http://www.dsmit.com/lisp/
+DISTNAME= whitespace.el
+EXTRACT_SUFX=
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= stolz@i2.informatik.rwth-aachen.de
+
+EXTRACT_AFTER_ARGS= | ${CAT} >${WRKDIR}/${DISTNAME}
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
+XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
+
+do-install:
+ ${MKDIR} ${EMACSLISPDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME} ${EMACSLISPDIR}/${DISTNAME}
+ ${MKDIR} ${XEMACSLISPDIR}
+ ${LN} -sf ${EMACSLISPDIR}/${DISTNAME} ${XEMACSLISPDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/whitespace.el/distinfo b/textproc/whitespace.el/distinfo
new file mode 100644
index 000000000000..fc1de62bce6b
--- /dev/null
+++ b/textproc/whitespace.el/distinfo
@@ -0,0 +1 @@
+MD5 (whitespace.el-3.0/whitespace.el) = 67a65f5c8cfd68628ae503e43666d1fd
diff --git a/textproc/whitespace.el/pkg-comment b/textproc/whitespace.el/pkg-comment
new file mode 100644
index 000000000000..ea3a0aae3e13
--- /dev/null
+++ b/textproc/whitespace.el/pkg-comment
@@ -0,0 +1 @@
+Emacs mode which detects and cleans up whitespace in source code
diff --git a/textproc/whitespace.el/pkg-descr b/textproc/whitespace.el/pkg-descr
new file mode 100644
index 000000000000..c30fc06468c5
--- /dev/null
+++ b/textproc/whitespace.el/pkg-descr
@@ -0,0 +1,4 @@
+Whitespace.el is an emacs mode which detects and cleans up
+whitespace in source code.
+
+WWW: http://www.dsmit.com/lisp/
diff --git a/textproc/whitespace.el/pkg-plist b/textproc/whitespace.el/pkg-plist
new file mode 100644
index 000000000000..0c751852c140
--- /dev/null
+++ b/textproc/whitespace.el/pkg-plist
@@ -0,0 +1,6 @@
+share/emacs/site-lisp/whitespace.el
+@exec mkdir -p %D/lib/xemacs/site-lisp
+@exec ln -sf %D/%F %D/lib/xemacs/site-lisp/whitespace.el
+@unexec rm %D/lib/xemacs/site-lisp/whitespace.el
+@dirrm lib/xemacs/site-lisp
+@dirrm lib/xemacs