aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-08-04 22:15:29 +0800
committerpawel <pawel@FreeBSD.org>2014-08-04 22:15:29 +0800
commit3f4cc3a83d290207061561a9a4e6fa5f8c580b4e (patch)
tree62748585620b931e56671e395ebbb59ab960a217 /textproc
parent2002f477b20c54aab9fbe2b42adc8558c65222d1 (diff)
downloadfreebsd-ports-gnome-3f4cc3a83d290207061561a9a4e6fa5f8c580b4e.tar.gz
freebsd-ports-gnome-3f4cc3a83d290207061561a9a4e6fa5f8c580b4e.tar.zst
freebsd-ports-gnome-3f4cc3a83d290207061561a9a4e6fa5f8c580b4e.zip
- Add staging support
- Convert to new options framework
Diffstat (limited to 'textproc')
-rw-r--r--textproc/prosper/Makefile53
1 files changed, 20 insertions, 33 deletions
diff --git a/textproc/prosper/Makefile b/textproc/prosper/Makefile
index 493e390bf150..c83b398294ec 100644
--- a/textproc/prosper/Makefile
+++ b/textproc/prosper/Makefile
@@ -33,44 +33,31 @@ DOCS= AUTHORS ChangeLog FAQ INSTALL NEWS README TODO \
doc/prosper-structure.eps doc/prosper-structure.fig \
doc/prosper-tour.pdf doc/prosper-tour.ps doc/prosper-tour.tex \
doc/rotation.ps doc/rotation.tex
-EXAMPLES_DIR= doc/doc-examples
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
post-extract:
@(cd ${WRKDIR}/contrib-prosper-1.0.0 && ${FIND} . | \
${CPIO} --quiet -dump ${WRKSRC}/contrib)
do-install:
- @${MKDIR} ${PROSPERDIR}/contrib/img
- @${MKDIR} ${PROSPERDIR}/designer
- @${MKDIR} ${PROSPERDIR}/img
- ${INSTALL_DATA} ${WRKSRC}/*.sty ${PROSPERDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.cls ${PROSPERDIR}
- ${INSTALL_DATA} ${WRKSRC}/img/*.gif ${PROSPERDIR}/img
- ${INSTALL_DATA} ${WRKSRC}/img/*.ps ${PROSPERDIR}/img
- ${INSTALL_DATA} ${WRKSRC}/contrib/*.sty ${PROSPERDIR}/contrib
- ${INSTALL_DATA} ${WRKSRC}/contrib/*.ps ${PROSPERDIR}/contrib
- ${INSTALL_DATA} ${WRKSRC}/contrib/*.tex ${PROSPERDIR}/contrib
- ${INSTALL_DATA} ${WRKSRC}/contrib/img/*.ps ${PROSPERDIR}/contrib/img
- ${INSTALL_DATA} ${WRKSRC}/contrib/img/*.eps ${PROSPERDIR}/contrib/img
- ${INSTALL_DATA} ${WRKSRC}/contrib/img/*.gif ${PROSPERDIR}/contrib/img
- ${INSTALL_DATA} ${WRKSRC}/designer/prosper* ${PROSPERDIR}/designer
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
-.endfor
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
-.for FILE in ${EXAMPLES_DIR}/Example*
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${EXAMPLESDIR}
-.endfor
- @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
-.endif
-
-post-install:
- ${MKTEXLSR}
+ @${MKDIR} ${STAGEDIR}${PROSPERDIR}/contrib/img
+ @${MKDIR} ${STAGEDIR}${PROSPERDIR}/designer
+ @${MKDIR} ${STAGEDIR}${PROSPERDIR}/img
+ ${INSTALL_DATA} ${WRKSRC}/*.sty ${STAGEDIR}${PROSPERDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.cls ${STAGEDIR}${PROSPERDIR}
+ ${INSTALL_DATA} ${WRKSRC}/img/*.gif ${STAGEDIR}${PROSPERDIR}/img
+ ${INSTALL_DATA} ${WRKSRC}/img/*.ps ${STAGEDIR}${PROSPERDIR}/img
+ (cd ${WRKSRC}/contrib && ${INSTALL_DATA} *.sty *.ps *.tex \
+ ${STAGEDIR}${PROSPERDIR}/contrib)
+ (cd ${WRKSRC}/contrib/img && ${INSTALL_DATA} *.ps *.eps *.gif \
+ ${STAGEDIR}${PROSPERDIR}/contrib/img)
+ ${INSTALL_DATA} ${WRKSRC}/designer/prosper* \
+ ${STAGEDIR}${PROSPERDIR}/designer
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/doc-examples/Example* \
+ ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>