aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-12-05 13:18:51 +0800
committerjbeich <jbeich@FreeBSD.org>2018-12-05 13:18:51 +0800
commit4199dc5c71d6c111e24ea0c10f4e47c94b39a21c (patch)
treeb88eaf7598acfb33a841431c921a107f5afc0e3a /textproc
parentcd0ee3a1391f336c00a0613c77f409bbd8bc527e (diff)
downloadfreebsd-ports-gnome-4199dc5c71d6c111e24ea0c10f4e47c94b39a21c.tar.gz
freebsd-ports-gnome-4199dc5c71d6c111e24ea0c10f4e47c94b39a21c.tar.zst
freebsd-ports-gnome-4199dc5c71d6c111e24ea0c10f4e47c94b39a21c.zip
textproc/ripgrep: unbreak AVX=on on i386 after r454995
error[E0432]: unresolved import `simd::x86::avx` --> cargo-crates/bytecount-0.3.2/src/lib.rs:49:16 | 49 | use simd::x86::avx::{LowHigh128, u8x32}; | ^^^ could not find `avx` in `x86` https://github.com/rust-lang/rust/issues/56527
Diffstat (limited to 'textproc')
-rw-r--r--textproc/ripgrep/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/textproc/ripgrep/Makefile b/textproc/ripgrep/Makefile
index ded966af5fea..101c2f71b212 100644
--- a/textproc/ripgrep/Makefile
+++ b/textproc/ripgrep/Makefile
@@ -133,7 +133,7 @@ PCRE2_VARS= CARGO_FEATURES+=pcre2
# unstable features similar to how lang/rust bootstraps. www/firefox
# uses the same hack when building with --enable-rust-simd.
SIMD_MAKE_ENV= RUSTC_BOOTSTRAP=1
-SIMD_VARS= CARGO_FEATURES+=simd-accel ${SIMD_VARS_${ARCH}}
+SIMD_VARS= CARGO_FEATURES+=simd-accel ${SIMD_VARS_${ARCH}${PORT_OPTIONS:MAVX}}
SIMD_VARS_i386= RUSTFLAGS+="-C target-feature=+sse2"
post-patch: