aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-15 12:50:30 +0800
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-15 12:50:30 +0800
commit421ec9fe7cbe8362f58334c866002e3e3e3283c0 (patch)
tree8b6c411d3bf5ce3a56cbb8c406c57422a9e7a8e3 /textproc
parent7370fc0160c45395f1aa1b65983a8797c2471330 (diff)
downloadfreebsd-ports-gnome-421ec9fe7cbe8362f58334c866002e3e3e3283c0.tar.gz
freebsd-ports-gnome-421ec9fe7cbe8362f58334c866002e3e3e3283c0.tar.zst
freebsd-ports-gnome-421ec9fe7cbe8362f58334c866002e3e3e3283c0.zip
New port: textproc/py-pdfminer3k: PDF parser and analyzer
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-pdfminer3k/Makefile21
-rw-r--r--textproc/py-pdfminer3k/distinfo3
-rw-r--r--textproc/py-pdfminer3k/pkg-descr9
4 files changed, 34 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 56347ba6a3b9..a0c8bb57111b 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1341,6 +1341,7 @@
SUBDIR += py-parsimonious
SUBDIR += py-parso
SUBDIR += py-pdfminer
+ SUBDIR += py-pdfminer3k
SUBDIR += py-pss
SUBDIR += py-pyPEG2
SUBDIR += py-pyctpp2
diff --git a/textproc/py-pdfminer3k/Makefile b/textproc/py-pdfminer3k/Makefile
new file mode 100644
index 000000000000..67b923f5dee1
--- /dev/null
+++ b/textproc/py-pdfminer3k/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= pdfminer3k
+PORTVERSION= 1.2.4
+CATEGORIES= textproc python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= PDF parser and analyzer
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ply>=3.4:devel/py-ply@${FLAVOR}
+
+USES= python:3.4+
+USE_GITHUB= yes
+GH_ACCOUNT= jaepil
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-pdfminer3k/distinfo b/textproc/py-pdfminer3k/distinfo
new file mode 100644
index 000000000000..e984afe16013
--- /dev/null
+++ b/textproc/py-pdfminer3k/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529037782
+SHA256 (jaepil-pdfminer3k-1.2.4_GH0.tar.gz) = d7c7eec5e9bb24896f1083c30b664b9d518baa727c20ce3aac42e8919c422998
+SIZE (jaepil-pdfminer3k-1.2.4_GH0.tar.gz) = 4168182
diff --git a/textproc/py-pdfminer3k/pkg-descr b/textproc/py-pdfminer3k/pkg-descr
new file mode 100644
index 000000000000..92994214055e
--- /dev/null
+++ b/textproc/py-pdfminer3k/pkg-descr
@@ -0,0 +1,9 @@
+pdfminer3k is a Python 3 port of pdfminer. PDFMiner is a tool for extracting
+information from PDF documents. Unlike other PDF-related tools, it focuses
+entirely on getting and analyzing text data. PDFMiner allows to obtain the exact
+location of texts in a page, as well as other information such as fonts or
+lines. It includes a PDF converter that can transform PDF files into other
+text formats (such as HTML). It has an extensible PDF parser that can be used
+for other purposes instead of text analysis.
+
+WWW: https://github.com/jaepil/pdfminer3k