aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-10-30 03:01:59 +0800
committerkwm <kwm@FreeBSD.org>2011-10-30 03:01:59 +0800
commit4428d4a2870a19fd2d2ecddc3813ddf5d81dafcd (patch)
treebd8a2088309288e74fbee65780d40df31928a708 /textproc
parentd970f7fbce8eafa6dc8776cd613101977376fa42 (diff)
downloadfreebsd-ports-gnome-4428d4a2870a19fd2d2ecddc3813ddf5d81dafcd.tar.gz
freebsd-ports-gnome-4428d4a2870a19fd2d2ecddc3813ddf5d81dafcd.tar.zst
freebsd-ports-gnome-4428d4a2870a19fd2d2ecddc3813ddf5d81dafcd.zip
Fix build with FreeBSD 10
Approved by: portmgr (miwi)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/augeas/Makefile1
-rw-r--r--textproc/hunspell/Makefile5
-rw-r--r--textproc/libnxml/Makefile1
-rw-r--r--textproc/opensp/Makefile1
4 files changed, 8 insertions, 0 deletions
diff --git a/textproc/augeas/Makefile b/textproc/augeas/Makefile
index 9ad2f4bd0d41..202d443c1e26 100644
--- a/textproc/augeas/Makefile
+++ b/textproc/augeas/Makefile
@@ -21,6 +21,7 @@ USE_AUTOTOOLS= autoconf aclocal autoheader automake libtool
ACLOCAL_ARGS= -I . -I gnulib/m4 -I ${LOCALBASE}/share/aclocal
AUTOMAKE_ARGS= --add-missing
USE_LDCONFIG= yes
+WITH_FBSD10_FIX=yes
MAN1= augparse.1 augtool.1
MANCOMPRESSED= no
diff --git a/textproc/hunspell/Makefile b/textproc/hunspell/Makefile
index ee9bb141718f..51ed89ceb036 100644
--- a/textproc/hunspell/Makefile
+++ b/textproc/hunspell/Makefile
@@ -18,6 +18,7 @@ LICENSE_COMB= dual
CONFIGURE_ARGS= --disable-nls --with-readline --with-ui
GNU_CONFIGURE= yes
+WITH_FBSD10_FIX=yes
MAKE_JOBS_SAFE= yes
USE_GNOME= gnomehack
USE_LDCONFIG= yes
@@ -33,4 +34,8 @@ MAN4_HU= hunspell.4
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/src/tools/hunspell.cxx
+pre-build:
+ @${TOUCH} ${WRKSRC}/aclocal.m4 ${WRKSRC}/Makefile.in \
+ ${WKRSRC}/configure ${WRKSRC}/config.h.in
+
.include <bsd.port.mk>
diff --git a/textproc/libnxml/Makefile b/textproc/libnxml/Makefile
index 61a963f0e5e2..92d4174092c6 100644
--- a/textproc/libnxml/Makefile
+++ b/textproc/libnxml/Makefile
@@ -18,6 +18,7 @@ COMMENT= A C library for writing XML 1.0/1.1 files or streams
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
GNU_CONFIGURE= yes
+WITH_FBSD10_FIX=yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/textproc/opensp/Makefile b/textproc/opensp/Makefile
index 118e9064595f..d269c0becd6e 100644
--- a/textproc/opensp/Makefile
+++ b/textproc/opensp/Makefile
@@ -18,6 +18,7 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
+WITH_FBSD10_FIX=yes
USE_PERL5= yes
CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog \
--datadir=${PREFIX}/share/sgml/openjade \