aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2017-10-21 04:16:57 +0800
committerbsam <bsam@FreeBSD.org>2017-10-21 04:16:57 +0800
commit444c93ff56aac0cd4bb2f00c633f5964feb6eaa5 (patch)
tree45dd2e17f3d027e2295be9ee5da826c613a28189 /textproc
parent94b986e7b6cfd81b98df8d4a3b82643ac9145fc0 (diff)
downloadfreebsd-ports-gnome-444c93ff56aac0cd4bb2f00c633f5964feb6eaa5.tar.gz
freebsd-ports-gnome-444c93ff56aac0cd4bb2f00c633f5964feb6eaa5.tar.zst
freebsd-ports-gnome-444c93ff56aac0cd4bb2f00c633f5964feb6eaa5.zip
textproc/goldendict: Fix iconv wchar_t initialization error.
From the original e-mail: Goldendict still uses internal libiconv and can't to load dictionaries that require use of iconv with WCHAR_T producing "Can't initialize iconv conversion: Invalid argument". The patch based on the example 6.17 of porter's handbook solves the problem. Submitted by: Art Kamog <ia.kamog@yandex.ru> (via e-mail)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/goldendict/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/textproc/goldendict/Makefile b/textproc/goldendict/Makefile
index a4c7ab0ee157..29387d8e957e 100644
--- a/textproc/goldendict/Makefile
+++ b/textproc/goldendict/Makefile
@@ -3,7 +3,7 @@
PORTNAME= goldendict
PORTVERSION= 1.0.1
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= textproc
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:C|(.*)\.[0-9]*$|\1|}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -17,11 +17,12 @@ LIB_DEPENDS= libhunspell-1.6.so:textproc/hunspell \
libvorbis.so:audio/libvorbis
NO_WRKSUBDIR= yes
-USES= dos2unix iconv pkgconfig qmake tar:bzip2
+USES= dos2unix iconv:wchar_t pkgconfig qmake tar:bzip2
DOS2UNIX_FILES= processwrapper.cc
USE_XORG= xtst
USE_QT4= corelib gui webkit phonon \
linguist_build moc_build rcc_build script_build uic_build
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
INSTALLS_ICONS= yes
post-patch: