aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-07-05 01:46:12 +0800
committerswills <swills@FreeBSD.org>2011-07-05 01:46:12 +0800
commit4590f93703cffdb21144e0bcdffee1e318b6b5d1 (patch)
tree12128d966c4353f14b667aef4bca4d4f66061324 /textproc
parentecff26c2f706f755a5e964a3cac1953e282e07f0 (diff)
downloadfreebsd-ports-gnome-4590f93703cffdb21144e0bcdffee1e318b6b5d1.tar.gz
freebsd-ports-gnome-4590f93703cffdb21144e0bcdffee1e318b6b5d1.tar.zst
freebsd-ports-gnome-4590f93703cffdb21144e0bcdffee1e318b6b5d1.zip
- Mark as broken with Ruby 1.9
Approved by: portmgr
Diffstat (limited to 'textproc')
-rw-r--r--textproc/eruby/Makefile2
-rw-r--r--textproc/ruby-erbscan/Makefile6
-rw-r--r--textproc/ruby-rd-mode.el/Makefile6
-rw-r--r--textproc/ruby-sablot/Makefile6
-rw-r--r--textproc/ruby-xslt/Makefile6
-rw-r--r--textproc/rubygem-htmltools/Makefile6
6 files changed, 23 insertions, 9 deletions
diff --git a/textproc/eruby/Makefile b/textproc/eruby/Makefile
index 0cd8d2de96f6..4feff21e9719 100644
--- a/textproc/eruby/Makefile
+++ b/textproc/eruby/Makefile
@@ -62,7 +62,7 @@ CONFIGURE_ENV+= EXTRA_LDFLAGS="${EXTRA_LDFLAGS} -pthread"
.endif
.endif
-.if ${RUBY_RELVERSION} == 1.9.1
+.if ${RUBY_RELVERSION} == 1.9.2
CONFIGURE_ENV+= EXTRA_CFLAGS="${EXTRA_CFLAGS} -DWITH_RUBY_19"
.endif
diff --git a/textproc/ruby-erbscan/Makefile b/textproc/ruby-erbscan/Makefile
index 14bc554a4676..66975ad437e2 100644
--- a/textproc/ruby-erbscan/Makefile
+++ b/textproc/ruby-erbscan/Makefile
@@ -20,12 +20,10 @@ USE_RUBY_EXTCONF= yes
INSTALL_TARGET= site-install
-RUBY_REQUIRE= Ruby > 180
-
.include <bsd.port.pre.mk>
-.if !defined(RUBY_PROVIDED)
-IGNORE= only works with Ruby 1.8.0 or later
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
.endif
post-patch:
diff --git a/textproc/ruby-rd-mode.el/Makefile b/textproc/ruby-rd-mode.el/Makefile
index fab31b9310ca..00c2e8311c25 100644
--- a/textproc/ruby-rd-mode.el/Makefile
+++ b/textproc/ruby-rd-mode.el/Makefile
@@ -40,4 +40,8 @@ do-install:
.endfor
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/textproc/ruby-sablot/Makefile b/textproc/ruby-sablot/Makefile
index c61ef7e0651b..6c1036397e8d 100644
--- a/textproc/ruby-sablot/Makefile
+++ b/textproc/ruby-sablot/Makefile
@@ -47,4 +47,8 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/textproc/ruby-xslt/Makefile b/textproc/ruby-xslt/Makefile
index 1e34ecf5b3ba..8f88476f0c5b 100644
--- a/textproc/ruby-xslt/Makefile
+++ b/textproc/ruby-xslt/Makefile
@@ -28,4 +28,8 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${RUBY_MODDOCDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/textproc/rubygem-htmltools/Makefile b/textproc/rubygem-htmltools/Makefile
index b9254804eecb..5a16c04667cf 100644
--- a/textproc/rubygem-htmltools/Makefile
+++ b/textproc/rubygem-htmltools/Makefile
@@ -17,4 +17,8 @@ USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not build with ruby 1.9
+.endif
+.include <bsd.port.post.mk>