aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2017-05-23 16:29:17 +0800
committerkwm <kwm@FreeBSD.org>2017-05-23 16:29:17 +0800
commit4811963160ca57bb0433a7e7d4db943444243557 (patch)
tree50dee1fe93d80cbaca2c602c902328bcbd950f58 /textproc
parentdafc768c061dcce83b0e14f402bee3af62556a9e (diff)
downloadfreebsd-ports-gnome-4811963160ca57bb0433a7e7d4db943444243557.tar.gz
freebsd-ports-gnome-4811963160ca57bb0433a7e7d4db943444243557.tar.zst
freebsd-ports-gnome-4811963160ca57bb0433a7e7d4db943444243557.zip
Update highlight to 3.36.
Regen patches with make makepatch
Diffstat (limited to 'textproc')
-rw-r--r--textproc/highlight/Makefile9
-rw-r--r--textproc/highlight/distinfo6
-rw-r--r--textproc/highlight/files/patch-makefile8
-rw-r--r--textproc/highlight/files/patch-src_makefile18
-rw-r--r--textproc/highlight/pkg-plist22
5 files changed, 42 insertions, 21 deletions
diff --git a/textproc/highlight/Makefile b/textproc/highlight/Makefile
index 7d40b18a8fdd..fba1a55d71c6 100644
--- a/textproc/highlight/Makefile
+++ b/textproc/highlight/Makefile
@@ -1,10 +1,8 @@
# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-# 3.29+ needs to_string() which gcc48 (for 9.3-R) doesn't provide
PORTNAME= highlight
-PORTVERSION= 3.29
-PORTREVISION= 4
+PORTVERSION= 3.36
PORTEPOCH= 3
CATEGORIES= textproc
MASTER_SITES= http://www.andre-simon.de/zip/
@@ -12,9 +10,12 @@ MASTER_SITES= http://www.andre-simon.de/zip/
MAINTAINER= kwm@FreeBSD.org
COMMENT= Customizable syntax highlighter
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= boost-libs>0:devel/boost-libs
-USES= compiler:c++11-lib dos2unix gmake lua:52 pkgconfig tar:bzip2
+USES= compiler:c++11-lib gmake lua:52 pkgconfig tar:bzip2
USE_CXXSTD= c++11
MAKEFILE= makefile
MAKE_ARGS= CXX="${CXX}" \
diff --git a/textproc/highlight/distinfo b/textproc/highlight/distinfo
index c74ed41641dd..38f14f43d208 100644
--- a/textproc/highlight/distinfo
+++ b/textproc/highlight/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1472157593
-SHA256 (highlight-3.29.tar.bz2) = 76cc769d98778985235c0b7d1345cff78c99f597b51edd4e9be7d3fc0160bf92
-SIZE (highlight-3.29.tar.bz2) = 670624
+TIMESTAMP = 1495523172
+SHA256 (highlight-3.36.tar.bz2) = 34cd5bcf52714f83364460c0c3551320564c56ff4e117353034e532275792171
+SIZE (highlight-3.36.tar.bz2) = 1221219
diff --git a/textproc/highlight/files/patch-makefile b/textproc/highlight/files/patch-makefile
index be3e9c3541cc..4f8f21d3d645 100644
--- a/textproc/highlight/files/patch-makefile
+++ b/textproc/highlight/files/patch-makefile
@@ -1,5 +1,5 @@
---- makefile.orig 2014-04-25 16:45:48.000000000 +0200
-+++ makefile 2014-04-25 16:46:45.000000000 +0200
+--- makefile.orig 2017-03-30 18:12:23 UTC
++++ makefile
@@ -4,10 +4,10 @@
# Installation directories:
@@ -13,7 +13,7 @@
# Location of the highlight data files:
data_dir = ${PREFIX}/share/highlight/
-@@ -16,7 +16,7 @@
+@@ -16,7 +16,7 @@ data_dir = ${PREFIX}/share/highlight/
bin_dir = ${PREFIX}/bin/
# Location of the highlight man page:
@@ -22,7 +22,7 @@
# Location of the highlight documentation:
doc_dir = ${PREFIX}/share/doc/highlight/
-@@ -25,8 +25,8 @@
+@@ -25,8 +25,8 @@ doc_dir = ${PREFIX}/share/doc/highlight/
examples_dir = ${doc_dir}examples/
# Location of the highlight config files:
diff --git a/textproc/highlight/files/patch-src_makefile b/textproc/highlight/files/patch-src_makefile
index 3e5e726211d9..5fb4ede3554d 100644
--- a/textproc/highlight/files/patch-src_makefile
+++ b/textproc/highlight/files/patch-src_makefile
@@ -1,15 +1,15 @@
---- src/makefile.orig 2015-07-02 16:51:26.582456000 +0200
-+++ src/makefile 2015-07-02 16:51:53.706070000 +0200
-@@ -12,7 +12,7 @@
-
+--- src/makefile.orig 2017-03-30 18:12:23 UTC
++++ src/makefile
+@@ -13,7 +13,7 @@
# See src/gui-qt/highlight.pro for the Qt GUI compilation options
--CXX=c++
+ #CXX=clang++
+-CXX=g++
+CXX?=c++
- # Added -qt4 because of Arch Linux Qt5 migration
- QMAKE=qmake-qt4
-@@ -37,10 +37,10 @@
+ # was: qmake-qt5
+ QMAKE=qmake
+@@ -39,10 +39,10 @@ INCLUDE_DIR=./include/
# If Lua 5.2 is not default on your system yet you have to
# use lua5.1 in the pkg-config calls
@@ -22,7 +22,7 @@
# luajit lib
# LUA_LIBS=$(shell pkg-config --libs luajit)
-@@ -67,7 +67,7 @@
+@@ -73,7 +73,7 @@ LDFLAGS = -ldl
#LDFLAGS = ${LDFLAGS} -s
#LDFLAGS= -Wl,--as-needed
diff --git a/textproc/highlight/pkg-plist b/textproc/highlight/pkg-plist
index 8705e7d1dbb9..6579941dc69e 100644
--- a/textproc/highlight/pkg-plist
+++ b/textproc/highlight/pkg-plist
@@ -37,15 +37,18 @@ man/man1/highlight.1.gz
%%DATADIR%%/langDefs/ceylon.lang
%%DATADIR%%/langDefs/charmm.lang
%%DATADIR%%/langDefs/chill.lang
+%%DATADIR%%/langDefs/chpl.lang
%%DATADIR%%/langDefs/clean.lang
%%DATADIR%%/langDefs/clearbasic.lang
%%DATADIR%%/langDefs/clipper.lang
%%DATADIR%%/langDefs/clojure.lang
%%DATADIR%%/langDefs/clp.lang
%%DATADIR%%/langDefs/cobol.lang
+%%DATADIR%%/langDefs/coffee.lang
%%DATADIR%%/langDefs/coldfusion.lang
%%DATADIR%%/langDefs/conf.lang
%%DATADIR%%/langDefs/crk.lang
+%%DATADIR%%/langDefs/cs_block_regex.lang
%%DATADIR%%/langDefs/csharp.lang
%%DATADIR%%/langDefs/css.lang
%%DATADIR%%/langDefs/d.lang
@@ -59,6 +62,7 @@ man/man1/highlight.1.gz
%%DATADIR%%/langDefs/euphoria.lang
%%DATADIR%%/langDefs/express.lang
%%DATADIR%%/langDefs/fame.lang
+%%DATADIR%%/langDefs/fasm.lang
%%DATADIR%%/langDefs/felix.lang
%%DATADIR%%/langDefs/fortran77.lang
%%DATADIR%%/langDefs/fortran90.lang
@@ -67,6 +71,7 @@ man/man1/highlight.1.gz
%%DATADIR%%/langDefs/fx.lang
%%DATADIR%%/langDefs/gambas.lang
%%DATADIR%%/langDefs/gdb.lang
+%%DATADIR%%/langDefs/gdscript.lang
%%DATADIR%%/langDefs/go.lang
%%DATADIR%%/langDefs/graphviz.lang
%%DATADIR%%/langDefs/haskell.lang
@@ -86,8 +91,10 @@ man/man1/highlight.1.gz
%%DATADIR%%/langDefs/jasmin.lang
%%DATADIR%%/langDefs/java.lang
%%DATADIR%%/langDefs/js.lang
+%%DATADIR%%/langDefs/js_regex.lang
%%DATADIR%%/langDefs/json.lang
%%DATADIR%%/langDefs/jsp.lang
+%%DATADIR%%/langDefs/jsx.lang
%%DATADIR%%/langDefs/julia.lang
%%DATADIR%%/langDefs/kotlin.lang
%%DATADIR%%/langDefs/ldif.lang
@@ -144,6 +151,8 @@ man/man1/highlight.1.gz
%%DATADIR%%/langDefs/plperl.lang
%%DATADIR%%/langDefs/plpython.lang
%%DATADIR%%/langDefs/pltcl.lang
+%%DATADIR%%/langDefs/po.lang
+%%DATADIR%%/langDefs/pony.lang
%%DATADIR%%/langDefs/pov.lang
%%DATADIR%%/langDefs/pro.lang
%%DATADIR%%/langDefs/progress.lang
@@ -151,6 +160,7 @@ man/man1/highlight.1.gz
%%DATADIR%%/langDefs/ps1.lang
%%DATADIR%%/langDefs/psl.lang
%%DATADIR%%/langDefs/pure.lang
+%%DATADIR%%/langDefs/purebasic.lang
%%DATADIR%%/langDefs/pyrex.lang
%%DATADIR%%/langDefs/python.lang
%%DATADIR%%/langDefs/q.lang
@@ -196,14 +206,16 @@ man/man1/highlight.1.gz
%%DATADIR%%/langDefs/vb.lang
%%DATADIR%%/langDefs/verilog.lang
%%DATADIR%%/langDefs/vhd.lang
+%%DATADIR%%/langDefs/vimscript.lang
+%%DATADIR%%/langDefs/whiley.lang
%%DATADIR%%/langDefs/xml.lang
%%DATADIR%%/langDefs/xpp.lang
%%DATADIR%%/langDefs/yaiff.lang
+%%DATADIR%%/langDefs/yaml.lang
%%DATADIR%%/langDefs/yang.lang
%%DATADIR%%/langDefs/znn.lang
%%DATADIR%%/plugins/asciidoc_html_add_links.lua
%%DATADIR%%/plugins/bash_functions.lua
-%%DATADIR%%/plugins/bash_ref_linuxmanpages_com.lua
%%DATADIR%%/plugins/comment_links.lua
%%DATADIR%%/plugins/cpp_qt.lua
%%DATADIR%%/plugins/cpp_ref_cplusplus_com.lua
@@ -221,10 +233,12 @@ man/man1/highlight.1.gz
%%DATADIR%%/plugins/mark_lines.lua
%%DATADIR%%/plugins/outhtml_add_background_stripes.lua
%%DATADIR%%/plugins/outhtml_add_background_svg.lua
+%%DATADIR%%/plugins/outhtml_add_figure.lua
%%DATADIR%%/plugins/outhtml_add_line.lua
%%DATADIR%%/plugins/outhtml_add_shadow.lua
%%DATADIR%%/plugins/outhtml_codefold.lua
%%DATADIR%%/plugins/outhtml_curly_brackets_matcher.lua
+%%DATADIR%%/plugins/outhtml_ie7_webctrl.lua
%%DATADIR%%/plugins/outhtml_keyword_matcher.lua
%%DATADIR%%/plugins/outhtml_modern_fonts.lua
%%DATADIR%%/plugins/outhtml_parantheses_matcher.lua
@@ -262,15 +276,19 @@ man/man1/highlight.1.gz
%%DATADIR%%/themes/earendel.theme
%%DATADIR%%/themes/easter.theme
%%DATADIR%%/themes/edit-anjuta.theme
+%%DATADIR%%/themes/edit-bbedit.theme
%%DATADIR%%/themes/edit-eclipse.theme
%%DATADIR%%/themes/edit-emacs.theme
+%%DATADIR%%/themes/edit-fasm.theme
%%DATADIR%%/themes/edit-flashdevelop.theme
%%DATADIR%%/themes/edit-gedit.theme
+%%DATADIR%%/themes/edit-godot.theme
%%DATADIR%%/themes/edit-jedit.theme
%%DATADIR%%/themes/edit-kwrite.theme
%%DATADIR%%/themes/edit-matlab.theme
%%DATADIR%%/themes/edit-msvs2008.theme
%%DATADIR%%/themes/edit-nedit.theme
+%%DATADIR%%/themes/edit-purebasic.theme
%%DATADIR%%/themes/edit-vim-dark.theme
%%DATADIR%%/themes/edit-vim.theme
%%DATADIR%%/themes/edit-xcode.theme
@@ -278,6 +296,7 @@ man/man1/highlight.1.gz
%%DATADIR%%/themes/fine_blue.theme
%%DATADIR%%/themes/freya.theme
%%DATADIR%%/themes/fruit.theme
+%%DATADIR%%/themes/github.theme
%%DATADIR%%/themes/golden.theme
%%DATADIR%%/themes/greenlcd.theme
%%DATADIR%%/themes/kellys.theme
@@ -308,6 +327,7 @@ man/man1/highlight.1.gz
%%DATADIR%%/themes/seashell.theme
%%DATADIR%%/themes/solarized-dark.theme
%%DATADIR%%/themes/solarized-light.theme
+%%DATADIR%%/themes/sourceforge.theme
%%DATADIR%%/themes/tabula.theme
%%DATADIR%%/themes/tcsoft.theme
%%DATADIR%%/themes/the.theme