aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortz <tz@FreeBSD.org>2018-07-24 16:44:32 +0800
committertz <tz@FreeBSD.org>2018-07-24 16:44:32 +0800
commit4827d6341c8195df448c86d232c0a643ba3aceaa (patch)
tree751612430d8a08dd5989d9992db1e4cabdd5ea9c /textproc
parent4494d7dc520498523a4d72377b421a7319f42162 (diff)
downloadfreebsd-ports-gnome-4827d6341c8195df448c86d232c0a643ba3aceaa.tar.gz
freebsd-ports-gnome-4827d6341c8195df448c86d232c0a643ba3aceaa.tar.zst
freebsd-ports-gnome-4827d6341c8195df448c86d232c0a643ba3aceaa.zip
PHP 7.1 and PHP 7.2: add TEST_TARGET to all extensions
This enables "make test" in every extension and eases the test of changes to PHP. I did ignore PHP 7.0 intentionally since it only receives security updates and will EOL at the end of the year. Therefore no great amount of work is expected for 7.0.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/php71-ctype/Makefile2
-rw-r--r--textproc/php71-dom/Makefile2
-rw-r--r--textproc/php71-enchant/Makefile2
-rw-r--r--textproc/php71-pspell/Makefile2
-rw-r--r--textproc/php71-simplexml/Makefile2
-rw-r--r--textproc/php71-wddx/Makefile2
-rw-r--r--textproc/php71-xml/Makefile2
-rw-r--r--textproc/php71-xmlreader/Makefile2
-rw-r--r--textproc/php71-xmlwriter/Makefile2
-rw-r--r--textproc/php71-xsl/Makefile2
-rw-r--r--textproc/php72-ctype/Makefile2
-rw-r--r--textproc/php72-dom/Makefile2
-rw-r--r--textproc/php72-enchant/Makefile2
-rw-r--r--textproc/php72-pspell/Makefile2
-rw-r--r--textproc/php72-simplexml/Makefile2
-rw-r--r--textproc/php72-wddx/Makefile2
-rw-r--r--textproc/php72-xml/Makefile2
-rw-r--r--textproc/php72-xmlreader/Makefile2
-rw-r--r--textproc/php72-xmlwriter/Makefile2
-rw-r--r--textproc/php72-xsl/Makefile2
20 files changed, 40 insertions, 0 deletions
diff --git a/textproc/php71-ctype/Makefile b/textproc/php71-ctype/Makefile
index e49199b94ce7..e5495e2dfcbc 100644
--- a/textproc/php71-ctype/Makefile
+++ b/textproc/php71-ctype/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -ctype
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-dom/Makefile b/textproc/php71-dom/Makefile
index dd695bee8d85..12b78c9dfda0 100644
--- a/textproc/php71-dom/Makefile
+++ b/textproc/php71-dom/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -dom
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-enchant/Makefile b/textproc/php71-enchant/Makefile
index 877eacc520c1..0adf665ba5ae 100644
--- a/textproc/php71-enchant/Makefile
+++ b/textproc/php71-enchant/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -enchant
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-pspell/Makefile b/textproc/php71-pspell/Makefile
index 88bbb59885b3..ed11ff89817b 100644
--- a/textproc/php71-pspell/Makefile
+++ b/textproc/php71-pspell/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -pspell
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-simplexml/Makefile b/textproc/php71-simplexml/Makefile
index de86001c09fc..804990e003c0 100644
--- a/textproc/php71-simplexml/Makefile
+++ b/textproc/php71-simplexml/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -simplexml
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-wddx/Makefile b/textproc/php71-wddx/Makefile
index 7243bf74e5ab..88878fd98c79 100644
--- a/textproc/php71-wddx/Makefile
+++ b/textproc/php71-wddx/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -wddx
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-xml/Makefile b/textproc/php71-xml/Makefile
index 703803a865bc..153a2760626a 100644
--- a/textproc/php71-xml/Makefile
+++ b/textproc/php71-xml/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -xml
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-xmlreader/Makefile b/textproc/php71-xmlreader/Makefile
index 087340030e85..8728ef004470 100644
--- a/textproc/php71-xmlreader/Makefile
+++ b/textproc/php71-xmlreader/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -xmlreader
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-xmlwriter/Makefile b/textproc/php71-xmlwriter/Makefile
index 4284c734aa90..f8ff86d144f0 100644
--- a/textproc/php71-xmlwriter/Makefile
+++ b/textproc/php71-xmlwriter/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -xmlwriter
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php71-xsl/Makefile b/textproc/php71-xsl/Makefile
index 00f0b650491f..2a2ad0760e0e 100644
--- a/textproc/php71-xsl/Makefile
+++ b/textproc/php71-xsl/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -xsl
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php72-ctype/Makefile b/textproc/php72-ctype/Makefile
index 7e0a6a41d4c3..2ce07d8ca2c9 100644
--- a/textproc/php72-ctype/Makefile
+++ b/textproc/php72-ctype/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -ctype
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php72-dom/Makefile b/textproc/php72-dom/Makefile
index 9490429213eb..8c51a4736470 100644
--- a/textproc/php72-dom/Makefile
+++ b/textproc/php72-dom/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -dom
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php72-enchant/Makefile b/textproc/php72-enchant/Makefile
index 2a5f23de3bcf..fe30e1377254 100644
--- a/textproc/php72-enchant/Makefile
+++ b/textproc/php72-enchant/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -enchant
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php72-pspell/Makefile b/textproc/php72-pspell/Makefile
index cb71c608908c..e1ed2ea52b22 100644
--- a/textproc/php72-pspell/Makefile
+++ b/textproc/php72-pspell/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -pspell
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php72-simplexml/Makefile b/textproc/php72-simplexml/Makefile
index 3a798f5e5b7c..e8836a183999 100644
--- a/textproc/php72-simplexml/Makefile
+++ b/textproc/php72-simplexml/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -simplexml
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php72-wddx/Makefile b/textproc/php72-wddx/Makefile
index cb657c48ed3e..40a18cd05649 100644
--- a/textproc/php72-wddx/Makefile
+++ b/textproc/php72-wddx/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -wddx
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php72-xml/Makefile b/textproc/php72-xml/Makefile
index 0e4e6674d31a..b5e2ffd71f69 100644
--- a/textproc/php72-xml/Makefile
+++ b/textproc/php72-xml/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -xml
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php72-xmlreader/Makefile b/textproc/php72-xmlreader/Makefile
index 6f6f41d8a9c8..1dcca2cac09a 100644
--- a/textproc/php72-xmlreader/Makefile
+++ b/textproc/php72-xmlreader/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -xmlreader
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php72-xmlwriter/Makefile b/textproc/php72-xmlwriter/Makefile
index db54ceccaa06..0d47832ecd2d 100644
--- a/textproc/php72-xmlwriter/Makefile
+++ b/textproc/php72-xmlwriter/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -xmlwriter
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"
diff --git a/textproc/php72-xsl/Makefile b/textproc/php72-xsl/Makefile
index 64f250ef2e0b..915d6fa83892 100644
--- a/textproc/php72-xsl/Makefile
+++ b/textproc/php72-xsl/Makefile
@@ -6,4 +6,6 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -xsl
+TEST_TARGET= test
+
.include "${MASTERDIR}/Makefile"