aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2019-06-23 21:39:35 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2019-06-23 21:39:35 +0800
commit4a136462431290f1061ed15d9149dee98f9a6385 (patch)
tree3d13de9dae95bf5ac7926ea39c97f9d672d84376 /textproc
parentc5b8c9aba4f820b5b28d7236f184caa6413d4031 (diff)
downloadfreebsd-ports-gnome-4a136462431290f1061ed15d9149dee98f9a6385.tar.gz
freebsd-ports-gnome-4a136462431290f1061ed15d9149dee98f9a6385.tar.zst
freebsd-ports-gnome-4a136462431290f1061ed15d9149dee98f9a6385.zip
textproc/kf5-sonnet: disable building of examples
- examples are built but not installed, so don't build them PR: 238710 Reported by: yuri
Diffstat (limited to 'textproc')
-rw-r--r--textproc/kf5-sonnet/Makefile4
-rw-r--r--textproc/kf5-sonnet/files/patch-CMakeLists.txt13
2 files changed, 17 insertions, 0 deletions
diff --git a/textproc/kf5-sonnet/Makefile b/textproc/kf5-sonnet/Makefile
index 28fe9f58b0e2..2cc5f4ca1134 100644
--- a/textproc/kf5-sonnet/Makefile
+++ b/textproc/kf5-sonnet/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sonnet
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= textproc kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -15,4 +16,7 @@ USE_KDE= ecm
USE_QT= buildtools_build core gui linguisttools qmake_build \
testlib widgets
+# Disable examples -- they are not installed anyways.
+CMAKE_OFF= ENABLE_EXAMPLES
+
.include <bsd.port.mk>
diff --git a/textproc/kf5-sonnet/files/patch-CMakeLists.txt b/textproc/kf5-sonnet/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..acba95ad8547
--- /dev/null
+++ b/textproc/kf5-sonnet/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+Allow disabling building examples, as they are not installed anyways.
+
+--- CMakeLists.txt.orig 2019-06-23 11:56:17 UTC
++++ CMakeLists.txt
+@@ -53,7 +53,7 @@ if (NOT CMAKE_CROSSCOMPILING)
+ add_subdirectory(data)
+ endif()
+
+-if(TARGET Qt5::Widgets)
++if((TARGET Qt5::Widgets) AND (ENABLE_EXAMPLES))
+ add_subdirectory(examples)
+ endif()
+