aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-10-10 04:12:37 +0800
committerkwm <kwm@FreeBSD.org>2010-10-10 04:12:37 +0800
commit51232cf3073e1597a77c7758269d52bc993fe52c (patch)
treebd9e3ca080ea46d65a7d6383e8672cb4830fad65 /textproc
parented25b91e3a23e35c7c2385079208c0fcabed1eba (diff)
downloadfreebsd-ports-gnome-51232cf3073e1597a77c7758269d52bc993fe52c.tar.gz
freebsd-ports-gnome-51232cf3073e1597a77c7758269d52bc993fe52c.tar.zst
freebsd-ports-gnome-51232cf3073e1597a77c7758269d52bc993fe52c.zip
Use USE_CSTD=gnu89 to build libxml2.
When build with Clang it tries to use C99 math functions we don't have. Also fix a symbol collision with the python bindings that got exposed by a Clang bug. With hat: gnome
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libxml2/Makefile1
-rw-r--r--textproc/libxml2/files/patch-python_libxml.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 08c2c5a96f0a..786a6f1c59db 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -25,6 +25,7 @@ COMMENT?= XML parser library for GNOME
.if !defined(REFERENCE_PORT)
+USE_CSTD= gnu89
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
USE_ICONV= yes
diff --git a/textproc/libxml2/files/patch-python_libxml.c b/textproc/libxml2/files/patch-python_libxml.c
new file mode 100644
index 000000000000..f45ef6f4ad6d
--- /dev/null
+++ b/textproc/libxml2/files/patch-python_libxml.c
@@ -0,0 +1,11 @@
+--- python/libxml.c.orig 2009-09-24 17:31:59.000000000 +0200
++++ python/libxml.c 2010-10-03 09:34:16.000000000 +0200
+@@ -30,7 +30,7 @@
+
+ #if (defined(_MSC_VER) || defined(__MINGW32__)) && !defined(vsnprintf)
+ #define vsnprintf(b,c,f,a) _vsnprintf(b,c,f,a)
+-#elif defined(WITH_TRIO)
++#elif defined(WITH_TRIO) && !defined(vsnprintf)
+ #include "trio.h"
+ #define vsnprintf trio_vsnprintf
+ #endif