aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-06-10 17:53:58 +0800
committerbapt <bapt@FreeBSD.org>2014-06-10 17:53:58 +0800
commit531e070bea87e6eb41f61fb46006aaad7cc1ba32 (patch)
tree5816d9d482ff6f1b383a83d29465b81d53a74bb9 /textproc
parent55b8b6826889fc4452907d1d67ea983c3864e6a9 (diff)
downloadfreebsd-ports-gnome-531e070bea87e6eb41f61fb46006aaad7cc1ba32.tar.gz
freebsd-ports-gnome-531e070bea87e6eb41f61fb46006aaad7cc1ba32.tar.zst
freebsd-ports-gnome-531e070bea87e6eb41f61fb46006aaad7cc1ba32.zip
Add libabw: library to handle Abiword documents
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/libabw/Makefile31
-rw-r--r--textproc/libabw/distinfo2
-rw-r--r--textproc/libabw/pkg-descr4
-rw-r--r--textproc/libabw/pkg-plist11
5 files changed, 49 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 723582105d4e..0c995fed214b 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -345,6 +345,7 @@
SUBDIR += latex-service
SUBDIR += latex2html
SUBDIR += lemmatizer2
+ SUBDIR += libabw
SUBDIR += libcrm114
SUBDIR += libcroco
SUBDIR += libcsv
diff --git a/textproc/libabw/Makefile b/textproc/libabw/Makefile
new file mode 100644
index 000000000000..6b8af2420647
--- /dev/null
+++ b/textproc/libabw/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= libabw
+PORTVERSION= 0.1.0
+CATEGORIES= textproc
+MASTER_SITES= http://dev-www.libreoffice.org/src/
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Library providing ability to interpret Abiword documents
+
+LICENSE= LGPL21 MPL
+LICENSE_COMB= dual
+
+OPTIONS_DEFINE= DOCS
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/algorithm/string.hpp:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= librevenge-0.0.so:${PORTSDIR}/textproc/librevenge
+
+USES= libtool pathfix pkgconfig tar:xz
+USE_GNOME= libxml2
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+CPPFLAGS= -I${LOCALBASE}/include
+CONFIGURE_ARGS= -disable-werror
+
+PORTDOCS= *
+DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
+DOCS_CONFIGURE_OFF= --without-docs
+
+.include <bsd.port.mk>
diff --git a/textproc/libabw/distinfo b/textproc/libabw/distinfo
new file mode 100644
index 000000000000..407cd67800a8
--- /dev/null
+++ b/textproc/libabw/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libabw-0.1.0.tar.xz) = ee99b280b7af226a48fd9afd395cc10bef2d8e4f844151277e90793706dfc0c1
+SIZE (libabw-0.1.0.tar.xz) = 282268
diff --git a/textproc/libabw/pkg-descr b/textproc/libabw/pkg-descr
new file mode 100644
index 000000000000..dc11ad2f0f6a
--- /dev/null
+++ b/textproc/libabw/pkg-descr
@@ -0,0 +1,4 @@
+Libabw is library providing ability to interpret and import AbiWord documents
+into various applications
+
+WWW: http://www.freedesktop.org/wiki/Software/libabw/
diff --git a/textproc/libabw/pkg-plist b/textproc/libabw/pkg-plist
new file mode 100644
index 000000000000..a12bb22ae799
--- /dev/null
+++ b/textproc/libabw/pkg-plist
@@ -0,0 +1,11 @@
+bin/abw2html
+bin/abw2raw
+bin/abw2text
+include/libabw-0.1/libabw/AbiDocument.h
+include/libabw-0.1/libabw/libabw.h
+lib/libabw-0.1.so
+lib/libabw-0.1.so.1
+lib/libabw-0.1.so.1.0.0
+libdata/pkgconfig/libabw-0.1.pc
+@dirrm include/libabw-0.1/libabw
+@dirrm include/libabw-0.1