aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-01-04 04:04:23 +0800
committerijliao <ijliao@FreeBSD.org>2002-01-04 04:04:23 +0800
commit53b6ed2f9906aa2f72ce4bb1b338466e2de33f72 (patch)
tree87c86cf4b375f7b2b11951ab5ff49f9f531e19fe /textproc
parent0b685dcea9b47a2e088c76b319ed6c0fb33c557b (diff)
downloadfreebsd-ports-gnome-53b6ed2f9906aa2f72ce4bb1b338466e2de33f72.tar.gz
freebsd-ports-gnome-53b6ed2f9906aa2f72ce4bb1b338466e2de33f72.tar.zst
freebsd-ports-gnome-53b6ed2f9906aa2f72ce4bb1b338466e2de33f72.zip
correct _xmlplus path
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-xmltools/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/textproc/py-xmltools/Makefile b/textproc/py-xmltools/Makefile
index e0ef6b26e4f6..989a80f7035b 100644
--- a/textproc/py-xmltools/Makefile
+++ b/textproc/py-xmltools/Makefile
@@ -14,11 +14,19 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
+USE_PYTHON= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_VERSION} == "python1.5" || ${PYTHON_VERSION} == "python1.6"
+XMLDIR= xml
+.else
+XMLDIR= _xmlplus
+.endif
+
RUN_DEPENDS= ${PYXML} \
${PYTHON_SITELIBDIR}/GDK.py:${PORTSDIR}/x11-toolkits/py-gtk \
- ${PYTHON_SITELIBDIR}/xml/xpath/__init__.py:${PORTSDIR}/textproc/py-4suite
-
-USE_PYTHON= yes
+ ${PYTHON_SITELIBDIR}/${XMLDIR}/xpath/__init__.py:${PORTSDIR}/textproc/py-4suite
SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
@@ -28,4 +36,4 @@ do-build:
do-install:
@${SETUP_CMD} install
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>