aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-10-10 19:16:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-10-10 19:16:12 +0800
commit55d6a8930ba3da0e43a58fdcf87d9d2570f8ee7a (patch)
tree7a3c3f750ced0dd86b5ab154d0d637f4c5ee1d79 /textproc
parentb820d177ce6d35a946a96256e66f0f4f64e0a975 (diff)
downloadfreebsd-ports-gnome-55d6a8930ba3da0e43a58fdcf87d9d2570f8ee7a.tar.gz
freebsd-ports-gnome-55d6a8930ba3da0e43a58fdcf87d9d2570f8ee7a.tar.zst
freebsd-ports-gnome-55d6a8930ba3da0e43a58fdcf87d9d2570f8ee7a.zip
Add p5-String-Tagged 0.15
String::Tagged implements an object class, instances of which store a (mutable) string buffer that supports tags. A tag is a name/value pair that applies to some non-empty extent of the underlying string. The types of tag names ought to be strings, or at least values that are well-behaved as strings, as the names will often be used as the keys in hashes or applied to the eq operator. The types of tag values are not restricted - any scalar will do. This could be a simple integer or string, ARRAY or HASH reference, or even a CODE reference containing an event handler of some kind. Tags may be arbitrarily overlapped. Any given offset within the string has in effect, a set of uniquely named tags. Tags of different names are independent. For tags of the same name, only the latest, shortest tag takes effect. WWW: http://search.cpan.org/dist/String-Tagged/
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-String-Tagged/Makefile23
-rw-r--r--textproc/p5-String-Tagged/distinfo3
-rw-r--r--textproc/p5-String-Tagged/pkg-descr17
-rw-r--r--textproc/p5-String-Tagged/pkg-plist4
5 files changed, 48 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index a02b4b28c3f1..65a08ef21906 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -819,6 +819,7 @@
SUBDIR += p5-String-ShellQuote
SUBDIR += p5-String-ShowDiff
SUBDIR += p5-String-Strip
+ SUBDIR += p5-String-Tagged
SUBDIR += p5-String-ToIdentifier-EN
SUBDIR += p5-String-Tokenizer
SUBDIR += p5-String-Trim
diff --git a/textproc/p5-String-Tagged/Makefile b/textproc/p5-String-Tagged/Makefile
new file mode 100644
index 000000000000..2d9976e22a4f
--- /dev/null
+++ b/textproc/p5-String-Tagged/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= String-Tagged
+PORTVERSION= 0.15
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Sstring buffers with value tags on extents
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= p5-Test-Identity>=0:devel/p5-Test-Identity
+
+NO_ARCH= yes
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-String-Tagged/distinfo b/textproc/p5-String-Tagged/distinfo
new file mode 100644
index 000000000000..085bf698340e
--- /dev/null
+++ b/textproc/p5-String-Tagged/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1507626874
+SHA256 (String-Tagged-0.15.tar.gz) = 0f4bb11a80ec54403d3e32a0db3091570c2c7218b5b2a411480e6bb9bd89d3a0
+SIZE (String-Tagged-0.15.tar.gz) = 40354
diff --git a/textproc/p5-String-Tagged/pkg-descr b/textproc/p5-String-Tagged/pkg-descr
new file mode 100644
index 000000000000..f012204b8718
--- /dev/null
+++ b/textproc/p5-String-Tagged/pkg-descr
@@ -0,0 +1,17 @@
+String::Tagged implements an object class, instances of which store a (mutable)
+string buffer that supports tags. A tag is a name/value pair that applies to
+some non-empty extent of the underlying string.
+
+The types of tag names ought to be strings, or at least values that are
+well-behaved as strings, as the names will often be used as the keys in hashes
+or applied to the eq operator.
+
+The types of tag values are not restricted - any scalar will do. This could be a
+simple integer or string, ARRAY or HASH reference, or even a CODE reference
+containing an event handler of some kind.
+
+Tags may be arbitrarily overlapped. Any given offset within the string has in
+effect, a set of uniquely named tags. Tags of different names are independent.
+For tags of the same name, only the latest, shortest tag takes effect.
+
+WWW: http://search.cpan.org/dist/String-Tagged/
diff --git a/textproc/p5-String-Tagged/pkg-plist b/textproc/p5-String-Tagged/pkg-plist
new file mode 100644
index 000000000000..788bbe1d53db
--- /dev/null
+++ b/textproc/p5-String-Tagged/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/String/Tagged.pm
+%%SITE_PERL%%/String/Tagged/Formatting.pod
+%%PERL5_MAN3%%/String::Tagged.3.gz
+%%PERL5_MAN3%%/String::Tagged::Formatting.3.gz