aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2008-04-18 14:04:08 +0800
committerclsung <clsung@FreeBSD.org>2008-04-18 14:04:08 +0800
commit60cbb566e7b4f6f4ea83e240ed86862d1d0998eb (patch)
treead0153216c2df8bfbe6f28582b4ecc390075a2db /textproc
parente8e4358867b51d9ac31348ecb51da298948de02a (diff)
downloadfreebsd-ports-gnome-60cbb566e7b4f6f4ea83e240ed86862d1d0998eb.tar.gz
freebsd-ports-gnome-60cbb566e7b4f6f4ea83e240ed86862d1d0998eb.tar.zst
freebsd-ports-gnome-60cbb566e7b4f6f4ea83e240ed86862d1d0998eb.zip
This libary can serve as an advanced lexer for (GNU) makefiles. It
parses makefiles as "documents" and the parsing is lossless. The results are data structures similar to DOM trees. The DOM trees hold every single bit of the information in the original input files, including white spaces, blank lines and makefile comments. That means it's possible to reproduce the original makefiles from the DOM trees. In addition, each node of the DOM trees is modifiable and so is the whole tree, just like the PPI module used for Perl source parsing and the HTML::TreeBuilder module used for parsing HTML source. WWW: http://search.cpan.org/dist/Makefile-DOM/ PR: ports/122843 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Makefile-DOM/Makefile33
-rw-r--r--textproc/p5-Makefile-DOM/distinfo3
-rw-r--r--textproc/p5-Makefile-DOM/pkg-descr11
-rw-r--r--textproc/p5-Makefile-DOM/pkg-plist31
5 files changed, 79 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b050b011ffbb..bdf150197ad0 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -435,6 +435,7 @@
SUBDIR += p5-MARC-Lint
SUBDIR += p5-MARC-Record
SUBDIR += p5-MKDoc-XML
+ SUBDIR += p5-Makefile-DOM
SUBDIR += p5-Makefile-Parser
SUBDIR += p5-MathML-Entities
SUBDIR += p5-Net-YASA
diff --git a/textproc/p5-Makefile-DOM/Makefile b/textproc/p5-Makefile-DOM/Makefile
new file mode 100644
index 000000000000..5c1875a4ce06
--- /dev/null
+++ b/textproc/p5-Makefile-DOM/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Makefile-DOM
+# Date created: 2008-04-17
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Makefile-DOM
+PORTVERSION= 0.004
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/A/AG/AGENT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Simple DOM parser for Makefiles
+
+RUN_DEPENDS= p5-Clone>=0.18:${PORTSDIR}/devel/p5-Clone \
+ p5-List-MoreUtils>=0.21:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Params-Util>=0.22:${PORTSDIR}/devel/p5-Params-Util
+
+PERL_CONFIGURE= 5.6.1+
+
+MAN3= MDOM::Dumper.3 \
+ MDOM::Element.3 \
+ MDOM::Node.3 \
+ MDOM::Token.3 \
+ MDOM::Token::Comment.3 \
+ MDOM::Token::Separator.3 \
+ MDOM::Token::Whitespace.3 \
+ Makefile::DOM.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Makefile-DOM/distinfo b/textproc/p5-Makefile-DOM/distinfo
new file mode 100644
index 000000000000..1563ffd4071a
--- /dev/null
+++ b/textproc/p5-Makefile-DOM/distinfo
@@ -0,0 +1,3 @@
+MD5 (Makefile-DOM-0.004.tar.gz) = 2860a83edc7396077716c63f30c12446
+SHA256 (Makefile-DOM-0.004.tar.gz) = 04535715ba9bbd79118524f54594630dd66b06b7d59afd61da411ecfb5094a63
+SIZE (Makefile-DOM-0.004.tar.gz) = 85761
diff --git a/textproc/p5-Makefile-DOM/pkg-descr b/textproc/p5-Makefile-DOM/pkg-descr
new file mode 100644
index 000000000000..e87a1a5ca562
--- /dev/null
+++ b/textproc/p5-Makefile-DOM/pkg-descr
@@ -0,0 +1,11 @@
+This libary can serve as an advanced lexer for (GNU) makefiles. It
+parses makefiles as "documents" and the parsing is lossless. The
+results are data structures similar to DOM trees. The DOM trees hold
+every single bit of the information in the original input files,
+including white spaces, blank lines and makefile comments. That means
+it's possible to reproduce the original makefiles from the DOM trees.
+In addition, each node of the DOM trees is modifiable and so is the
+whole tree, just like the PPI module used for Perl source parsing and
+the HTML::TreeBuilder module used for parsing HTML source.
+
+WWW: http://search.cpan.org/dist/Makefile-DOM/
diff --git a/textproc/p5-Makefile-DOM/pkg-plist b/textproc/p5-Makefile-DOM/pkg-plist
new file mode 100644
index 000000000000..19c0a91c5461
--- /dev/null
+++ b/textproc/p5-Makefile-DOM/pkg-plist
@@ -0,0 +1,31 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Makefile/DOM/.packlist
+%%SITE_PERL%%/MDOM/Assignment.pm
+%%SITE_PERL%%/MDOM/Command.pm
+%%SITE_PERL%%/MDOM/Directive.pm
+%%SITE_PERL%%/MDOM/Document.pm
+%%SITE_PERL%%/MDOM/Document/Gmake.pm
+%%SITE_PERL%%/MDOM/Dumper.pm
+%%SITE_PERL%%/MDOM/Element.pm
+%%SITE_PERL%%/MDOM/Node.pm
+%%SITE_PERL%%/MDOM/Rule.pm
+%%SITE_PERL%%/MDOM/Rule/Simple.pm
+%%SITE_PERL%%/MDOM/Rule/StaticPattern.pm
+%%SITE_PERL%%/MDOM/Token.pm
+%%SITE_PERL%%/MDOM/Token/Bare.pm
+%%SITE_PERL%%/MDOM/Token/Comment.pm
+%%SITE_PERL%%/MDOM/Token/Continuation.pm
+%%SITE_PERL%%/MDOM/Token/Interpolation.pm
+%%SITE_PERL%%/MDOM/Token/Modifier.pm
+%%SITE_PERL%%/MDOM/Token/Separator.pm
+%%SITE_PERL%%/MDOM/Token/Whitespace.pm
+%%SITE_PERL%%/MDOM/Unknown.pm
+%%SITE_PERL%%/MDOM/Util.pm
+%%SITE_PERL%%/Makefile/DOM.pm
+@dirrmtry %%SITE_PERL%%/Makefile
+@dirrmtry %%SITE_PERL%%/MDOM/Token
+@dirrmtry %%SITE_PERL%%/MDOM/Rule
+@dirrmtry %%SITE_PERL%%/MDOM/Document
+@dirrmtry %%SITE_PERL%%/MDOM
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Makefile/DOM
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Makefile