aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
committertijl <tijl@FreeBSD.org>2016-09-06 03:23:42 +0800
commit6255104baacfdd2c23e07550f90d2f9a7020ca87 (patch)
tree516db145d6cf5fd4d2666f811272aad577272ac5 /textproc
parent016de2316ed16336a58b66dafd7f332614a041ac (diff)
downloadfreebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.gz
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.tar.zst
freebsd-ports-gnome-6255104baacfdd2c23e07550f90d2f9a7020ca87.zip
- Replace Mk/bsd.linux-apps.mk and Mk/bsd.linux-rpm.mk with
Mk/Uses/linux.mk. - Replace USE_LINUX=yes with USES+=linux and USE_LINUX=(.*) with USES+=linux:\1 in all ports. - Replace USE_LINUX_APPS with USE_LINUX in all ports. - Use INSTALL_SCRIPT instead of INSTALL_PROGRAM to install scripts in some ports. - When USE_LINUX_RPM is defined, simplify the way DISTFILES and EXTRACT_ONLY are defined. - Remove BRANDELF_DIRS and BRANDELF_FILES handling. In the very rare cases that it is still necessary ports can run ${BRANDELF} from post-patch. - Remove AUTOMATIC_PLIST handling. Only one port used it. - Fix Linux MASTER_SITES. - Replace OVERRIDE_LINUX_BASE_PORT and OVERRIDE_LINUX_NONBASE_PORTS with default versions framework. - bsd.port.mk: - Move Linux related bits to Uses/linux.mk, except USE_LINUX_PREFIX. - Put USE_LINUX_PREFIX handling after USES processing. - Define DOCSDIR, DATADIR, etc. after handling USE_LINUX_PREFIX so it can give these variables a different default value. - When a package needs to run Linux ldconfig check before installation if Linux support is enabled. - emulators/linux_base-*: - Use USES=linux and remove duplication. - Remove files/lp. FreeBSD or CUPS lp(1) should work. - Remove files/yp.conf. No longer seems to be used. - Remove pkg-deinstall and move pkg-install into pkg-plist. - Update pkg-descr and pkg-message. - Fix handling of ldconfig cache in pkg-plist. - devel/fb-adb: Use a Linux shell to run a Linux script but patch the script to use FreeBSD mkdir so mkdir -p $path creates $path and not /compat/linux/$path. PR: 211645 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/linux-c6-aspell/Makefile4
-rw-r--r--textproc/linux-c6-expat/Makefile5
-rw-r--r--textproc/linux-c6-libxml2/Makefile4
-rw-r--r--textproc/linux-f10-aspell/Makefile5
-rw-r--r--textproc/linux-f10-expat/Makefile6
-rw-r--r--textproc/linux-f10-libxml2/Makefile5
-rw-r--r--textproc/linux-f10-scim-gtk/Makefile8
-rw-r--r--textproc/linux-f10-scim-libs/Makefile8
-rw-r--r--textproc/pocketreader/Makefile2
9 files changed, 13 insertions, 34 deletions
diff --git a/textproc/linux-c6-aspell/Makefile b/textproc/linux-c6-aspell/Makefile
index f490fee26044..81c2779c2972 100644
--- a/textproc/linux-c6-aspell/Makefile
+++ b/textproc/linux-c6-aspell/Makefile
@@ -11,12 +11,10 @@ COMMENT= Spelling checker with better logic than ispell (Linux CentOS ${LINUX_DI
CONFLICTS= linux-aspell-[0-9]* linux-f10-aspell-[0-9]*
-ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= c6
+USES= linux:c6
USE_LINUX_RPM= yes
RPMVERSION= 12.el6
-BRANDELF_DIRS= usr/bin
USE_LDCONFIG= yes
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
diff --git a/textproc/linux-c6-expat/Makefile b/textproc/linux-c6-expat/Makefile
index 4401389d967c..f46f686150c2 100644
--- a/textproc/linux-c6-expat/Makefile
+++ b/textproc/linux-c6-expat/Makefile
@@ -11,14 +11,11 @@ COMMENT= Linux/i386 binary port of Expat XML-parsing library (Linux CentOS ${LIN
CONFLICTS= linux-expat-[0-9]* linux-f8-expat-[0-9]* linux-f10-expat-[0-9]*
-ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= c6
+USES= linux:c6
USE_LINUX_RPM= yes
RPMVERSION= 11.el6_2
-BRANDELF_FILES= usr/bin/xmlwf
USE_LDCONFIG= yes
-DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= COPYING README
DESCR= ${.CURDIR}/../${PORTNAME}2/pkg-descr
diff --git a/textproc/linux-c6-libxml2/Makefile b/textproc/linux-c6-libxml2/Makefile
index bcb6399d1b08..7356e09579ff 100644
--- a/textproc/linux-c6-libxml2/Makefile
+++ b/textproc/linux-c6-libxml2/Makefile
@@ -11,14 +11,12 @@ COMMENT= Library providing XML and HTML support (Linux CentOS ${LINUX_DIST_VER})
CONFLICTS= linux-f10-libxml2-[0-9]*
-USE_LINUX= c6
+USES= linux:c6
USE_LINUX_RPM= yes
RPMVERSION= 21.el6_8.1
-BRANDELF_DIRS= usr/bin
USE_LDCONFIG= yes
-DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= AUTHORS ChangeLog.gz Copyright NEWS README TODO
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
diff --git a/textproc/linux-f10-aspell/Makefile b/textproc/linux-f10-aspell/Makefile
index 2e37c26158b8..ddc3263928bd 100644
--- a/textproc/linux-f10-aspell/Makefile
+++ b/textproc/linux-f10-aspell/Makefile
@@ -5,19 +5,16 @@ PORTNAME= aspell
PORTVERSION= 0.60.6
PORTREVISION= 1
CATEGORIES= textproc linux
-MASTER_SITES= LOCAL/ehaupt/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Spelling checker with better logic than ispell (Linux Fedora 10)
CONFLICTS= linux-aspell-[0-9]* linux-f8-aspell-[0-9]*
-ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= f10
+USES= linux:f10
USE_LINUX_RPM= yes
RPMVERSION= 3.fc10
-BRANDELF_DIRS= usr/bin
USE_LDCONFIG= yes
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
diff --git a/textproc/linux-f10-expat/Makefile b/textproc/linux-f10-expat/Makefile
index ced349120c58..8fa4cfc15f73 100644
--- a/textproc/linux-f10-expat/Makefile
+++ b/textproc/linux-f10-expat/Makefile
@@ -5,24 +5,20 @@ PORTNAME= expat
PORTVERSION= 2.0.1
PORTREVISION= 1
CATEGORIES= textproc linux
-MASTER_SITES= LOCAL/ehaupt/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Linux/i386 binary port of Expat XML-parsing library (Linux Fedora 10)
CONFLICTS= linux-expat-[0-9]* linux-f8-expat-[0-9]*
-ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= f10
+USES= linux:f10
USE_LINUX_RPM= yes
RPMVERSION= 5
-BRANDELF_FILES= usr/bin/xmlwf
USE_LDCONFIG= yes
PLIST_FILES= lib/libexpat.so.1 lib/libexpat.so.1.5.2 \
usr/bin/xmlwf usr/share/man/man1/xmlwf.1.gz
-DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= COPYING README
DESCR= ${.CURDIR}/../${PORTNAME}2/pkg-descr
diff --git a/textproc/linux-f10-libxml2/Makefile b/textproc/linux-f10-libxml2/Makefile
index a6ad4ae1e7c0..5d6a0f69339a 100644
--- a/textproc/linux-f10-libxml2/Makefile
+++ b/textproc/linux-f10-libxml2/Makefile
@@ -5,25 +5,22 @@ PORTNAME= libxml2
PORTVERSION= 2.7.3
PORTREVISION= 2
CATEGORIES= textproc linux
-MASTER_SITES= LOCAL/ehaupt/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Library providing XML and HTML support (Linux Fedora 10)
CONFLICTS= linux-libxml2-[0-9]* linux-f8-libxml2-[0-9]*
-USE_LINUX= f10
+USES= linux:f10
USE_LINUX_RPM= yes
RPMVERSION= 1.fc10
-BRANDELF_DIRS= usr/bin
USE_LDCONFIG= yes
PLIST_FILES= usr/bin/xmlcatalog usr/bin/xmllint \
usr/lib/libxml2.so.2 usr/lib/libxml2.so.${PORTVERSION} \
usr/share/man/man1/xmlcatalog.1.gz \
usr/share/man/man1/xmllint.1.gz usr/share/man/man3/libxml.3.gz
-DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
PORTDOCS= AUTHORS ChangeLog.gz Copyright NEWS README TODO
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
diff --git a/textproc/linux-f10-scim-gtk/Makefile b/textproc/linux-f10-scim-gtk/Makefile
index 3f8b41e08c27..9d24e24ba6b5 100644
--- a/textproc/linux-f10-scim-gtk/Makefile
+++ b/textproc/linux-f10-scim-gtk/Makefile
@@ -5,20 +5,18 @@ PORTNAME= scim-gtk
PORTVERSION= 1.4.7
PORTREVISION= 2
CATEGORIES= textproc linux
-MASTER_SITES= LOCAL/ehaupt/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Smart Common Input Method platform, gtk module, (Linux Fedora 10)
CONFLICTS= linux-scim-gtk-[0-9]*
-ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= f10
+USES= linux:f10
USE_LINUX_RPM= yes
-USE_LINUX_APPS= gtk2 scimlibs
+USE_LINUX= gtk2 scimlibs
RPMVERSION= 35.fc10
USE_LDCONFIG= yes
-SRC_DISTFILES= scim-${PORTVERSION}-${RPMVERSION}${SRC_SUFX}
+SRC_DISTFILES= scim-${PORTVERSION}-${RPMVERSION}${SRC_SUFX}:SOURCE
.include <bsd.port.mk>
diff --git a/textproc/linux-f10-scim-libs/Makefile b/textproc/linux-f10-scim-libs/Makefile
index f9543d13dfcf..d4a3c433585e 100644
--- a/textproc/linux-f10-scim-libs/Makefile
+++ b/textproc/linux-f10-scim-libs/Makefile
@@ -5,21 +5,19 @@ PORTNAME= scim-libs
PORTVERSION= 1.4.7
PORTREVISION= 3
CATEGORIES= textproc linux
-MASTER_SITES= LOCAL/ehaupt/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Smart Common Input Method libraries (Linux Fedora 10)
CONFLICTS= linux-scim-libs-[0-9]* linux-f8-scim-libs-[0-9]*
-ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= f10
+USES= linux:f10
USE_LINUX_RPM= yes
-USE_LINUX_APPS= gtk2
+USE_LINUX= gtk2
RPMVERSION= 35.fc10
USE_LDCONFIG= yes
-SRC_DISTFILES= scim-${PORTVERSION}-${RPMVERSION}.src.rpm
+SRC_DISTFILES= scim-${PORTVERSION}-${RPMVERSION}.src.rpm:SOURCE
DESCR= ${.CURDIR}/../scim/pkg-descr
diff --git a/textproc/pocketreader/Makefile b/textproc/pocketreader/Makefile
index 80154d4f319a..c8f7f011134e 100644
--- a/textproc/pocketreader/Makefile
+++ b/textproc/pocketreader/Makefile
@@ -13,7 +13,7 @@ DIST_SUBDIR= pocketreader
MAINTAINER= simond@irrelevant.org
COMMENT= Siemens PocketReader
-USE_LINUX= yes
+USES= linux
NO_BUILD= yes
PLIST_FILES= bin/pocketreader