aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2011-08-15 01:46:17 +0800
committerpgj <pgj@FreeBSD.org>2011-08-15 01:46:17 +0800
commit71a7e34969c5fc4778fd651f4e988733aaaab49e (patch)
tree5e7cafbc821605528098dbfb790fb3b9ac6a4b5c /textproc
parent6065f122fbe08ccc957ac0886b79659e1304d7ae (diff)
downloadfreebsd-ports-gnome-71a7e34969c5fc4778fd651f4e988733aaaab49e.tar.gz
freebsd-ports-gnome-71a7e34969c5fc4778fd651f4e988733aaaab49e.tar.zst
freebsd-ports-gnome-71a7e34969c5fc4778fd651f4e988733aaaab49e.zip
A library that performs fast, accurate conversion between double
precision floating point and text. This library is implemented as bindings to the C++ double-conversion library written by Florian Loitsch at Google: http://code.google.com/p/double-conversion/. The Text versions of these functions are about 30 times faster than the default show implementation for the Double type. The ByteString versions are slower than the Text versions; roughly half the speed. (This seems to be due to the cost of allocating ByteString values via malloc.) As a final note, be aware that the bytestring-show package is about 50% slower than simply using show. WWW: http://github.com/mailrank/double-conversion Obtained from: FreeBSD Haskell
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/hs-double-conversion/Makefile20
-rw-r--r--textproc/hs-double-conversion/distinfo2
-rw-r--r--textproc/hs-double-conversion/files/patch-double-conversion.cabal11
-rw-r--r--textproc/hs-double-conversion/pkg-descr14
5 files changed, 48 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 43a8e6d26e1a..c9406413d06c 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -239,6 +239,7 @@
SUBDIR += hs-bytestring-csv
SUBDIR += hs-case-insensitive
SUBDIR += hs-citeproc-hs
+ SUBDIR += hs-double-conversion
SUBDIR += hs-feed
SUBDIR += hs-highlighting-kate
SUBDIR += hs-hs-bibutils
diff --git a/textproc/hs-double-conversion/Makefile b/textproc/hs-double-conversion/Makefile
new file mode 100644
index 000000000000..f40fe7717406
--- /dev/null
+++ b/textproc/hs-double-conversion/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: hs-double-conversion
+# Date created: July 13, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= double-conversion
+PORTVERSION= 0.2.0.1
+CATEGORIES= textproc haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Fast conversion between double-precision floating point and text
+
+LICENSE= BSD
+
+USE_CABAL= text>=0.11.0.6
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/textproc/hs-double-conversion/distinfo b/textproc/hs-double-conversion/distinfo
new file mode 100644
index 000000000000..384ecea8983b
--- /dev/null
+++ b/textproc/hs-double-conversion/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/double-conversion-0.2.0.1.tar.gz) = 0a1845b663d45e029255b3e2f5a5f0995f39cb3ddf128f38c514cc523693d190
+SIZE (cabal/double-conversion-0.2.0.1.tar.gz) = 6831038
diff --git a/textproc/hs-double-conversion/files/patch-double-conversion.cabal b/textproc/hs-double-conversion/files/patch-double-conversion.cabal
new file mode 100644
index 000000000000..2bc16b321303
--- /dev/null
+++ b/textproc/hs-double-conversion/files/patch-double-conversion.cabal
@@ -0,0 +1,11 @@
+--- ./double-conversion.cabal.orig 2011-06-29 07:47:53.000000000 +0200
++++ ./double-conversion.cabal 2011-07-14 06:13:05.343763049 +0200
+@@ -82,7 +82,7 @@
+ base == 4.*,
+ bytestring,
+ ghc-prim,
+- text >= 0.11.0.8
++ text >= 0.11.0.6
+
+ if flag(developer)
+ ghc-options: -Werror
diff --git a/textproc/hs-double-conversion/pkg-descr b/textproc/hs-double-conversion/pkg-descr
new file mode 100644
index 000000000000..6da6186995bc
--- /dev/null
+++ b/textproc/hs-double-conversion/pkg-descr
@@ -0,0 +1,14 @@
+A library that performs fast, accurate conversion between double
+precision floating point and text. This library is implemented as
+bindings to the C++ double-conversion library written by Florian Loitsch
+at Google: http://code.google.com/p/double-conversion/.
+
+The Text versions of these functions are about 30 times faster than the
+default show implementation for the Double type. The ByteString versions
+are slower than the Text versions; roughly half the speed. (This seems
+to be due to the cost of allocating ByteString values via malloc.)
+
+As a final note, be aware that the bytestring-show package is about 50%
+slower than simply using show.
+
+WWW: http://github.com/mailrank/double-conversion