aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-07-23 11:09:36 +0800
committerclsung <clsung@FreeBSD.org>2007-07-23 11:09:36 +0800
commit7c1c3526966547c095b4b6e1ffb3bee197d1bdc6 (patch)
tree24687d0923e485a2f06e03abba1a5e34e1c811c1 /textproc
parent62b910accf1dc517d0c823132baaa27d8ec7d195 (diff)
downloadfreebsd-ports-gnome-7c1c3526966547c095b4b6e1ffb3bee197d1bdc6.tar.gz
freebsd-ports-gnome-7c1c3526966547c095b4b6e1ffb3bee197d1bdc6.tar.zst
freebsd-ports-gnome-7c1c3526966547c095b4b6e1ffb3bee197d1bdc6.zip
This module provides an implementation of Canonical XML Recommendation
(Version 1, 15 March 2001). It uses XML::GDOME for its DOM tree and XPath nodes. It provides a XS wrapper around libxml2's Canonical XML code. WWW: http://search.cpan.org/dist/XML-Canonical/ PR: ports/114596 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-Canonical/Makefile24
-rw-r--r--textproc/p5-XML-Canonical/distinfo3
-rw-r--r--textproc/p5-XML-Canonical/files/patch-Makefile.PL10
-rw-r--r--textproc/p5-XML-Canonical/pkg-descr7
-rw-r--r--textproc/p5-XML-Canonical/pkg-plist8
6 files changed, 53 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index c434fc4bbeb2..a69ab6d4d752 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -602,6 +602,7 @@
SUBDIR += p5-XML-Atom-Stream
SUBDIR += p5-XML-Atom-Syndication
SUBDIR += p5-XML-AutoWriter
+ SUBDIR += p5-XML-Canonical
SUBDIR += p5-XML-Catalog
SUBDIR += p5-XML-Clean
SUBDIR += p5-XML-Compile
diff --git a/textproc/p5-XML-Canonical/Makefile b/textproc/p5-XML-Canonical/Makefile
new file mode 100644
index 000000000000..ba1d0fdc6454
--- /dev/null
+++ b/textproc/p5-XML-Canonical/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-XML-Canonical
+# Date created: 2007-07-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Canonical
+PORTVERSION= 0.10
+CATEGORIES= textproc
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl Implementation of Canonical XML
+
+LIB_DEPENDS= gdome:${PORTSDIR}/textproc/gdome2
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Canonical.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Canonical/distinfo b/textproc/p5-XML-Canonical/distinfo
new file mode 100644
index 000000000000..d6deeaaff1f0
--- /dev/null
+++ b/textproc/p5-XML-Canonical/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-Canonical-0.10.tar.gz) = 9c75fadad906ee63e43ced695b3412fd
+SHA256 (XML-Canonical-0.10.tar.gz) = 419ea71c91b8cdb07cb48075ff04424ea7ce69a90955dd5f73bd23f60488c488
+SIZE (XML-Canonical-0.10.tar.gz) = 6243
diff --git a/textproc/p5-XML-Canonical/files/patch-Makefile.PL b/textproc/p5-XML-Canonical/files/patch-Makefile.PL
new file mode 100644
index 000000000000..7ed1cee3b0ac
--- /dev/null
+++ b/textproc/p5-XML-Canonical/files/patch-Makefile.PL
@@ -0,0 +1,10 @@
+--- Makefile.PL.orig Sun Jul 15 16:00:28 2007
++++ Makefile.PL Sun Jul 15 16:00:31 2007
+@@ -17,7 +17,6 @@
+ print "running gdome-config... ";
+ my $ver = backtick('gdome-config --version');
+ my ($major, $minor, $point) = $ver =~ /(\d+).(\d+)\.(\d+)/g;
+- die "VERSION" unless $major == 0 && $minor == 7 && $point == 1;
+ $config{LIBS} ||= backtick('gdome-config --libs');
+ $config{INC} ||= backtick('gdome-config --cflags');
+ print "ok\n";
diff --git a/textproc/p5-XML-Canonical/pkg-descr b/textproc/p5-XML-Canonical/pkg-descr
new file mode 100644
index 000000000000..3fac5350ba22
--- /dev/null
+++ b/textproc/p5-XML-Canonical/pkg-descr
@@ -0,0 +1,7 @@
+This module provides an implementation of Canonical XML Recommendation
+(Version 1, 15 March 2001). It uses XML::GDOME for its DOM tree and
+XPath nodes.
+
+It provides a XS wrapper around libxml2's Canonical XML code.
+
+WWW: http://search.cpan.org/dist/XML-Canonical/
diff --git a/textproc/p5-XML-Canonical/pkg-plist b/textproc/p5-XML-Canonical/pkg-plist
new file mode 100644
index 000000000000..d95a29b3ff37
--- /dev/null
+++ b/textproc/p5-XML-Canonical/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/XML/Canonical.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Canonical/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Canonical/Canonical.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Canonical/Canonical.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Canonical
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/XML