aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2019-03-10 00:30:06 +0800
committertcberner <tcberner@FreeBSD.org>2019-03-10 00:30:06 +0800
commit828f2b517292c26614581192f6f3746e330299fa (patch)
treee219ac77824e698490489209c20ff9eb5492ab28 /textproc
parentb8ed0bce51110cb0c171861bd461de96ab65e681 (diff)
downloadfreebsd-ports-gnome-828f2b517292c26614581192f6f3746e330299fa.tar.gz
freebsd-ports-gnome-828f2b517292c26614581192f6f3746e330299fa.tar.zst
freebsd-ports-gnome-828f2b517292c26614581192f6f3746e330299fa.zip
textproc/qstardict: update to 1.3 (with Qt5)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/qstardict/Makefile40
-rw-r--r--textproc/qstardict/distinfo5
-rw-r--r--textproc/qstardict/files/patch-plugins_stardict_lib.cpp10
-rw-r--r--textproc/qstardict/files/patch-plugins_stardict_mapfile.hpp16
-rw-r--r--textproc/qstardict/files/patch-qstardict.pri10
-rw-r--r--textproc/qstardict/pkg-plist28
6 files changed, 39 insertions, 70 deletions
diff --git a/textproc/qstardict/Makefile b/textproc/qstardict/Makefile
index 69668dadac9b..64b9556f8e68 100644
--- a/textproc/qstardict/Makefile
+++ b/textproc/qstardict/Makefile
@@ -2,48 +2,36 @@
# $FreeBSD$
PORTNAME= qstardict
-PORTVERSION= 1.0.1
-PORTREVISION= 1
+DISTVERSIONPREFIX= qstardict-
+DISTVERSION= 1.3
CATEGORIES= textproc
MASTER_SITES= http://qstardict.ylsoftware.com/files/
MAINTAINER= ports@FreeBSD.org
-COMMENT= Qt 4 based dictionary program (stardict clone)
+COMMENT= Qt based dictionary program (stardict clone)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-DEPRECATED= Qt4 has been EOL since december 2015
-EXPIRATION_DATE= 2019-03-15
-
-USES= dos2unix pkgconfig qmake qt:4 tar:bzip2
-USE_QT= corelib gui network xml uic_build moc_build rcc_build
+USES= gl gnome pkgconfig qmake qt:5 tar:bzip2
+USE_GL= gl
USE_GNOME= glib20
+USE_QT= core dbus gui network printsupport widgets xml \
+ buildtools_build linguisttools_build qmake_build
USE_XORG= x11
-DOS2UNIX_FILES= qstardict.pri
-# Path to dictionaries installed by stardict-* ports
-DICPATH= ${LOCALBASE}/share/stardict/dic
+USE_GITHUB= yes
+GH_ACCOUNT= a-rodin
-OPTIONS_DEFINE= DBUS DOCS NLS
-OPTIONS_DEFAULT=DBUS
-OPTIONS_SUB= yes
+QMAKE_ARGS= INSTALL_PREFIX=${PREFIX}
-DBUS_USES= qt:4
-DBUS_USE= QT=dbus
-DBUS_QMAKE_OFF= NO_DBUS=1
+OPTIONS_DEFINE= DOCS
-NLS_QMAKE_OFF= NO_TRANSLATIONS=1
+# Path to dictionaries installed by stardict-* ports
+DICPATH= ${LOCALBASE}/share/stardict/dic
post-patch:
- @${REINPLACE_CMD} -e "s|/usr|${PREFIX}|g" \
- ${WRKSRC}/qstardict.pri
- @${REINPLACE_CMD} -e "s|/usr/share/stardict/dic|${DICPATH}|g" \
- -e "s|glib.*\.h|glib.h|g" \
+ ${REINPLACE_CMD} '/m_dictDirs/s|/usr/share/stardict/dic|${PREFIX}/share/stardict/dic|g' \
${WRKSRC}/plugins/stardict/stardict.cpp
-post-patch-DOCS-off:
- @${REINPLACE_CMD} -e "/^INSTALLS/s|docs||g" \
- ${WRKSRC}/qstardict.pro
-
.include <bsd.port.mk>
diff --git a/textproc/qstardict/distinfo b/textproc/qstardict/distinfo
index 7b7dd47b86ee..cfaade15126d 100644
--- a/textproc/qstardict/distinfo
+++ b/textproc/qstardict/distinfo
@@ -1,2 +1,3 @@
-SHA256 (qstardict-1.0.1.tar.bz2) = b778ace65a22e5b9724d687ad90c77ec98feb2671774f73cd51725ec7b59e62f
-SIZE (qstardict-1.0.1.tar.bz2) = 565098
+TIMESTAMP = 1552147870
+SHA256 (a-rodin-qstardict-qstardict-1.3_GH0.tar.gz) = 9b083a3177407d66a17403742590471a0aa89a3d31df886926b79fa21e4d41a4
+SIZE (a-rodin-qstardict-qstardict-1.3_GH0.tar.gz) = 490595
diff --git a/textproc/qstardict/files/patch-plugins_stardict_lib.cpp b/textproc/qstardict/files/patch-plugins_stardict_lib.cpp
deleted file mode 100644
index c0e8b1a1e899..000000000000
--- a/textproc/qstardict/files/patch-plugins_stardict_lib.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- plugins/stardict/lib.cpp.orig 2011-12-05 12:40:49 UTC
-+++ plugins/stardict/lib.cpp
-@@ -9,6 +9,7 @@
- #include <sys/stat.h>
- #include <zlib.h>
- #include <glib/gstdio.h>
-+#include <stdlib.h>
-
- #include "distance.h"
- #include "file.hpp"
diff --git a/textproc/qstardict/files/patch-plugins_stardict_mapfile.hpp b/textproc/qstardict/files/patch-plugins_stardict_mapfile.hpp
index f38ebf94e094..f36701fc6232 100644
--- a/textproc/qstardict/files/patch-plugins_stardict_mapfile.hpp
+++ b/textproc/qstardict/files/patch-plugins_stardict_mapfile.hpp
@@ -1,10 +1,10 @@
---- plugins/stardict/mapfile.hpp.orig 2011-12-05 12:40:49 UTC
+--- plugins/stardict/mapfile.hpp.orig 2019-03-09 16:13:21 UTC
+++ plugins/stardict/mapfile.hpp
-@@ -9,6 +9,7 @@
- # include <sys/types.h>
- # include <fcntl.h>
- # include <sys/mman.h>
-+# include <unistd.h>
- #endif
- #ifdef _WIN32
+@@ -14,6 +14,7 @@
# include <windows.h>
+ #endif
+ #include <glib.h>
++#include <unistd.h>
+
+ class MapFile
+ {
diff --git a/textproc/qstardict/files/patch-qstardict.pri b/textproc/qstardict/files/patch-qstardict.pri
deleted file mode 100644
index 080615290367..000000000000
--- a/textproc/qstardict/files/patch-qstardict.pri
+++ /dev/null
@@ -1,10 +0,0 @@
---- qstardict.pri.orig 2016-11-07 11:15:01 UTC
-+++ qstardict.pri
-@@ -49,7 +49,6 @@ win32 {
- }
-
- unix:DEFINES += HAVE_MMAP
--unix:isEmpty(NO_DBUS):!contains(QT_CONFIG, dbus): NO_DBUS = 1
- unix:isEmpty(NO_DBUS):CONFIG += qdbus
- unix:isEmpty(NO_DBUS):DEFINES += QSTARDICT_WITH_DBUS
- isEmpty(NO_TRANSLATIONS):DEFINES += QSTARDICT_WITH_TRANSLATIONS
diff --git a/textproc/qstardict/pkg-plist b/textproc/qstardict/pkg-plist
index 0c97ee39378a..989bab23761f 100644
--- a/textproc/qstardict/pkg-plist
+++ b/textproc/qstardict/pkg-plist
@@ -6,17 +6,17 @@ share/applications/qstardict.desktop
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/THANKS
-share/pixmaps/qstardict.png
-%%NLS%%%%DATADIR%%/translations/qstardict-bg_BG.qm
-%%NLS%%%%DATADIR%%/translations/qstardict-cs_CZ.qm
-%%NLS%%%%DATADIR%%/translations/qstardict-de_DE.qm
-%%NLS%%%%DATADIR%%/translations/qstardict-es_ES.qm
-%%NLS%%%%DATADIR%%/translations/qstardict-fr_FR.qm
-%%NLS%%%%DATADIR%%/translations/qstardict-it_IT.qm
-%%NLS%%%%DATADIR%%/translations/qstardict-lt_LT.qm
-%%NLS%%%%DATADIR%%/translations/qstardict-pl_PL.qm
-%%NLS%%%%DATADIR%%/translations/qstardict-pt_BR.qm
-%%NLS%%%%DATADIR%%/translations/qstardict-ru_RU.qm
-%%NLS%%%%DATADIR%%/translations/qstardict-ua_UA.qm
-%%NLS%%%%DATADIR%%/translations/qstardict-zh_CN.qm
-%%NLS%%%%DATADIR%%/translations/qstardict-zh_TW.qm
+share/icons/hicolor/scalable/apps/qstardict.svg
+%%DATADIR%%/translations/qstardict-bg_BG.qm
+%%DATADIR%%/translations/qstardict-cs_CZ.qm
+%%DATADIR%%/translations/qstardict-de_DE.qm
+%%DATADIR%%/translations/qstardict-es_ES.qm
+%%DATADIR%%/translations/qstardict-fr_FR.qm
+%%DATADIR%%/translations/qstardict-it_IT.qm
+%%DATADIR%%/translations/qstardict-lt_LT.qm
+%%DATADIR%%/translations/qstardict-pl_PL.qm
+%%DATADIR%%/translations/qstardict-pt_BR.qm
+%%DATADIR%%/translations/qstardict-ru_RU.qm
+%%DATADIR%%/translations/qstardict-ua_UA.qm
+%%DATADIR%%/translations/qstardict-zh_CN.qm
+%%DATADIR%%/translations/qstardict-zh_TW.qm