aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2010-06-10 01:03:34 +0800
committerpgj <pgj@FreeBSD.org>2010-06-10 01:03:34 +0800
commit83de4ff8a591b1c6391670f12126198073f39aa8 (patch)
tree79f025d703146ea808cda761582a04569210b99c /textproc
parent56c69c54b5560606ba4e8c140e20bb48e2c01199 (diff)
downloadfreebsd-ports-gnome-83de4ff8a591b1c6391670f12126198073f39aa8.tar.gz
freebsd-ports-gnome-83de4ff8a591b1c6391670f12126198073f39aa8.tar.zst
freebsd-ports-gnome-83de4ff8a591b1c6391670f12126198073f39aa8.zip
- Make it work with tagsoup > 0.8
- Bump PORTREVISION Forgotten by: pgj Reported by: QAT
Diffstat (limited to 'textproc')
-rw-r--r--textproc/hs-hxt/Makefile3
-rw-r--r--textproc/hs-hxt/files/patch-hxt.cabal9
-rw-r--r--textproc/hs-hxt/files/patch-src__Text__XML__HXT__Parser__TagSoup.hs31
3 files changed, 42 insertions, 1 deletions
diff --git a/textproc/hs-hxt/Makefile b/textproc/hs-hxt/Makefile
index d099bbc30782..0473e40dc8bf 100644
--- a/textproc/hs-hxt/Makefile
+++ b/textproc/hs-hxt/Makefile
@@ -7,12 +7,13 @@
PORTNAME= hxt
PORTVERSION= 8.5.2
+PORTREVISION= 1
CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= A collection of tools for processing XML with Haskell
-USE_HACKAGE= curl>=1.3 deepseq>=1.1 tagsoup==0.8
+USE_HACKAGE= curl>=1.3 deepseq>=1.1 tagsoup>=0.8
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/textproc/hs-hxt/files/patch-hxt.cabal b/textproc/hs-hxt/files/patch-hxt.cabal
new file mode 100644
index 000000000000..242be88b609b
--- /dev/null
+++ b/textproc/hs-hxt/files/patch-hxt.cabal
@@ -0,0 +1,9 @@
+--- ./hxt.cabal.orig 2010-03-15 13:38:37.000000000 +0100
++++ ./hxt.cabal 2010-06-07 05:17:35.000000000 +0200
+@@ -173,5 +173,5 @@
+ network >= 2.1 && < 3,
+ deepseq >= 1.1 && < 2,
+ bytestring >= 0.9 && < 1,
+- tagsoup >= 0.8 && < 0.9,
++ tagsoup,
+ curl >= 1.3 && < 2
diff --git a/textproc/hs-hxt/files/patch-src__Text__XML__HXT__Parser__TagSoup.hs b/textproc/hs-hxt/files/patch-src__Text__XML__HXT__Parser__TagSoup.hs
new file mode 100644
index 000000000000..cdd4e43dedd7
--- /dev/null
+++ b/textproc/hs-hxt/files/patch-src__Text__XML__HXT__Parser__TagSoup.hs
@@ -0,0 +1,31 @@
+--- ./src/Text/XML/HXT/Parser/TagSoup.hs.orig 2010-03-15 13:38:36.000000000 +0100
++++ ./src/Text/XML/HXT/Parser/TagSoup.hs 2010-06-07 05:27:36.000000000 +0200
+@@ -240,8 +240,8 @@
+
+ -- own entity lookup to prevent problems with &amp; and tagsoup hack for IE
+
+-lookupEntity :: Bool -> Bool -> String -> Tags
+-lookupEntity withWarnings _asHtml e0@('#':e)
++lookupEntity :: Bool -> Bool -> (String, Bool) -> Tags
++lookupEntity withWarnings _asHtml (e0@('#':e), b)
+ = case lookupNumericEntity e of
+ Just c -> [ TagText [c] ]
+ Nothing -> ( TagText $ "&" ++ e0 ++ ";") :
+@@ -249,7 +249,7 @@
+ then [TagWarning $ "illegal char reference: &" ++ e ++ ";"]
+ else []
+
+-lookupEntity withWarnings asHtml e
++lookupEntity withWarnings asHtml (e, b)
+ = case (lookup e entities) of
+ Just x -> [TagText [toEnum x]]
+ Nothing -> (TagText $ "&" ++ e ++ ";") :
+@@ -266,7 +266,7 @@
+ | null r = (s, r)
+ | otherwise = ("&" ++ s ++ [';'|b], r)
+ where
+- (TagText s) : r = lookupEntity withWarnings asHtml e
++ (TagText s) : r = lookupEntity withWarnings asHtml (e, b)
+
+ -- ----------------------------------------
+ {-