aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
author0mp <0mp@FreeBSD.org>2018-11-19 23:25:08 +0800
committer0mp <0mp@FreeBSD.org>2018-11-19 23:25:08 +0800
commit856f63cc00154c0f417e61e3d7bb218de9e1ebf8 (patch)
tree4a13cc74e538779e6a89aba9f108a747b997307e /textproc
parent602306d7e2fadc83aa09256fb3df88b25ddcd133 (diff)
downloadfreebsd-ports-gnome-856f63cc00154c0f417e61e3d7bb218de9e1ebf8.tar.gz
freebsd-ports-gnome-856f63cc00154c0f417e61e3d7bb218de9e1ebf8.tar.zst
freebsd-ports-gnome-856f63cc00154c0f417e61e3d7bb218de9e1ebf8.zip
New port: textproc/chkascii: Check an ASCII text file for invalid characters
chkascii is a small C program that checks files for any ASCII values that are possibly junk. The following are considered the only good ASCII values permissible in a text file: 32-126, 9, 10 The user can optionally force additional ASCII values to be treated as good. For good text files, chkascii will wind up by checking on proper EOL termination. If the file is not EOL-terminated, that too is reported as an error. WWW: https://github.com/bourne-again/chkascii PR: 233254 Submitted by: bourne.identity@hotmail.com Reviewed by: krion Approved by: krion (mentor) Differential Revision: https://reviews.freebsd.org/D18047
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/chkascii/Makefile23
-rw-r--r--textproc/chkascii/distinfo3
-rw-r--r--textproc/chkascii/pkg-descr16
4 files changed, 43 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e2e0fd55c785..bac4d7213bb7 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -85,6 +85,7 @@
SUBDIR += cdiff
SUBDIR += cgrep
SUBDIR += chpp
+ SUBDIR += chkascii
SUBDIR += cl-meta
SUBDIR += cl-meta-sbcl
SUBDIR += cl-ppcre
diff --git a/textproc/chkascii/Makefile b/textproc/chkascii/Makefile
new file mode 100644
index 000000000000..d4fe07a53587
--- /dev/null
+++ b/textproc/chkascii/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= chkascii
+DISTVERSION= 1.0
+CATEGORIES= textproc
+
+MAINTAINER= bourne.identity@hotmail.com
+COMMENT= Check an ASCII text file for invalid characters
+
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= bourne-again
+
+PLIST_FILES= bin/chkascii \
+ man/man1/chkascii.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/chkascii ${STAGEDIR}${PREFIX}/bin/chkascii
+ ${INSTALL_MAN} ${WRKSRC}/chkascii.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/textproc/chkascii/distinfo b/textproc/chkascii/distinfo
new file mode 100644
index 000000000000..8c06128e5b51
--- /dev/null
+++ b/textproc/chkascii/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1542639723
+SHA256 (bourne-again-chkascii-1.0_GH0.tar.gz) = e25dfa56022894a62b0ebc8f5457871a99c8ccf9f632c6a193f05dbefc27d8ef
+SIZE (bourne-again-chkascii-1.0_GH0.tar.gz) = 9895
diff --git a/textproc/chkascii/pkg-descr b/textproc/chkascii/pkg-descr
new file mode 100644
index 000000000000..f0563411d7ac
--- /dev/null
+++ b/textproc/chkascii/pkg-descr
@@ -0,0 +1,16 @@
+chkascii is a small C program that checks files for any ASCII values
+that are possibly junk. The following are considered the only good ASCII
+values permissible in a text file:
+
+32-126
+9
+10
+
+The user can optionally force additional ASCII values to be treated as
+good.
+
+For good text files, chkascii will wind up by checking on proper EOL
+termination. If the file is not EOL-terminated, that too is reported as
+an error.
+
+WWW: https://github.com/bourne-again/chkascii