aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2009-07-17 01:32:11 +0800
committerRenato Botelho <garga@FreeBSD.org>2009-07-17 01:32:11 +0800
commit8593ce8c5c97f703516ffc6289055c816f4b2a4c (patch)
tree082b45b3a0a278588220e0faac9947c448015740 /textproc
parent060e40869e3ed391ffd31d793618f4efbcd52f71 (diff)
downloadfreebsd-ports-gnome-8593ce8c5c97f703516ffc6289055c816f4b2a4c.tar.gz
freebsd-ports-gnome-8593ce8c5c97f703516ffc6289055c816f4b2a4c.tar.zst
freebsd-ports-gnome-8593ce8c5c97f703516ffc6289055c816f4b2a4c.zip
This keyboard is designed to enable simple input of most Latin script
languages, including all major European Latin-script languages. The keyboard is written in KMN Keyboard Language by the KMN language developer, Tavultesoft (http://www.tavultesoft.com). The keyboard uses punctuation and letter keys in sequence to access diacritic and other letters. This port installs the keyboard so that it can be used through SCIM KMFL IMEngine (textproc/scim-kmfl-imengine). Some of the supported languages include: Afrikaans, Albanian, Balearic, Basque, Breton, Catalan, Croatian, Czech, Danish, Dutch, Esperanto, Estonian, Faroese, Finnish, French, Gaelic, Galician, German, Hungarian, Icelandic, Inuktitut, Italian, Kashubian, Ladin, Latvian, Lithuanian, Maltese, Norwegian, Nynorsk, Polish, Portugese, Romansch, Saami, Serbian, Slovak, Slovenian, Sorbian, Spanish, Swedish, Tagalog, Turkish, Valencian, Vlaams, Walloon, Welsh and Zulu. The keyboard is distributed under the terms of 3-clause BSD-licence. WWW: http://eurolatin.keymankeyboards.com/ PR: ports/136150 Submitted by: Nikola Lecic <nikola.lecic at anthesphoria.net>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/kmfl-european-latin/Makefile64
-rw-r--r--textproc/kmfl-european-latin/distinfo3
-rw-r--r--textproc/kmfl-european-latin/pkg-descr21
-rw-r--r--textproc/scim-kmfl-european-latin/Makefile64
-rw-r--r--textproc/scim-kmfl-european-latin/distinfo3
-rw-r--r--textproc/scim-kmfl-european-latin/pkg-descr21
7 files changed, 177 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 0ed813960b8d..3553edf03cbc 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1050,6 +1050,7 @@
SUBDIR += scim-bridge
SUBDIR += scim-bridge-qt4
SUBDIR += scim-input-pad
+ SUBDIR += scim-kmfl-european-latin
SUBDIR += scim-kmfl-imengine
SUBDIR += scim-kmfl-sil-ipa-unicode5
SUBDIR += scim-m17n
diff --git a/textproc/kmfl-european-latin/Makefile b/textproc/kmfl-european-latin/Makefile
new file mode 100644
index 000000000000..c2324644f396
--- /dev/null
+++ b/textproc/kmfl-european-latin/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: scim-kmfl-european-latin
+# Date created: 27 June 2009
+# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
+#
+# $FreeBSD$
+
+PORTNAME= scim-kmfl-european-latin
+PORTVERSION= 1.2
+CATEGORIES= textproc
+MASTER_SITES= http://eurolatin.keymankeyboards.com/ \
+ http://anthesphoria.net/FreeBSD/ports/distfiles/
+DISTNAME= eurolatin-${PORTVERSION}
+
+MAINTAINER= nikola.lecic@anthesphoria.net
+COMMENT= Paneuropean Latin KMFL SCIM IMEngine keyboard covering 42 languages
+
+RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp \
+ ${LOCALBASE}/lib/scim-1.0/1.4.0/IMEngine/kmfl.so:${PORTSDIR}/textproc/scim-kmfl-imengine
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+USE_ZIP= yes
+
+DOCSDIR_REL= share/doc/kmfl/${PORTNAME}
+DOCSDIR= ${PREFIX}/${DOCSDIR_REL}
+SCIM_KMFL_DIR= share/scim/kmfl
+SCIM_KMFL_ICONS_DIR= share/scim/kmfl/icons
+
+PORTDOCS= *
+DOCSLIST= eurolatin12.pdf european.html licence.txt readme.html \
+ welcome.htm
+PLIST_FILES= ${SCIM_KMFL_DIR}/european.kmn \
+ ${SCIM_KMFL_ICONS_DIR}/european.bmp \
+ ${SCIM_KMFL_ICONS_DIR}/latin.bmp \
+ ${SCIM_KMFL_ICONS_DIR}/latin.ico
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|latin.ico|latin.bmp|' ${WRKSRC}/european.kmn
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/*.kmn ${LOCALBASE}/${SCIM_KMFL_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.bmp ${WRKSRC}/*.ico \
+ ${LOCALBASE}/${SCIM_KMFL_ICONS_DIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ for doc in ${DOCSLIST} ; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$doc ${DOCSDIR} ; \
+ done
+.endif
+
+post-install:
+ @${ECHO_MSG} "--------------------------------------------------------"
+ @${ECHO_MSG} " You should now have the new keyboard in the section"
+ @${ECHO_MSG} " \"Others\" in your SCIM menu. If you don't see it,"
+ @${ECHO_MSG} " restart X."
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG}
+ @${ECHO_MSG} " The PDF documentation for use of the European Latin"
+ @${ECHO_MSG} " Keyboard can be found in:"
+ @${ECHO_MSG} " ${PREFIX}/share/doc/kmfl/scim-kmfl-european-latin/"
+.endif
+ @${ECHO_MSG} "--------------------------------------------------------"
+
+.include <bsd.port.mk>
diff --git a/textproc/kmfl-european-latin/distinfo b/textproc/kmfl-european-latin/distinfo
new file mode 100644
index 000000000000..a85dae8761e3
--- /dev/null
+++ b/textproc/kmfl-european-latin/distinfo
@@ -0,0 +1,3 @@
+MD5 (eurolatin-1.2.zip) = 7785b7102296521294eb8c5db7f13a07
+SHA256 (eurolatin-1.2.zip) = 9a31983c240d1b3e46474a264e904b69dc3cc058eea25c7185e99af211454a77
+SIZE (eurolatin-1.2.zip) = 362966
diff --git a/textproc/kmfl-european-latin/pkg-descr b/textproc/kmfl-european-latin/pkg-descr
new file mode 100644
index 000000000000..01638056e9dd
--- /dev/null
+++ b/textproc/kmfl-european-latin/pkg-descr
@@ -0,0 +1,21 @@
+This keyboard is designed to enable simple input of most Latin script
+languages, including all major European Latin-script languages. The
+keyboard is written in KMN Keyboard Language by the KMN language
+developer, Tavultesoft (http://www.tavultesoft.com). The keyboard
+uses punctuation and letter keys in sequence to access diacritic and
+other letters.
+
+This port installs the keyboard so that it can be used through SCIM
+KMFL IMEngine (textproc/scim-kmfl-imengine).
+
+Some of the supported languages include: Afrikaans, Albanian,
+Balearic, Basque, Breton, Catalan, Croatian, Czech, Danish, Dutch,
+Esperanto, Estonian, Faroese, Finnish, French, Gaelic, Galician,
+German, Hungarian, Icelandic, Inuktitut, Italian, Kashubian, Ladin,
+Latvian, Lithuanian, Maltese, Norwegian, Nynorsk, Polish, Portugese,
+Romansch, Saami, Serbian, Slovak, Slovenian, Sorbian, Spanish,
+Swedish, Tagalog, Turkish, Valencian, Vlaams, Walloon, Welsh and Zulu.
+
+The keyboard is distributed under the terms of 3-clause BSD-licence.
+
+WWW: http://eurolatin.keymankeyboards.com/
diff --git a/textproc/scim-kmfl-european-latin/Makefile b/textproc/scim-kmfl-european-latin/Makefile
new file mode 100644
index 000000000000..c2324644f396
--- /dev/null
+++ b/textproc/scim-kmfl-european-latin/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: scim-kmfl-european-latin
+# Date created: 27 June 2009
+# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
+#
+# $FreeBSD$
+
+PORTNAME= scim-kmfl-european-latin
+PORTVERSION= 1.2
+CATEGORIES= textproc
+MASTER_SITES= http://eurolatin.keymankeyboards.com/ \
+ http://anthesphoria.net/FreeBSD/ports/distfiles/
+DISTNAME= eurolatin-${PORTVERSION}
+
+MAINTAINER= nikola.lecic@anthesphoria.net
+COMMENT= Paneuropean Latin KMFL SCIM IMEngine keyboard covering 42 languages
+
+RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp \
+ ${LOCALBASE}/lib/scim-1.0/1.4.0/IMEngine/kmfl.so:${PORTSDIR}/textproc/scim-kmfl-imengine
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+USE_ZIP= yes
+
+DOCSDIR_REL= share/doc/kmfl/${PORTNAME}
+DOCSDIR= ${PREFIX}/${DOCSDIR_REL}
+SCIM_KMFL_DIR= share/scim/kmfl
+SCIM_KMFL_ICONS_DIR= share/scim/kmfl/icons
+
+PORTDOCS= *
+DOCSLIST= eurolatin12.pdf european.html licence.txt readme.html \
+ welcome.htm
+PLIST_FILES= ${SCIM_KMFL_DIR}/european.kmn \
+ ${SCIM_KMFL_ICONS_DIR}/european.bmp \
+ ${SCIM_KMFL_ICONS_DIR}/latin.bmp \
+ ${SCIM_KMFL_ICONS_DIR}/latin.ico
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|latin.ico|latin.bmp|' ${WRKSRC}/european.kmn
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/*.kmn ${LOCALBASE}/${SCIM_KMFL_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.bmp ${WRKSRC}/*.ico \
+ ${LOCALBASE}/${SCIM_KMFL_ICONS_DIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ for doc in ${DOCSLIST} ; do \
+ ${INSTALL_DATA} ${WRKSRC}/$$doc ${DOCSDIR} ; \
+ done
+.endif
+
+post-install:
+ @${ECHO_MSG} "--------------------------------------------------------"
+ @${ECHO_MSG} " You should now have the new keyboard in the section"
+ @${ECHO_MSG} " \"Others\" in your SCIM menu. If you don't see it,"
+ @${ECHO_MSG} " restart X."
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG}
+ @${ECHO_MSG} " The PDF documentation for use of the European Latin"
+ @${ECHO_MSG} " Keyboard can be found in:"
+ @${ECHO_MSG} " ${PREFIX}/share/doc/kmfl/scim-kmfl-european-latin/"
+.endif
+ @${ECHO_MSG} "--------------------------------------------------------"
+
+.include <bsd.port.mk>
diff --git a/textproc/scim-kmfl-european-latin/distinfo b/textproc/scim-kmfl-european-latin/distinfo
new file mode 100644
index 000000000000..a85dae8761e3
--- /dev/null
+++ b/textproc/scim-kmfl-european-latin/distinfo
@@ -0,0 +1,3 @@
+MD5 (eurolatin-1.2.zip) = 7785b7102296521294eb8c5db7f13a07
+SHA256 (eurolatin-1.2.zip) = 9a31983c240d1b3e46474a264e904b69dc3cc058eea25c7185e99af211454a77
+SIZE (eurolatin-1.2.zip) = 362966
diff --git a/textproc/scim-kmfl-european-latin/pkg-descr b/textproc/scim-kmfl-european-latin/pkg-descr
new file mode 100644
index 000000000000..01638056e9dd
--- /dev/null
+++ b/textproc/scim-kmfl-european-latin/pkg-descr
@@ -0,0 +1,21 @@
+This keyboard is designed to enable simple input of most Latin script
+languages, including all major European Latin-script languages. The
+keyboard is written in KMN Keyboard Language by the KMN language
+developer, Tavultesoft (http://www.tavultesoft.com). The keyboard
+uses punctuation and letter keys in sequence to access diacritic and
+other letters.
+
+This port installs the keyboard so that it can be used through SCIM
+KMFL IMEngine (textproc/scim-kmfl-imengine).
+
+Some of the supported languages include: Afrikaans, Albanian,
+Balearic, Basque, Breton, Catalan, Croatian, Czech, Danish, Dutch,
+Esperanto, Estonian, Faroese, Finnish, French, Gaelic, Galician,
+German, Hungarian, Icelandic, Inuktitut, Italian, Kashubian, Ladin,
+Latvian, Lithuanian, Maltese, Norwegian, Nynorsk, Polish, Portugese,
+Romansch, Saami, Serbian, Slovak, Slovenian, Sorbian, Spanish,
+Swedish, Tagalog, Turkish, Valencian, Vlaams, Walloon, Welsh and Zulu.
+
+The keyboard is distributed under the terms of 3-clause BSD-licence.
+
+WWW: http://eurolatin.keymankeyboards.com/