aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-08-04 03:58:19 +0800
committerpawel <pawel@FreeBSD.org>2014-08-04 03:58:19 +0800
commit937b620a407cd217eff13facb556fcc571e536d9 (patch)
tree7e0fd75d0c33cae9e813572ba7d4c6545751e1ae /textproc
parent0ea75ddf4b12cf9c3d46c960527da95480e78d1a (diff)
downloadfreebsd-ports-gnome-937b620a407cd217eff13facb556fcc571e536d9.tar.gz
freebsd-ports-gnome-937b620a407cd217eff13facb556fcc571e536d9.tar.zst
freebsd-ports-gnome-937b620a407cd217eff13facb556fcc571e536d9.zip
- Add staging support
- Convert to new options framework
Diffstat (limited to 'textproc')
-rw-r--r--textproc/muse/Makefile36
1 files changed, 12 insertions, 24 deletions
diff --git a/textproc/muse/Makefile b/textproc/muse/Makefile
index 641f21f3d769..8b18edc6fa94 100644
--- a/textproc/muse/Makefile
+++ b/textproc/muse/Makefile
@@ -21,34 +21,22 @@ INFO= muse
LISPDIR= ${PREFIX}/${EMACS_SITE_LISPDIR}/${PORTNAME}
-.if !defined(NOPORTDOCS)
PORTDOCS= AUTHORS ChangeLog ChangeLog.1 ChangeLog.2 ChangeLog.3 NEWS \
README scripts COPYING
-.endif
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-install:
- ${MKDIR} ${LISPDIR}/contrib
-.for i in *
- ${CP} -R ${WRKSRC}/contrib/${i} ${LISPDIR}/contrib
-.endfor
-
- ${MKDIR} ${LISPDIR}/experimental
-.for i in *
- ${INSTALL_DATA} ${WRKSRC}/experimental/${i} ${LISPDIR}/experimental
-.endfor
-
- ${MKDIR} ${EXAMPLESDIR}
-.for i in *
- ${CP} -R ${WRKSRC}/examples/${i} ${EXAMPLESDIR}
-.endfor
-
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${CP} -R ${WRKSRC}/${i} ${DOCSDIR}
-.endfor
-.endif
+ @${MKDIR} ${STAGEDIR}${LISPDIR}/contrib
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} contrib ${STAGEDIR}${LISPDIR})
+ ${INSTALL_DATA} ${WRKSRC}/experimental/* \
+ ${STAGEDIR}${LISPDIR}/experimental
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|scripts||:S|^|${WRKSRC}/|} \
+ ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} scripts ${STAGEDIR}${DOCSDIR})
.include <bsd.port.pre.mk>