aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2006-08-07 07:21:41 +0800
committerhq <hq@FreeBSD.org>2006-08-07 07:21:41 +0800
commit93e222d8a49527678610d889ec1978db2c241dfe (patch)
tree7ecc13f94965170720f6b630063aee17ea82f5cc /textproc
parent5d1649d1451013c9b39eec3f5e9bb86d8e0fb360 (diff)
downloadfreebsd-ports-gnome-93e222d8a49527678610d889ec1978db2c241dfe.tar.gz
freebsd-ports-gnome-93e222d8a49527678610d889ec1978db2c241dfe.tar.zst
freebsd-ports-gnome-93e222d8a49527678610d889ec1978db2c241dfe.zip
- Re-enable Java 1.5 [1]
- Use exec(1) to launch the JVM - Set CLASSPATH so that it only contains the required JAR files Submitted by: mi [1] (a long time ago on freebsd-java@)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xalan-j/Makefile9
-rw-r--r--textproc/xalan-j/files/xalan-j.sh.in3
2 files changed, 7 insertions, 5 deletions
diff --git a/textproc/xalan-j/Makefile b/textproc/xalan-j/Makefile
index bbc6bcfbbc22..e345159a0df5 100644
--- a/textproc/xalan-j/Makefile
+++ b/textproc/xalan-j/Makefile
@@ -15,11 +15,10 @@ DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}-src
MAINTAINER= hq@FreeBSD.org
COMMENT= Apache XSLT processor for transforming XML documents
-RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper \
- ${JAVALIBDIR}/xml-apis.jar:${PORTSDIR}/textproc/xerces-j
+RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
USE_JAVA= yes
-JAVA_VERSION= 1.2 1.3 1.4
+JAVA_VERSION= 1.2+
USE_ANT= yes
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION:S/./_/g}
@@ -35,6 +34,10 @@ SUB_FILES= xalan-j.sh
.include <bsd.port.pre.mk>
+.if ${JAVA_PORT_VERSION:C/^([0-9])\.([0-9])(.*)$/\1.\2/} != "1.5"
+RUN_DEPENDS+= ${JAVALIBDIR}/xml-apis.jar:${PORTSDIR}/textproc/xerces-j
+.endif
+
do-install:
@${ECHO_MSG} -n ">> Installing JAR files in ${JAVAJARDIR}..."
.for jarfile in ${JARFILES}
diff --git a/textproc/xalan-j/files/xalan-j.sh.in b/textproc/xalan-j/files/xalan-j.sh.in
index 463d16dae2ab..89dbf4c58adf 100644
--- a/textproc/xalan-j/files/xalan-j.sh.in
+++ b/textproc/xalan-j/files/xalan-j.sh.in
@@ -1,5 +1,4 @@
#!/bin/sh
# $FreeBSD$
-export CLASSPATH="`%%LOCALBASE%%/bin/classpath`:%%JAVAJARDIR%%/xalan.jar"
-JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" org.apache.xalan.xslt.Process "$@"
+JAVA_VERSION="%%JAVA_VERSION%%" exec "%%LOCALBASE%%/bin/java" -cp "%%JAVALIBDIR%%/xml-apis.jar:%%JAVALIBDIR/xercesImpl.jar:%%JAVAJARDIR%%/xalan.jar" org.apache.xalan.xslt.Process "$@"