aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-07-09 16:05:30 +0800
committeryuri <yuri@FreeBSD.org>2018-07-09 16:05:30 +0800
commit97f478c31505d019aa53f5d5d37b949256e38210 (patch)
treeeee0dc7a05ef481ed07246f4777e628391511d96 /textproc
parent35d54c64aaf8891407e041e3a6662df225f26ebb (diff)
downloadfreebsd-ports-gnome-97f478c31505d019aa53f5d5d37b949256e38210.tar.gz
freebsd-ports-gnome-97f478c31505d019aa53f5d5d37b949256e38210.tar.zst
freebsd-ports-gnome-97f478c31505d019aa53f5d5d37b949256e38210.zip
textproc/zxing-cpp: Update 0.20161114 -> 0.20180320
Port changes: * Switch to the static library * Order USExx section * It now depends on OpenCV
Diffstat (limited to 'textproc')
-rw-r--r--textproc/zxing-cpp/Makefile11
-rw-r--r--textproc/zxing-cpp/distinfo6
-rw-r--r--textproc/zxing-cpp/files/patch-CMakeLists.txt11
-rw-r--r--textproc/zxing-cpp/files/patch-core_src_zxing_DecodeHints.cpp11
-rw-r--r--textproc/zxing-cpp/files/patch-core_src_zxing_oned_OneDReader.cpp4
-rw-r--r--textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.cpp14
-rw-r--r--textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.h19
-rw-r--r--textproc/zxing-cpp/pkg-plist7
8 files changed, 29 insertions, 54 deletions
diff --git a/textproc/zxing-cpp/Makefile b/textproc/zxing-cpp/Makefile
index 78186da6f134..fe5ba575dd2f 100644
--- a/textproc/zxing-cpp/Makefile
+++ b/textproc/zxing-cpp/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= zxing-cpp
-PORTVERSION= 0.20161114
-DISTVERSIONPREFIX= v
+DISTVERSION= 0.20180320
CATEGORIES= textproc
MAINTAINER= yuri@FreeBSD.org
@@ -12,10 +11,14 @@ COMMENT= ZXing C++ Library for QR code recognition
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/COPYING
+LIB_DEPENDS= libopencv_core.so:graphics/opencv-core \
+ libopencv_photo.so:graphics/opencv
+
+USES= cmake:outsource iconv
USE_GITHUB= yes
GH_ACCOUNT= glassechidna
-GH_TAGNAME= 97e9c5c
+GH_TAGNAME= 5aad474
-USES= cmake:outsource iconv
+CMAKE_ARGS= -DBUILD_SHARED_LIBS=ON
.include <bsd.port.mk>
diff --git a/textproc/zxing-cpp/distinfo b/textproc/zxing-cpp/distinfo
index 74e1bdedb42f..fc97544ab718 100644
--- a/textproc/zxing-cpp/distinfo
+++ b/textproc/zxing-cpp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1479160657
-SHA256 (glassechidna-zxing-cpp-v0.20161114-97e9c5c_GH0.tar.gz) = 5084329c0d3a045b2c1e416c42e8f52bf4b1afea5d44cb9442b8af12a19cba05
-SIZE (glassechidna-zxing-cpp-v0.20161114-97e9c5c_GH0.tar.gz) = 307807
+TIMESTAMP = 1531121512
+SHA256 (glassechidna-zxing-cpp-0.20180320-5aad474_GH0.tar.gz) = dee73f487b9160582a48dd71d521a48403a635d0f482a6a6ddfa331daf938f57
+SIZE (glassechidna-zxing-cpp-0.20180320-5aad474_GH0.tar.gz) = 312290
diff --git a/textproc/zxing-cpp/files/patch-CMakeLists.txt b/textproc/zxing-cpp/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..251a61278629
--- /dev/null
+++ b/textproc/zxing-cpp/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2018-07-09 07:47:42 UTC
++++ CMakeLists.txt
+@@ -83,7 +83,7 @@ file(GLOB_RECURSE ZXING_FILES
+ )
+
+ add_executable(zxing ${ZXING_FILES})
+-target_link_libraries(zxing libzxing)
++target_link_libraries(zxing libzxing ${OpenCV_LIBRARIES})
+
+ install(TARGETS zxing libzxing EXPORT zxing-targets
+ LIBRARY DESTINATION lib
diff --git a/textproc/zxing-cpp/files/patch-core_src_zxing_DecodeHints.cpp b/textproc/zxing-cpp/files/patch-core_src_zxing_DecodeHints.cpp
deleted file mode 100644
index 59ca7b777c9f..000000000000
--- a/textproc/zxing-cpp/files/patch-core_src_zxing_DecodeHints.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- core/src/zxing/DecodeHints.cpp.orig 2016-11-10 14:45:28 UTC
-+++ core/src/zxing/DecodeHints.cpp
-@@ -29,7 +29,7 @@ using zxing::DecodeHints;
- // VC++
- using zxing::BarcodeFormat;
-
--// const DecodeHintType DecodeHints::CHARACTER_SET;
-+const DecodeHintType DecodeHints::CHARACTER_SET;
-
- const DecodeHints DecodeHints::PRODUCT_HINT(
- UPC_A_HINT |
diff --git a/textproc/zxing-cpp/files/patch-core_src_zxing_oned_OneDReader.cpp b/textproc/zxing-cpp/files/patch-core_src_zxing_oned_OneDReader.cpp
index 7ea729463064..8de3d6aeb92d 100644
--- a/textproc/zxing-cpp/files/patch-core_src_zxing_oned_OneDReader.cpp
+++ b/textproc/zxing-cpp/files/patch-core_src_zxing_oned_OneDReader.cpp
@@ -1,4 +1,4 @@
---- core/src/zxing/oned/OneDReader.cpp.orig 2016-11-10 14:45:28 UTC
+--- core/src/zxing/oned/OneDReader.cpp.orig 2018-03-20 15:08:49 UTC
+++ core/src/zxing/oned/OneDReader.cpp
@@ -21,6 +21,7 @@
#include <zxing/oned/OneDResultPoint.h>
@@ -7,4 +7,4 @@
+#include <float.h>
#include <limits.h>
#include <algorithm>
-
+ #include <cfloat>
diff --git a/textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.cpp b/textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.cpp
deleted file mode 100644
index 3b5cad6c226f..000000000000
--- a/textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- core/src/zxing/pdf417/detector/LinesSampler.cpp.orig 2016-11-10 14:45:28 UTC
-+++ core/src/zxing/pdf417/detector/LinesSampler.cpp
-@@ -75,6 +75,11 @@ VoteResult getValueWithMaxVotes(map<int,
-
- }
-
-+const int LinesSampler::MODULES_IN_SYMBOL = 17;
-+const int LinesSampler::BARS_IN_SYMBOL = 8;
-+const int LinesSampler::POSSIBLE_SYMBOLS = 2787;
-+const int LinesSampler::BARCODE_START_OFFSET = 2;
-+
- vector<float> LinesSampler::init_ratios_table() {
- // Pre-computes and outputs the symbol ratio table.
- vector<vector<float> > table (BitMatrixParser::SYMBOL_TABLE_LENGTH);
diff --git a/textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.h b/textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.h
deleted file mode 100644
index 221ef74afe8f..000000000000
--- a/textproc/zxing-cpp/files/patch-core_src_zxing_pdf417_detector_LinesSampler.h
+++ /dev/null
@@ -1,19 +0,0 @@
---- core/src/zxing/pdf417/detector/LinesSampler.h.orig 2016-11-14 22:55:07 UTC
-+++ core/src/zxing/pdf417/detector/LinesSampler.h
-@@ -28,12 +28,12 @@ namespace detector {
-
- class LinesSampler {
- protected:
-- static const int MODULES_IN_SYMBOL = 17;
-- static const int BARS_IN_SYMBOL = 8;
-- static const int POSSIBLE_SYMBOLS = 2787;
-+ static const int MODULES_IN_SYMBOL;
-+ static const int BARS_IN_SYMBOL;
-+ static const int POSSIBLE_SYMBOLS;
- static const std::vector<float> RATIOS_TABLE;
- static std::vector<float> init_ratios_table();
-- static const int BARCODE_START_OFFSET = 2;
-+ static const int BARCODE_START_OFFSET;
-
- Ref<BitMatrix> linesMatrix_;
- int symbolsPerLine_;
diff --git a/textproc/zxing-cpp/pkg-plist b/textproc/zxing-cpp/pkg-plist
index ac1762747232..71f8c1b93a6e 100644
--- a/textproc/zxing-cpp/pkg-plist
+++ b/textproc/zxing-cpp/pkg-plist
@@ -9,6 +9,7 @@ include/zxing/FormatException.h
include/zxing/IllegalStateException.h
include/zxing/InvertedLuminanceSource.h
include/zxing/LuminanceSource.h
+include/zxing/MatSource.h
include/zxing/MultiFormatReader.h
include/zxing/NotFoundException.h
include/zxing/Reader.h
@@ -101,4 +102,8 @@ include/zxing/qrcode/detector/Detector.h
include/zxing/qrcode/detector/FinderPattern.h
include/zxing/qrcode/detector/FinderPatternFinder.h
include/zxing/qrcode/detector/FinderPatternInfo.h
-lib/libzxing.a
+lib/libzxing.so
+lib/zxing/cmake/zxing-config.cmake
+lib/zxing/cmake/zxing-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/zxing/cmake/zxing-targets.cmake
+