aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-11-13 20:54:57 +0800
committertrevor <trevor@FreeBSD.org>2003-11-13 20:54:57 +0800
commit99ccbb6b71b7698a171b47b4acb288b8115e0a5b (patch)
tree8539a8273e773aa9e7e4c8e20ed94e1cbb1e2352 /textproc
parentf32647514bf03eb1a573982c5d55b2d3188a2e39 (diff)
downloadfreebsd-ports-gnome-99ccbb6b71b7698a171b47b4acb288b8115e0a5b.tar.gz
freebsd-ports-gnome-99ccbb6b71b7698a171b47b4acb288b8115e0a5b.tar.zst
freebsd-ports-gnome-99ccbb6b71b7698a171b47b4acb288b8115e0a5b.zip
Use the FIND and XARGS macros introduced in bsd.port.mk 1.391.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/coco/Makefile2
-rw-r--r--textproc/dsssl-docbook-modular/Makefile4
-rw-r--r--textproc/fop/Makefile3
-rw-r--r--textproc/html/Makefile2
-rw-r--r--textproc/jade/Makefile3
-rw-r--r--textproc/p5-RDF-Core/Makefile2
-rw-r--r--textproc/p5-RDF-Notation3/Makefile2
-rw-r--r--textproc/p5-SVG/Makefile2
-rw-r--r--textproc/p5-XML-Directory/Makefile2
-rw-r--r--textproc/py-xml/Makefile4
-rw-r--r--textproc/scrollkeeper/Makefile2
-rw-r--r--textproc/webcpp/Makefile2
12 files changed, 16 insertions, 14 deletions
diff --git a/textproc/coco/Makefile b/textproc/coco/Makefile
index 7b69f815d5a4..0d0e9319041e 100644
--- a/textproc/coco/Makefile
+++ b/textproc/coco/Makefile
@@ -40,7 +40,7 @@ pre-patch:
# delete dust files before build
pre-build:
- find ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
+ ${FIND} ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
${RM} -f ${WRKSRC}/etc/DOC* ${WRKSRC}/src/emacs ${WRKSRC}/src/emacs-${EMACS_VERSION}.*
.include <bsd.port.mk>
diff --git a/textproc/dsssl-docbook-modular/Makefile b/textproc/dsssl-docbook-modular/Makefile
index 7b1ee10ef2ec..bc08fa7f6f0f 100644
--- a/textproc/dsssl-docbook-modular/Makefile
+++ b/textproc/dsssl-docbook-modular/Makefile
@@ -35,8 +35,8 @@ do-build:
pre-install:
@[ -d ${INSTDIR} ] || ${MKDIR} ${INSTDIR}
- @find ${WRKDIR} -name '*~' -exec ${RM} {} \;
- @find ${WRKDIR} -name '*.orig' -exec ${RM} {} \;
+ @${FIND} ${WRKDIR} -name '*~' -exec ${RM} {} \;
+ @${FIND} ${WRKDIR} -name '*.orig' -exec ${RM} {} \;
do-install:
@${CP} -Rp ${WRKSRC}/* ${INSTDIR}
diff --git a/textproc/fop/Makefile b/textproc/fop/Makefile
index e13599ce333e..d644dcc18ca5 100644
--- a/textproc/fop/Makefile
+++ b/textproc/fop/Makefile
@@ -26,7 +26,8 @@ JAVA_LIBDIR= ${PREFIX}/share/java/classes
pre-install:
${MKDIR} ${JAVA_LIBDIR} ${DATADIR} ${DOCSDIR}
- find ${WRKSRC} \( -name \*.orig -o -name \*~ -o -name CVS \) -exec ${RM} -rf \{} \;
+ ${FIND} ${WRKSRC} \( -name \*.orig -o -name \*~ -o -name CVS \) \
+ -exec ${RM} -rf \{} \;
do-install:
cd ${WRKSRC}; \
diff --git a/textproc/html/Makefile b/textproc/html/Makefile
index cb66cfe61c19..2a7fb8e55e7c 100644
--- a/textproc/html/Makefile
+++ b/textproc/html/Makefile
@@ -34,7 +34,7 @@ pre-install:
do-install:
@zcat ${DISTDIR}/${DISTFILES} |(cd ${INSTDIR}; pax -r)
- @${CHMOD} ${SHAREMODE} `find ${INSTDIR} -type f`
+ @${CHMOD} ${SHAREMODE} `${FIND} ${INSTDIR} -type f`
@${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${INSTDIR}
post-install:
diff --git a/textproc/jade/Makefile b/textproc/jade/Makefile
index f9116e773434..377a7171808d 100644
--- a/textproc/jade/Makefile
+++ b/textproc/jade/Makefile
@@ -34,7 +34,8 @@ post-extract:
@${CHMOD} u+w ${WRKSRC}/configure
pre-install:
- @find ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
+ @${FIND} ${WRKSRC} \( -name \*.orig -o -name \*~ \) \
+ -exec ${RM} -f \{} \;
post-install:
.for i in jade nsgmls sgmlnorm spam spent sx
diff --git a/textproc/p5-RDF-Core/Makefile b/textproc/p5-RDF-Core/Makefile
index f5bf623f652a..29b2d7aa87b0 100644
--- a/textproc/p5-RDF-Core/Makefile
+++ b/textproc/p5-RDF-Core/Makefile
@@ -40,7 +40,7 @@ DOCSUBDIR= / RDF RDF/Core RDF/Core/Enumerator RDF/Core/Model \
RDF/Core/Storage
pre-patch:
- @find ${WRKSRC} -name "*.pm" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "*.pm" | ${XARGS} ${PERL} -pi -e \
'$$package=$$1 if /^package\s+([^\s;]*);/; s!^require 5.005_62;!!; s!^use warnings;!!; s!^our\s+(\$$)(VERSION)\s+=!$$1$${package}::$$2=!;'
post-install:
diff --git a/textproc/p5-RDF-Notation3/Makefile b/textproc/p5-RDF-Notation3/Makefile
index 6e1e36a364b4..b8dcc66818b5 100644
--- a/textproc/p5-RDF-Notation3/Makefile
+++ b/textproc/p5-RDF-Notation3/Makefile
@@ -32,7 +32,7 @@ MAN3= RDF::Notation3.3 RDF::Notation3::PrefTriples.3 \
RDF::Notation3::XML.3
pre-patch:
- @${FIND} ${WRKSRC} -name "*.pm" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "*.pm" | ${XARGS} ${PERL} -pi -e \
'$$package=$$1 if /^package\s+([^\s;]*);/; s!^require 5.005_62;!!; s!^use warnings;!!; s!^our\s+(\$$)(VERSION)\s+=!$$1$${package}::$$2=!;'
.include <bsd.port.pre.mk>
diff --git a/textproc/p5-SVG/Makefile b/textproc/p5-SVG/Makefile
index 89216e2cedbe..8e499593a1cc 100644
--- a/textproc/p5-SVG/Makefile
+++ b/textproc/p5-SVG/Makefile
@@ -21,7 +21,7 @@ MAN3= SVG.3 SVG::DOM.3 SVG::Element.3 SVG::Manual.3 SVG::XML.3
post-patch:
@${FIND} ${WRKSRC} \( -name "*.p[lm]" -or -name "*.cgi" \
- -or -name "*.pod" \)|xargs ${PERL} -pi -e 's/\x0d//g;'
+ -or -name "*.pod" \)|${XARGS} ${PERL} -pi -e 's/\x0d//g;'
post-install:
.ifndef(NOPORTDOCS)
diff --git a/textproc/p5-XML-Directory/Makefile b/textproc/p5-XML-Directory/Makefile
index bebe61e08b61..cca041900583 100644
--- a/textproc/p5-XML-Directory/Makefile
+++ b/textproc/p5-XML-Directory/Makefile
@@ -26,7 +26,7 @@ MAN3= XML::Directory.3 XML::Directory::Apache.3 \
pre-patch:
- @find ${WRKSRC} -name "*.pm" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "*.pm" | ${XARGS} ${PERL} -pi -e \
'$$package=$$1 if /^package\s+([^\s;]*);/; s!^require 5.005_62;!!; s!^use warnings;!!; s!^our\s+(\$$|@)(VERSION|ISA|EXPORT|EXPORT_OK)\s+=!$$1$${package}::$$2=!;'
.include <bsd.port.pre.mk>
diff --git a/textproc/py-xml/Makefile b/textproc/py-xml/Makefile
index adb92ca4444e..3db18f469bf3 100644
--- a/textproc/py-xml/Makefile
+++ b/textproc/py-xml/Makefile
@@ -37,10 +37,10 @@ post-install:
.for docfile in ANNOUNCE CREDITS LICENCE README* TODO
@ ${INSTALL_DATA} ${WRKSRC}/${docfile} ${DOCSDIR}
.endfor
- @ cd ${WRKSRC}/doc && find * \
+ @ cd ${WRKSRC}/doc && ${FIND} * \
| ${CPIO} ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
@ ${MKDIR} ${EXAMPLESDIR}
- @ cd ${WRKSRC} && find demo test \
+ @ cd ${WRKSRC} && ${FIND} demo test \
| ${CPIO} ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif
diff --git a/textproc/scrollkeeper/Makefile b/textproc/scrollkeeper/Makefile
index baf33bc16df6..1edc7cacfcf3 100644
--- a/textproc/scrollkeeper/Makefile
+++ b/textproc/scrollkeeper/Makefile
@@ -62,7 +62,7 @@ MTREE_FILE= /etc/mtree/BSD.x11-4.dist
.endif
post-patch:
- @find ${WRKSRC} -name Makefile.in | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|[(]LN_S[)] -f -n|(LN_S) -f|g'
@${REINPLACE_CMD} -e 's|/usr/share/locale|${PREFIX}/share/locale|g' \
${WRKSRC}/libs/scrollkeeper.h.in
diff --git a/textproc/webcpp/Makefile b/textproc/webcpp/Makefile
index 2e61ff1e48c5..c1889b23664f 100644
--- a/textproc/webcpp/Makefile
+++ b/textproc/webcpp/Makefile
@@ -27,7 +27,7 @@ USE_GMAKE= yes
.endif
pre-patch:
- ${FIND} ${WRKSRC} -name '*.h' | xargs ${REINPLACE_CMD} \
+ ${FIND} ${WRKSRC} -name '*.h' | ${XARGS} ${REINPLACE_CMD} \
's|IO->close()|if(IO) IO->close()|g'
post-install: