aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2002-05-27 16:51:51 +0800
committerskv <skv@FreeBSD.org>2002-05-27 16:51:51 +0800
commit9c3de94fce4053f76b03e745db44abe56927a8ab (patch)
tree9e7b3382fc197f8c872267a5c4aac85ddf6b41ca /textproc
parentd6054595ce9c4bb52f050bb24fff63cbc1ef9110 (diff)
downloadfreebsd-ports-gnome-9c3de94fce4053f76b03e745db44abe56927a8ab.tar.gz
freebsd-ports-gnome-9c3de94fce4053f76b03e745db44abe56927a8ab.tar.zst
freebsd-ports-gnome-9c3de94fce4053f76b03e745db44abe56927a8ab.zip
Add p5-XML-Filter-SAXT 0.01,
replicates SAX events to several SAX event handlers.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-XML-Filter-SAXT/Makefile22
-rw-r--r--textproc/p5-XML-Filter-SAXT/distinfo1
-rw-r--r--textproc/p5-XML-Filter-SAXT/pkg-comment1
-rw-r--r--textproc/p5-XML-Filter-SAXT/pkg-descr9
-rw-r--r--textproc/p5-XML-Filter-SAXT/pkg-plist7
6 files changed, 41 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 602ee037a453..e73488819352 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -188,6 +188,7 @@
SUBDIR += p5-XML-Filter-Base
SUBDIR += p5-XML-Filter-BufferText
SUBDIR += p5-XML-Filter-DetectWS
+ SUBDIR += p5-XML-Filter-SAXT
SUBDIR += p5-XML-Filter-XSLT
SUBDIR += p5-XML-Generator-DBI
SUBDIR += p5-XML-Handler-Trees
diff --git a/textproc/p5-XML-Filter-SAXT/Makefile b/textproc/p5-XML-Filter-SAXT/Makefile
new file mode 100644
index 000000000000..2d654377d04e
--- /dev/null
+++ b/textproc/p5-XML-Filter-SAXT/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: XML::Filter::SAXT
+# Date created: 13 Mar 2002
+# Whom: Sergey Skvortsov <skv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Filter-SAXT
+PORTVERSION= 0.01
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= XML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Filter::SAXT.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-Filter-SAXT/distinfo b/textproc/p5-XML-Filter-SAXT/distinfo
new file mode 100644
index 000000000000..9f7e48adee2d
--- /dev/null
+++ b/textproc/p5-XML-Filter-SAXT/distinfo
@@ -0,0 +1 @@
+MD5 (XML-Filter-SAXT-0.01.tar.gz) = da65cbe1938bff4c8975014c80063e05
diff --git a/textproc/p5-XML-Filter-SAXT/pkg-comment b/textproc/p5-XML-Filter-SAXT/pkg-comment
new file mode 100644
index 000000000000..ec1b07d8f85f
--- /dev/null
+++ b/textproc/p5-XML-Filter-SAXT/pkg-comment
@@ -0,0 +1 @@
+Replicates SAX events to several SAX event handlers
diff --git a/textproc/p5-XML-Filter-SAXT/pkg-descr b/textproc/p5-XML-Filter-SAXT/pkg-descr
new file mode 100644
index 000000000000..34065470b9c3
--- /dev/null
+++ b/textproc/p5-XML-Filter-SAXT/pkg-descr
@@ -0,0 +1,9 @@
+SAXT is like the Unix 'tee' command in that it multiplexes the input
+stream to several output streams. In this case, the input stream is a
+PerlSAX event producer (like XML::Parser::PerlSAX) and the output
+streams are PerlSAX handlers or filters.
+
+WWW: http://search.cpan.org/search?dist=XML-Filter-SAXT
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/textproc/p5-XML-Filter-SAXT/pkg-plist b/textproc/p5-XML-Filter-SAXT/pkg-plist
new file mode 100644
index 000000000000..d85a30b3f069
--- /dev/null
+++ b/textproc/p5-XML-Filter-SAXT/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Filter/SAXT/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/XML/Filter/SAXT.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Filter/SAXT
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML/Filter 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/Filter 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true