aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-11-04 22:20:39 +0800
committerwg <wg@FreeBSD.org>2013-11-04 22:20:39 +0800
commita32f0968324a36ef7bb4581c64a1abcab439c779 (patch)
tree145b505af1b7414d88bb3fbbb037ef8d88258ff3 /textproc
parent239454ae660a0460093aeee4c0b10dac3519467e (diff)
downloadfreebsd-ports-gnome-a32f0968324a36ef7bb4581c64a1abcab439c779.tar.gz
freebsd-ports-gnome-a32f0968324a36ef7bb4581c64a1abcab439c779.tar.zst
freebsd-ports-gnome-a32f0968324a36ef7bb4581c64a1abcab439c779.zip
textproc/apache-poi: update to 3.9
- Update to 3.9 - Rename it to jakarta-poi - Allow staging PR: ports/181308 Submitted by: Pedro Giffuni <giffunip tutopia.com> Approved by: maintainer (timeout)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/apache-poi/Makefile51
-rw-r--r--textproc/apache-poi/distinfo2
-rw-r--r--textproc/apache-poi/pkg-descr (renamed from textproc/jakarta-poi/pkg-descr)2
-rw-r--r--textproc/jakarta-poi/Makefile50
-rw-r--r--textproc/jakarta-poi/distinfo2
5 files changed, 54 insertions, 53 deletions
diff --git a/textproc/apache-poi/Makefile b/textproc/apache-poi/Makefile
new file mode 100644
index 000000000000..446e7db7c1b4
--- /dev/null
+++ b/textproc/apache-poi/Makefile
@@ -0,0 +1,51 @@
+# Created by: Anton Yudin <toha@toha.org.ua>
+# $FreeBSD$
+
+PORTNAME= poi
+PORTVERSION= 3.9
+CATEGORIES= textproc devel java
+MASTER_SITES= ${MASTER_SITE_APACHE}
+MASTER_SITE_SUBDIR= ${PORTNAME:S,-,/,}/release/src
+PKGNAMEPREFIX= apache-
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}-20121203
+
+MAINTAINER= toha@toha.org.ua
+COMMENT= Java API To Access Microsoft Format Files
+
+BUILD_DEPENDS= ${JAVALIBDIR}/xalan.jar:${PORTSDIR}/textproc/xalan-j
+
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+DSTAMP= `date +%Y%m%d`
+
+USE_ANT= yes
+MAKE_ARGS=
+MAKE_ENV+= ANT_INCLUDE_SHARED_JARS=YES
+PORTDOCS= *
+ALL_TARGET= jar
+JARFILE= ${PORTNAME}-${PORTVERSION}-${DSTAMP}.jar
+DESTJARFILE= ${PORTNAME}.jar
+JARNAMES= examples excelant scratchpad ooxml ooxml-schemas
+
+PLIST_FILES= %%JAVAJARDIR%%/${DESTJARFILE}
+
+.for i in ${JARNAMES}
+PLIST_FILES+=%%JAVAJARDIR%%/${PORTNAME}-${i}.jar
+.endfor
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/build/dist/${JARFILE} ${JAVAJARDIR}/${DESTJARFILE}
+.for i in ${JARNAMES}
+ ${INSTALL_DATA} ${WRKSRC}/build/dist/${PORTNAME}-${i}-${PORTVERSION}-${DSTAMP}.jar ${JAVAJARDIR}/${PORTNAME}-${i}.jar
+.endfor
+ cd ${WRKSRC}/docs/apidocs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
+
+# Workaround stage and ANT bug
+do-build:
+ @(cd ${BUILD_WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${ANT} ${ALL_TARGET})
+
+.include <bsd.port.mk>
diff --git a/textproc/apache-poi/distinfo b/textproc/apache-poi/distinfo
new file mode 100644
index 000000000000..4b33ab562847
--- /dev/null
+++ b/textproc/apache-poi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (poi-src-3.9-20121203.tar.gz) = 15f948546525a73438ef6544e8ba006813b79a4a7e8529582c99e3926c238ead
+SIZE (poi-src-3.9-20121203.tar.gz) = 48227396
diff --git a/textproc/jakarta-poi/pkg-descr b/textproc/apache-poi/pkg-descr
index d7e1374c28cd..4e8e78471584 100644
--- a/textproc/jakarta-poi/pkg-descr
+++ b/textproc/apache-poi/pkg-descr
@@ -5,4 +5,4 @@ write Word files using Java. POI is your Java Excel solution as well as your
Word Excel solution. However, we have a complete API for porting other OLE 2
Compound Document formats and welcome others to participate.
-WWW: http://jakarta.apache.org/poi/
+WWW: http://poi.apache.org/
diff --git a/textproc/jakarta-poi/Makefile b/textproc/jakarta-poi/Makefile
deleted file mode 100644
index aac3fc99fa00..000000000000
--- a/textproc/jakarta-poi/Makefile
+++ /dev/null
@@ -1,50 +0,0 @@
-# Created by: Anton Yudin <toha@toha.org.ua>
-# $FreeBSD$
-
-PORTNAME= poi
-PORTVERSION= 2.5.1
-PORTREVISION= 2
-CATEGORIES= textproc devel java
-MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
-MASTER_SITE_SUBDIR= ${PORTNAME:S,-,/,}/release/src
-PKGNAMEPREFIX= jakarta-
-DISTNAME= ${PORTNAME}-src-${PORTVERSION}-final-20040804
-
-MAINTAINER= toha@toha.org.ua
-COMMENT= Java API To Access Microsoft Format Files
-
-BUILD_DEPENDS= ${JAVALIBDIR}/xalan.jar:${PORTSDIR}/textproc/xalan-j
-
-USE_JAVA= yes
-JAVA_VERSION= 1.6+
-
-NO_WRKSUBDIR= yes
-
-DSTAMP= `date +%Y%m%d`
-
-USE_ANT= yes
-MAKE_ENV+= ANT_INCLUDE_SHARED_JARS=YES
-.if !defined(NOPORTDOCS)
-PORTDOCS= *
-.endif
-ALL_TARGET= jar
-JARFILE= ${PORTNAME}-${PORTVERSION}-final-${DSTAMP}.jar
-DESTJARFILE= ${PORTNAME}.jar
-
-PLIST_FILES= %%JAVAJARDIR%%/${DESTJARFILE}
-
-NO_STAGE= yes
-do-install:
- @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${DESTJARFILE}..."
- @${INSTALL_DATA} ${WRKSRC}/build/dist/${JARFILE} ${JAVAJARDIR}/${DESTJARFILE}
- @${ECHO_MSG} " [ DONE ]"
-
-.if !defined(NOPORTDOCS)
- @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
- @cd ${WRKSRC}/docs/apidocs \
- && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
- && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
- @${ECHO_MSG} " [ DONE ]"
-.endif
-
-.include <bsd.port.mk>
diff --git a/textproc/jakarta-poi/distinfo b/textproc/jakarta-poi/distinfo
deleted file mode 100644
index 5d9e8211fc85..000000000000
--- a/textproc/jakarta-poi/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (poi-src-2.5.1-final-20040804.tar.gz) = 783c6c36b9762aafd3386adcfbe71ad46aaa14d9fe20545c4a60eb591cfe0cc1
-SIZE (poi-src-2.5.1-final-20040804.tar.gz) = 6870414