aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-09-04 22:57:27 +0800
committeryuri <yuri@FreeBSD.org>2018-09-04 22:57:27 +0800
commita4bd3c92d94bff9a5182ea728a9b6f70b6e8f668 (patch)
treeafdddcb8667b026b01e03d07a0710cc3de8210a2 /textproc
parent356e1e53e9b748549ed85477f8c89b0a718cf806 (diff)
downloadfreebsd-ports-gnome-a4bd3c92d94bff9a5182ea728a9b6f70b6e8f668.tar.gz
freebsd-ports-gnome-a4bd3c92d94bff9a5182ea728a9b6f70b6e8f668.tar.zst
freebsd-ports-gnome-a4bd3c92d94bff9a5182ea728a9b6f70b6e8f668.zip
New port: textproc/xmlf90: Suite of light-weight libraries to work with XML in Fortran
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/fox-xml/Makefile2
-rw-r--r--textproc/xmlf90/Makefile25
-rw-r--r--textproc/xmlf90/distinfo3
-rw-r--r--textproc/xmlf90/files/patch-config_data_xmlf90.mk.in10
-rw-r--r--textproc/xmlf90/pkg-descr18
-rw-r--r--textproc/xmlf90/pkg-plist46
7 files changed, 105 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 750174e4c50c..aeb4ddd32664 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1833,6 +1833,7 @@
SUBDIR += xmlcharent
SUBDIR += xmldiff
SUBDIR += xmlenc
+ SUBDIR += xmlf90
SUBDIR += xmlformat
SUBDIR += xmlgen
SUBDIR += xmlindent
diff --git a/textproc/fox-xml/Makefile b/textproc/fox-xml/Makefile
index d01e8943e4f1..c36028fed6d1 100644
--- a/textproc/fox-xml/Makefile
+++ b/textproc/fox-xml/Makefile
@@ -13,6 +13,8 @@ COMMENT= Fortran XML library
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+CONFLICTS_INSTALL= xmlf90
+
GNU_CONFIGURE= yes
USES= fortran gmake
USE_GITHUB= yes
diff --git a/textproc/xmlf90/Makefile b/textproc/xmlf90/Makefile
new file mode 100644
index 000000000000..eb15a389897c
--- /dev/null
+++ b/textproc/xmlf90/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= xmlf90
+DISTVERSION= 1.5.4
+CATEGORIES= textproc
+MASTER_SITES= https://launchpad.net/xmlf90/trunk/1.5/+download/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Suite of light-weight libraries to work with XML in Fortran
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+CONFLICTS_INSTALL= fox-xml
+
+USES= fortran gmake libtool
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= DOCS
+
+PORTDOCS= *
+
+.include <bsd.port.mk>
diff --git a/textproc/xmlf90/distinfo b/textproc/xmlf90/distinfo
new file mode 100644
index 000000000000..193dac8ec1d8
--- /dev/null
+++ b/textproc/xmlf90/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536046355
+SHA256 (xmlf90-1.5.4.tar.gz) = a0b1324ff224d5b5ad1127a6ad4f90979f6b127f1a517f98253eea377237bbe4
+SIZE (xmlf90-1.5.4.tar.gz) = 1013508
diff --git a/textproc/xmlf90/files/patch-config_data_xmlf90.mk.in b/textproc/xmlf90/files/patch-config_data_xmlf90.mk.in
new file mode 100644
index 000000000000..baeefac61245
--- /dev/null
+++ b/textproc/xmlf90/files/patch-config_data_xmlf90.mk.in
@@ -0,0 +1,10 @@
+--- config/data/xmlf90.mk.in.orig 2018-09-04 07:46:34 UTC
++++ config/data/xmlf90.mk.in
+@@ -18,6 +18,6 @@ XMLF90_H__ = 1
+
+ XMLF90_ROOT_BUILD = @prefix@
+ XMLF90_INCFLAGS = -I$(XMLF90_ROOT_BUILD)/include
+-XMLF90_LIBS = $(XMLF90_ROOT_BUILD)/lib/libxmlf90.a
++XMLF90_LIBS = $(XMLF90_ROOT_BUILD)/lib/libxmlf90.so
+
+ endif
diff --git a/textproc/xmlf90/pkg-descr b/textproc/xmlf90/pkg-descr
new file mode 100644
index 000000000000..7f9699e34736
--- /dev/null
+++ b/textproc/xmlf90/pkg-descr
@@ -0,0 +1,18 @@
+xmlf90 is a suite of libraries to handle XML in Fortran. It has two
+major components:
+
+* A XML parsing library. The parser was designed to be a useful
+ tool in the extraction and analysis of data in the context of
+ scientific computing, and thus the priorities were efficiency and the
+ ability to deal with very large XML files while maintaining a small
+ memory footprint. The most complete programming interface is
+ based on the very successful SAX (Simple API for XML) model,
+ although a partial DOM interface and a very experimental XPATH interface
+ are also present.
+
+- A library (xmlf90-wxml) that facilitates the writing of well-formed
+ XML, including such features as automatic start-tag completion,
+ attribute pretty-printing, and element indentation. There are also
+ helper routines to handle the output of numerical arrays.
+
+WWW: https://launchpad.net/xmlf90
diff --git a/textproc/xmlf90/pkg-plist b/textproc/xmlf90/pkg-plist
new file mode 100644
index 000000000000..64e4937df2b7
--- /dev/null
+++ b/textproc/xmlf90/pkg-plist
@@ -0,0 +1,46 @@
+include/m_dom_attribute.mod
+include/m_dom_debug.mod
+include/m_dom_document.mod
+include/m_dom_element.mod
+include/m_dom_error.mod
+include/m_dom_namednodemap.mod
+include/m_dom_node.mod
+include/m_dom_nodelist.mod
+include/m_dom_parse.mod
+include/m_dom_strings.mod
+include/m_dom_types.mod
+include/m_dom_utils.mod
+include/m_sax_buffer.mod
+include/m_sax_charset.mod
+include/m_sax_converters.mod
+include/m_sax_debug.mod
+include/m_sax_dictionary.mod
+include/m_sax_elstack.mod
+include/m_sax_entities.mod
+include/m_sax_fsm.mod
+include/m_sax_reader.mod
+include/m_wcml.mod
+include/m_wstml.mod
+include/m_wxml_array_str.mod
+include/m_wxml_buffer.mod
+include/m_wxml_core.mod
+include/m_wxml_dictionary.mod
+include/m_wxml_elstack.mod
+include/m_wxml_error.mod
+include/m_wxml_escape.mod
+include/m_wxml_overloads.mod
+include/m_wxml_text.mod
+include/m_xml_error.mod
+include/m_xml_parser.mod
+include/m_xpath_api.mod
+include/xmlf90_cml.mod
+include/xmlf90_dom.mod
+include/xmlf90_info.mod
+include/xmlf90_sax.mod
+include/xmlf90_wxml.mod
+include/xmlf90_xpath.mod
+lib/libxmlf90.so
+lib/libxmlf90.so.0
+lib/libxmlf90.so.0.0.0
+libdata/pkgconfig/xmlf90.pc
+share/org.siesta-project/xmlf90.mk