aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2015-10-06 00:54:13 +0800
committerolivierd <olivierd@FreeBSD.org>2015-10-06 00:54:13 +0800
commita5e7e3b3b0c55f6bb7e355ef6b6d3dea9b271f68 (patch)
treef57fc98bde56181c65765cfbfad602ff9db46690 /textproc
parent16b7e76421dbc47fe81664b0934d8428a1bf18d1 (diff)
downloadfreebsd-ports-gnome-a5e7e3b3b0c55f6bb7e355ef6b6d3dea9b271f68.tar.gz
freebsd-ports-gnome-a5e7e3b3b0c55f6bb7e355ef6b6d3dea9b271f68.tar.zst
freebsd-ports-gnome-a5e7e3b3b0c55f6bb7e355ef6b6d3dea9b271f68.zip
gspell provides a flexible API to implement the spell checking in a GTK+
application. WWW: https://github.com/swilmet/gspell
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/gspell/Makefile33
-rw-r--r--textproc/gspell/distinfo2
-rw-r--r--textproc/gspell/files/patch-configure11
-rw-r--r--textproc/gspell/pkg-descr4
-rw-r--r--textproc/gspell/pkg-plist48
6 files changed, 99 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index f0db8532ff61..e3673744cc2b 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -223,6 +223,7 @@
SUBDIR += groff
SUBDIR += groonga
SUBDIR += gsed
+ SUBDIR += gspell
SUBDIR += gtk-doc
SUBDIR += gtkspell
SUBDIR += gtkspell-reference
diff --git a/textproc/gspell/Makefile b/textproc/gspell/Makefile
new file mode 100644
index 000000000000..a0712f0185f9
--- /dev/null
+++ b/textproc/gspell/Makefile
@@ -0,0 +1,33 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+
+PORTNAME= gspell
+PORTVERSION= 0.1.0
+CATEGORIES= textproc
+MASTER_SITES= https://people.gnome.org/~swilmet/gspell/
+
+MAINTAINER= olivierd@FreeBSD.org
+COMMENT= Spell checking for GTK+
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala \
+ iso-codes>=3.57:${PORTSDIR}/misc/iso-codes
+LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant
+
+USES= gmake iconv libtool pathfix pkgconfig tar:xz
+USE_GNOME= glib20 gtksourceview3 introspection:build libxml2
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+
+CONFIGURE_ARGS=--enable-introspection=yes \
+ --enable-compile-warnings=no \
+ --without-html-dir
+
+OPTIONS_DEFINE= NLS
+NLS_USES= gettext-tools
+NLS_CONFIGURE_ENABLE= nls
+OPTIONS_SUB= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/gspell/distinfo b/textproc/gspell/distinfo
new file mode 100644
index 000000000000..88d8011ff89f
--- /dev/null
+++ b/textproc/gspell/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gspell-0.1.0.tar.xz) = 8c10c5c447ca8c4a230516bd89bcfb00791fe3b4a7bbd4f34a53c72505db9628
+SIZE (gspell-0.1.0.tar.xz) = 353140
diff --git a/textproc/gspell/files/patch-configure b/textproc/gspell/files/patch-configure
new file mode 100644
index 000000000000..db67451582ef
--- /dev/null
+++ b/textproc/gspell/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2015-09-30 18:57:09 UTC
++++ configure
+@@ -4288,7 +4288,7 @@ fi
+ if test "${with_pkgconfigdir+set}" = set; then :
+ withval=$with_pkgconfigdir;
+ else
+- with_pkgconfigdir='${libdir}/pkgconfig'
++ with_pkgconfigdir='${prefix}/libdata/pkgconfig'
+ fi
+
+ pkgconfigdir=$with_pkgconfigdir
diff --git a/textproc/gspell/pkg-descr b/textproc/gspell/pkg-descr
new file mode 100644
index 000000000000..92141bba9e8f
--- /dev/null
+++ b/textproc/gspell/pkg-descr
@@ -0,0 +1,4 @@
+gspell provides a flexible API to implement the spell checking in a GTK+
+application.
+
+WWW: https://github.com/swilmet/gspell
diff --git a/textproc/gspell/pkg-plist b/textproc/gspell/pkg-plist
new file mode 100644
index 000000000000..09decb485d11
--- /dev/null
+++ b/textproc/gspell/pkg-plist
@@ -0,0 +1,48 @@
+include/gspell-1/gspell/gspell-checker-dialog.h
+include/gspell-1/gspell/gspell-checker.h
+include/gspell-1/gspell/gspell-inline-checker-gtv.h
+include/gspell-1/gspell/gspell-language-chooser-button.h
+include/gspell-1/gspell/gspell-language-chooser-dialog.h
+include/gspell-1/gspell/gspell-language-chooser.h
+include/gspell-1/gspell/gspell-language.h
+include/gspell-1/gspell/gspell-navigator-gtv.h
+include/gspell-1/gspell/gspell-navigator.h
+include/gspell-1/gspell/gspell.h
+lib/girepository-1.0/Gspell-1.typelib
+lib/libgspell-1.so
+lib/libgspell-1.so.0
+lib/libgspell-1.so.0.0.0
+libdata/pkgconfig/gspell-1.pc
+share/gir-1.0/Gspell-1.gir
+%%NLS%%share/locale/ar/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/da/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/el/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/es/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/he/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/gspell-1.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/gspell-1.mo
+share/vala/vapi/gspell-1.deps
+share/vala/vapi/gspell-1.vapi