aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-03-13 02:38:55 +0800
committerswills <swills@FreeBSD.org>2011-03-13 02:38:55 +0800
commita607cd24cf1eb318921201f4910bd86b6306446f (patch)
tree2b2857b307de707b0096303808eb9caa62db3716 /textproc
parent2eaff345d51409ee6fdd2be3129dba7652c0898d (diff)
downloadfreebsd-ports-gnome-a607cd24cf1eb318921201f4910bd86b6306446f.tar.gz
freebsd-ports-gnome-a607cd24cf1eb318921201f4910bd86b6306446f.tar.zst
freebsd-ports-gnome-a607cd24cf1eb318921201f4910bd86b6306446f.zip
Perl module which implements version 4.0 of the Wordnik API and provides a
simple object-oriented interface with methods named after the REST ones provided by Wordnik. WWW: http://search.cpan.org/dist/WWW-Wordnik-API/
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-WWW-Wordnik-API/Makefile29
-rw-r--r--textproc/p5-WWW-Wordnik-API/distinfo2
-rw-r--r--textproc/p5-WWW-Wordnik-API/pkg-descr5
4 files changed, 37 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index c2b2b98835af..013fc6e7b5c9 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -790,6 +790,7 @@
SUBDIR += p5-Vroom
SUBDIR += p5-WDDX
SUBDIR += p5-WWW-Google-SiteMap
+ SUBDIR += p5-WWW-Wordnik-API
SUBDIR += p5-WordNet-QueryData
SUBDIR += p5-WordNet-Similarity
SUBDIR += p5-XML-Atom
diff --git a/textproc/p5-WWW-Wordnik-API/Makefile b/textproc/p5-WWW-Wordnik-API/Makefile
new file mode 100644
index 000000000000..4ee0131bb7de
--- /dev/null
+++ b/textproc/p5-WWW-Wordnik-API/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-WWW-Wordnik-API
+# Date created: 2011-03-12
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Wordnik-API
+PORTVERSION= 0.0.5
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:PSILVA
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Wordnik API implementation
+
+PERL_CONFIGURE= YES
+
+MAN3= WWW::Wordnik::API.3
+PLIST_FILES= %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Wordnik/API/.packlist \
+ %%SITE_PERL%%/WWW/Wordnik/API.pm
+PLIST_DIRS= %%SITE_PERL%%/WWW/Wordnik %%SITE_PERL%%/WWW \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Wordnik/API \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Wordnik \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-WWW-Wordnik-API/distinfo b/textproc/p5-WWW-Wordnik-API/distinfo
new file mode 100644
index 000000000000..2430d150395c
--- /dev/null
+++ b/textproc/p5-WWW-Wordnik-API/distinfo
@@ -0,0 +1,2 @@
+SHA256 (WWW-Wordnik-API-v0.0.5.tar.gz) = 6ddb49faa31b55d91ff5c09c030753dbb7590a20bc47088cee0982420c40a38a
+SIZE (WWW-Wordnik-API-v0.0.5.tar.gz) = 31438
diff --git a/textproc/p5-WWW-Wordnik-API/pkg-descr b/textproc/p5-WWW-Wordnik-API/pkg-descr
new file mode 100644
index 000000000000..7627575f4065
--- /dev/null
+++ b/textproc/p5-WWW-Wordnik-API/pkg-descr
@@ -0,0 +1,5 @@
+Perl module which implements version 4.0 of the Wordnik API and provides a
+simple object-oriented interface with methods named after the REST ones
+provided by Wordnik.
+
+WWW: http://search.cpan.org/dist/WWW-Wordnik-API/