aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-07-22 03:16:45 +0800
committersat <sat@FreeBSD.org>2007-07-22 03:16:45 +0800
commita96a521603f834512d8d512ed5063aa4e705ed3d (patch)
treee01f5491b469ba9d1d80491de36a5d8f6e1c01cc /textproc
parent3cc6ce2b49c280803df57861b66e31515876d84b (diff)
downloadfreebsd-ports-gnome-a96a521603f834512d8d512ed5063aa4e705ed3d.tar.gz
freebsd-ports-gnome-a96a521603f834512d8d512ed5063aa4e705ed3d.tar.zst
freebsd-ports-gnome-a96a521603f834512d8d512ed5063aa4e705ed3d.zip
Add port textproc/humanzip:
humanzip is a compression program that operates on text files. Unlike most compression algorithms, its output is human readable. Indeed, it is explictly meant to be read by humans and might even be easier to read than the original. humanzip compresses files by looking for common strings of words and replacing them with single symbols. The idea is to reduce the screen and print size of documents. Humanzip does not explictly try to reduce the size of the file as measured in bytes, although this usually happens incidentally. WWW: http://savannah.nongnu.org/projects/humanzip/ Author: Matthew Strait
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/humanzip/Makefile33
-rw-r--r--textproc/humanzip/distinfo3
-rw-r--r--textproc/humanzip/pkg-descr13
4 files changed, 50 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 10157d063c79..c434fc4bbeb2 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -201,6 +201,7 @@
SUBDIR += htmlize.el
SUBDIR += htmlsection
SUBDIR += htmltolatex
+ SUBDIR += humanzip
SUBDIR += hy-aspell
SUBDIR += hyperestraier
SUBDIR += ia-aspell
diff --git a/textproc/humanzip/Makefile b/textproc/humanzip/Makefile
new file mode 100644
index 000000000000..b5c7d7bc8931
--- /dev/null
+++ b/textproc/humanzip/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: humanzip
+# Date created: 21 July 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= humanzip
+PORTVERSION= 0.5
+CATEGORIES= textproc archivers
+MASTER_SITES= SAVANNAH CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Compresses text to human readable output
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|g++|${CXX}|;s|-O2|${CFLAGS}|' \
+ ${WRKSRC}/${MAKEFILE}
+
+MAN1= ${PORTNAME}.1
+MLINKS= ${PORTNAME}.1 humanunzip.1
+PLIST_FILES= bin/${PORTNAME} bin/humanunzip
+PORTDOCS= CHANGELOG README TODO
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/human*zip ${PREFIX}/bin/
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/humanzip/distinfo b/textproc/humanzip/distinfo
new file mode 100644
index 000000000000..5c0163d9f466
--- /dev/null
+++ b/textproc/humanzip/distinfo
@@ -0,0 +1,3 @@
+MD5 (humanzip-0.5.tar.gz) = f4807a54f167a890b2c81733eb3a9c4c
+SHA256 (humanzip-0.5.tar.gz) = 7d48bd18e161117f1aa772bfa1726a001f9058cf6df84c1c4667aefd4b2ccf8e
+SIZE (humanzip-0.5.tar.gz) = 19979
diff --git a/textproc/humanzip/pkg-descr b/textproc/humanzip/pkg-descr
new file mode 100644
index 000000000000..e2f9005d33a1
--- /dev/null
+++ b/textproc/humanzip/pkg-descr
@@ -0,0 +1,13 @@
+humanzip is a compression program that operates on text files. Unlike
+most compression algorithms, its output is human readable. Indeed, it
+is explictly meant to be read by humans and might even be easier to read
+than the original.
+
+humanzip compresses files by looking for common strings of words and
+replacing them with single symbols. The idea is to reduce the screen and
+print size of documents. Humanzip does not explictly try to reduce the
+size of the file as measured in bytes, although this usually happens
+incidentally.
+
+WWW: http://savannah.nongnu.org/projects/humanzip/
+Author: Matthew Strait