aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2014-09-21 23:13:07 +0800
committerdinoex <dinoex@FreeBSD.org>2014-09-21 23:13:07 +0800
commitaaf74ab71161253739e08086624e1b2e43cd8b10 (patch)
tree9add6580f7501287bf60cbb2f4ff6ac79a5259ca /textproc
parentd7f583ee57c84ced44939652e3d0b91adb6910f0 (diff)
downloadfreebsd-ports-gnome-aaf74ab71161253739e08086624e1b2e43cd8b10.tar.gz
freebsd-ports-gnome-aaf74ab71161253739e08086624e1b2e43cd8b10.tar.zst
freebsd-ports-gnome-aaf74ab71161253739e08086624e1b2e43cd8b10.zip
This is a Ruby library for approximate string matching and searching
using a dynamic programming algorithm to compute the Levenstein distance between strings. Written in C for speed. WWW: http://flori.github.io/amatch/
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/rubygem-amatch/Makefile15
-rw-r--r--textproc/rubygem-amatch/distinfo2
-rw-r--r--textproc/rubygem-amatch/pkg-descr5
4 files changed, 23 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4dfd78e6e749..0f0525418266 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1292,6 +1292,7 @@
SUBDIR += ruby-xmlparser
SUBDIR += ruby-xmlscan
SUBDIR += rubygem-albino
+ SUBDIR += rubygem-amatch
SUBDIR += rubygem-asciidoctor
SUBDIR += rubygem-augeas
SUBDIR += rubygem-charlock_holmes
diff --git a/textproc/rubygem-amatch/Makefile b/textproc/rubygem-amatch/Makefile
new file mode 100644
index 000000000000..23752399110a
--- /dev/null
+++ b/textproc/rubygem-amatch/Makefile
@@ -0,0 +1,15 @@
+# $FreeBSD$
+
+PORTNAME= amatch
+PORTVERSION= 0.3.0
+CATEGORIES= textproc rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby library for approximate string matching and searching
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/rubygem-amatch/distinfo b/textproc/rubygem-amatch/distinfo
new file mode 100644
index 000000000000..135c7b3e4c2a
--- /dev/null
+++ b/textproc/rubygem-amatch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/amatch-0.3.0.gem) = 669bac06769ab21d2fbd87839b5aa1b1d9e0eb39971b4404fe88de103685f45d
+SIZE (rubygem/amatch-0.3.0.gem) = 28672
diff --git a/textproc/rubygem-amatch/pkg-descr b/textproc/rubygem-amatch/pkg-descr
new file mode 100644
index 000000000000..3717b7647256
--- /dev/null
+++ b/textproc/rubygem-amatch/pkg-descr
@@ -0,0 +1,5 @@
+This is a Ruby library for approximate string matching and searching
+using a dynamic programming algorithm to compute the Levenstein
+distance between strings. Written in C for speed.
+
+WWW: http://flori.github.io/amatch/