aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-11-23 04:18:37 +0800
committertcberner <tcberner@FreeBSD.org>2018-11-23 04:18:37 +0800
commitaeaabbbd04baa842b0c71d3cf998f23c9471cb13 (patch)
tree61cb3664013fb792e76869e17b47783aadc54052 /textproc
parentb93ec524b74388e856dc1319427475b175db003d (diff)
downloadfreebsd-ports-gnome-aeaabbbd04baa842b0c71d3cf998f23c9471cb13.tar.gz
freebsd-ports-gnome-aeaabbbd04baa842b0c71d3cf998f23c9471cb13.tar.zst
freebsd-ports-gnome-aeaabbbd04baa842b0c71d3cf998f23c9471cb13.zip
pyqt: Change install directories for Python flavor support
* PyQt could not be installed for multiple Python versions at the same time, as there were conflicting files. This patch creates Python-version versioned directories for all these, and further installs binaries with a version number. * Note, there might be some hickups for software that depends on on of the .so's provided by PyQt5, which might not be found anymore autmotically, and maybe need some LD-flaggery. * Update PyQt5 to 5.10.1 * Mark www/py-qt5-webengine broken. It is unforuntately no longer compatible with the old qt5-webengine-5.9.4 we ship. PR: 232745 Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D8714
Diffstat (limited to 'textproc')
-rw-r--r--textproc/py-qt4-xml/Makefile6
-rw-r--r--textproc/py-qt4-xml/pkg-plist2
-rw-r--r--textproc/py-qt4-xmlpatterns/Makefile6
-rw-r--r--textproc/py-qt4-xmlpatterns/pkg-plist2
-rw-r--r--textproc/py-qt5-xml/Makefile5
-rw-r--r--textproc/py-qt5-xml/pkg-plist2
-rw-r--r--textproc/py-qt5-xmlpatterns/Makefile5
-rw-r--r--textproc/py-qt5-xmlpatterns/pkg-plist2
-rw-r--r--textproc/retext/Makefile1
9 files changed, 15 insertions, 16 deletions
diff --git a/textproc/py-qt4-xml/Makefile b/textproc/py-qt4-xml/Makefile
index 67ec6dc20ca3..92c27031c5ef 100644
--- a/textproc/py-qt4-xml/Makefile
+++ b/textproc/py-qt4-xml/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xml
PORTEPOCH= 1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc devel python
MAINTAINER= kde@FreeBSD.org
@@ -14,7 +14,7 @@ PYQT_DIST= yes
USES= python pyqt:4 qt:4
USE_PYQT= sip_build core_run
-USE_PYTHON= flavors
+USE_PYTHON= concurrent flavors py3kplist
USE_QT= corelib xml moc_build qmake_build
OPTIONS_DEFINE= API DEBUG
@@ -22,7 +22,7 @@ OPTIONS_DEFAULT=API
OPTIONS_SUB= yes
API_DESC= Install QtXml API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt4.so:devel/qscintilla2
DEBUG_CONFIGURE_ON= --debug --trace
diff --git a/textproc/py-qt4-xml/pkg-plist b/textproc/py-qt4-xml/pkg-plist
index 0b4d6871ec85..052b909e6da9 100644
--- a/textproc/py-qt4-xml/pkg-plist
+++ b/textproc/py-qt4-xml/pkg-plist
@@ -5,4 +5,4 @@ bin/pyrcc4
%%PYQT_SIPDIR%%/QtXml/qdom.sip
%%PYQT_SIPDIR%%/QtXml/qxml.sip
%%PYQT_SIPDIR%%/QtXml/qxmlstream.sip
-%%API%%share/qt4/qsci/api/python/QtXml.api
+%%API%%%%PYQT_APIDIR%%/api/python/QtXml.api
diff --git a/textproc/py-qt4-xmlpatterns/Makefile b/textproc/py-qt4-xmlpatterns/Makefile
index d389f1e87521..b1a63fa52bdf 100644
--- a/textproc/py-qt4-xmlpatterns/Makefile
+++ b/textproc/py-qt4-xmlpatterns/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xmlpatterns
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= textproc devel python
MAINTAINER= kde@FreeBSD.org
@@ -13,7 +13,7 @@ PYQT_DIST= yes
USES= python pyqt:4 qt:4
USE_PYQT= sip_build core_run network_run
-USE_PYTHON= flavors
+USE_PYTHON= concurrent flavors py3kplist
USE_QT= corelib network xmlpatterns moc_build qmake_build
OPTIONS_DEFINE= API DEBUG
@@ -21,7 +21,7 @@ OPTIONS_DEFAULT=API
OPTIONS_SUB= yes
API_DESC= Install QtXmlPatterns API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt4.so:devel/qscintilla2
DEBUG_CONFIGURE_ON= --debug --trace
diff --git a/textproc/py-qt4-xmlpatterns/pkg-plist b/textproc/py-qt4-xmlpatterns/pkg-plist
index a50fa6d04d37..35f10d1ae41e 100644
--- a/textproc/py-qt4-xmlpatterns/pkg-plist
+++ b/textproc/py-qt4-xmlpatterns/pkg-plist
@@ -14,4 +14,4 @@
%%PYQT_SIPDIR%%/QtXmlPatterns/qxmlschema.sip
%%PYQT_SIPDIR%%/QtXmlPatterns/qxmlschemavalidator.sip
%%PYQT_SIPDIR%%/QtXmlPatterns/qxmlserializer.sip
-%%API%%share/qt4/qsci/api/python/QtXmlPatterns.api
+%%API%%%%PYQT_APIDIR%%/api/python/QtXmlPatterns.api
diff --git a/textproc/py-qt5-xml/Makefile b/textproc/py-qt5-xml/Makefile
index 691bb01ec3bf..26a26c6230de 100644
--- a/textproc/py-qt5-xml/Makefile
+++ b/textproc/py-qt5-xml/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= xml
-PORTREVISION= 6
CATEGORIES= textproc devel python
MAINTAINER= kde@FreeBSD.org
@@ -12,7 +11,7 @@ PYQT_DIST= yes
USES= python pyqt:5 qt:5
USE_PYQT= sip_build core_run
-USE_PYTHON= flavors py3kplist
+USE_PYTHON= concurrent flavors py3kplist
USE_QT= core xml buildtools_build qmake_build
OPTIONS_DEFINE= API DEBUG
@@ -20,7 +19,7 @@ OPTIONS_DEFAULT=API
OPTIONS_SUB= yes
API_DESC= Install QtXml API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
DEBUG_CONFIGURE_ON= --debug --trace
diff --git a/textproc/py-qt5-xml/pkg-plist b/textproc/py-qt5-xml/pkg-plist
index 58134a93546c..1d6ce867b1c9 100644
--- a/textproc/py-qt5-xml/pkg-plist
+++ b/textproc/py-qt5-xml/pkg-plist
@@ -13,4 +13,4 @@ bin/pyrcc5
%%PYQT_SIPDIR%%/QtXml/QtXmlmod.sip
%%PYQT_SIPDIR%%/QtXml/qdom.sip
%%PYQT_SIPDIR%%/QtXml/qxml.sip
-%%API%%share/qt5/qsci/api/python/QtXml.api
+%%API%%%%PYQT_APIDIR%%/api/python/QtXml.api
diff --git a/textproc/py-qt5-xmlpatterns/Makefile b/textproc/py-qt5-xmlpatterns/Makefile
index 1b6974ed770d..4dd131d93e3a 100644
--- a/textproc/py-qt5-xmlpatterns/Makefile
+++ b/textproc/py-qt5-xmlpatterns/Makefile
@@ -1,7 +1,6 @@
# $FreeBSD$
PORTNAME= xmlpatterns
-PORTREVISION= 5
CATEGORIES= textproc devel python
MAINTAINER= kde@FreeBSD.org
@@ -12,7 +11,7 @@ PYQT_DIST= yes
USES= python pyqt:5 qt:5
USE_PYQT= sip_build core_run network_run
-USE_PYTHON= flavors
+USE_PYTHON= concurrent flavors py3kplist
USE_QT= core network xmlpatterns qmake_build
OPTIONS_DEFINE= API DEBUG
@@ -20,7 +19,7 @@ OPTIONS_DEFAULT=API
OPTIONS_SUB= yes
API_DESC= Install QtXmlPatterns API for QScintilla2
-API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${PYQT_APIDIR}
API_CONFIGURE_OFF= --no-qsci-api
API_LIB_DEPENDS= libqscintilla2_qt5.so:devel/qscintilla2-qt5
DEBUG_CONFIGURE_ON= --debug --trace
diff --git a/textproc/py-qt5-xmlpatterns/pkg-plist b/textproc/py-qt5-xmlpatterns/pkg-plist
index c12bac01f0ef..3d9b5d36bc4a 100644
--- a/textproc/py-qt5-xmlpatterns/pkg-plist
+++ b/textproc/py-qt5-xmlpatterns/pkg-plist
@@ -15,4 +15,4 @@
%%PYQT_SIPDIR%%/QtXmlPatterns/qxmlschema.sip
%%PYQT_SIPDIR%%/QtXmlPatterns/qxmlschemavalidator.sip
%%PYQT_SIPDIR%%/QtXmlPatterns/qxmlserializer.sip
-%%API%%share/qt5/qsci/api/python/QtXmlPatterns.api
+%%API%%%%PYQT_APIDIR%%/api/python/QtXmlPatterns.api
diff --git a/textproc/retext/Makefile b/textproc/retext/Makefile
index 5695c6d8801c..ef08c7ddc058 100644
--- a/textproc/retext/Makefile
+++ b/textproc/retext/Makefile
@@ -2,6 +2,7 @@
PORTNAME= retext
PORTVERSION= 7.0.0
+PORTREVISION= 1
CATEGORIES= textproc
MAINTAINER= arved@FreeBSD.org