aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2004-02-03 17:23:23 +0800
committerbland <bland@FreeBSD.org>2004-02-03 17:23:23 +0800
commitafea70a7bf20d6161629abfb2d69e778a011534a (patch)
treee3c276ca5662f848a9823b2d71339a51699ce163 /textproc
parent2fe0432dd587f1878c4acb4942e191bf6e5f2da1 (diff)
downloadfreebsd-ports-gnome-afea70a7bf20d6161629abfb2d69e778a011534a.tar.gz
freebsd-ports-gnome-afea70a7bf20d6161629abfb2d69e778a011534a.tar.zst
freebsd-ports-gnome-afea70a7bf20d6161629abfb2d69e778a011534a.zip
Get rid of .libs in RPATH entries.
PR: 62162 Reported by: Matthias Andree <matthias.andree@gmx.de>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/libxml2/Makefile2
-rw-r--r--textproc/libxml2/files/patch-configure8
-rw-r--r--textproc/libxml2/files/patch-ltmain.sh51
3 files changed, 52 insertions, 9 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 7d0ad8922178..b5c36a79620a 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv
USE_BZIP2= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
USE_GNOME= gnomehack gnometarget pkgconfig
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
diff --git a/textproc/libxml2/files/patch-configure b/textproc/libxml2/files/patch-configure
index d954c8093e1f..06cf509aa607 100644
--- a/textproc/libxml2/files/patch-configure
+++ b/textproc/libxml2/files/patch-configure
@@ -1,13 +1,5 @@
--- configure.orig Thu Aug 14 20:33:30 2003
+++ configure Thu Aug 14 22:12:01 2003
-@@ -8256,6 +8256,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -14275,7 +14276,7 @@
fi
if test "$with_python" != ""
diff --git a/textproc/libxml2/files/patch-ltmain.sh b/textproc/libxml2/files/patch-ltmain.sh
new file mode 100644
index 000000000000..1d5a5c7b87e1
--- /dev/null
+++ b/textproc/libxml2/files/patch-ltmain.sh
@@ -0,0 +1,51 @@
+--- ltmain.sh.orig Fri Sep 12 14:51:51 2003
++++ ltmain.sh Sun Sep 21 17:49:07 2003
+@@ -1280,7 +1280,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1290,8 +1290,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -3000,6 +3008,9 @@
+ # problems, so we reset it completely
+ verstring=
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ verstring="0.0"
+ ;;
+@@ -5428,10 +5439,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"