aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-11-05 02:58:27 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-11-05 02:58:27 +0800
commitb7ef4f6570cdbff99ccb96d5b08880146186685d (patch)
treeaa2d7cd1df41871c114043a055bef6e036a983cd /textproc
parentc8b5b69a71bf31546e81aa0220b3f6a7e948d2a7 (diff)
downloadfreebsd-ports-gnome-b7ef4f6570cdbff99ccb96d5b08880146186685d.tar.gz
freebsd-ports-gnome-b7ef4f6570cdbff99ccb96d5b08880146186685d.tar.zst
freebsd-ports-gnome-b7ef4f6570cdbff99ccb96d5b08880146186685d.zip
Fix PLIST on powerpc*
PR: 232909 (based on) Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xerces-c3/Makefile12
-rw-r--r--textproc/xerces-c3/pkg-plist2
2 files changed, 11 insertions, 3 deletions
diff --git a/textproc/xerces-c3/Makefile b/textproc/xerces-c3/Makefile
index 7e778af110fa..1223fb4fcddf 100644
--- a/textproc/xerces-c3/Makefile
+++ b/textproc/xerces-c3/Makefile
@@ -13,7 +13,7 @@ COMMENT= Validating XML parser from the Apache XML Project
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= cpe gmake iconv libtool pathfix
+USES= cpe iconv libtool pathfix
CONFIGURE_ARGS= --enable-netaccessor-socket \
--enable-transcoder-iconv \
@@ -29,10 +29,18 @@ PLIST_SUB= MAJOR_VER=${PORTVERSION:R}
CPE_PRODUCT= xerces-c++
CPE_VENDOR= apache
+.include <bsd.port.pre.mk>
+
+.if ${ARCH:Mpowerpc*}
+PLIST_SUB+= MUTEXMGR="PosixMutexMgr"
+.else
+PLIST_SUB+= MUTEXMGR="StdMutexMgr"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s,@DEFS@,& -D__STDC_LIMIT_MACROS," ${WRKSRC}/src/Makefile.in
post-install:
${LN} -s libxerces-c-${PORTVERSION:R}.so ${STAGEDIR}${PREFIX}/lib/libxerces-c.so.${PORTVERSION:R:R}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/xerces-c3/pkg-plist b/textproc/xerces-c3/pkg-plist
index 4f0eae9b5a41..bfaeba448512 100644
--- a/textproc/xerces-c3/pkg-plist
+++ b/textproc/xerces-c3/pkg-plist
@@ -264,7 +264,7 @@ include/xercesc/util/KeyValuePair.hpp
include/xercesc/util/LogicalPath.c
include/xercesc/util/MsgLoaders/InMemory/InMemMsgLoader.hpp
include/xercesc/util/MsgLoaders/InMemory/XercesMessages_en_US.hpp
-include/xercesc/util/MutexManagers/StdMutexMgr.hpp
+include/xercesc/util/MutexManagers/%%MUTEXMGR%%.hpp
include/xercesc/util/Mutexes.hpp
include/xercesc/util/NameIdPool.c
include/xercesc/util/NameIdPool.hpp