aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2007-04-20 08:39:04 +0800
committersobomax <sobomax@FreeBSD.org>2007-04-20 08:39:04 +0800
commitc1dbc6bd854fb3e4168be7b48139f110ab718b4e (patch)
treeac6c225200e84df7fdb171fb37136cf25b0f0e65 /textproc
parentf00b743856d8bbbfdc463bf9b2e50dffc8a9fc41 (diff)
downloadfreebsd-ports-gnome-c1dbc6bd854fb3e4168be7b48139f110ab718b4e.tar.gz
freebsd-ports-gnome-c1dbc6bd854fb3e4168be7b48139f110ab718b4e.tar.zst
freebsd-ports-gnome-c1dbc6bd854fb3e4168be7b48139f110ab718b4e.zip
Add libwbxml 0.9.2, library and tools to parse, encode and handle WBXML
documents.
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/libwbxml/Makefile35
-rw-r--r--textproc/libwbxml/distinfo3
-rw-r--r--textproc/libwbxml/files/patch-Makefile.am25
-rw-r--r--textproc/libwbxml/files/patch-src_Makefile.am25
-rw-r--r--textproc/libwbxml/files/patch-tools_Makefile.am16
-rw-r--r--textproc/libwbxml/pkg-descr7
-rw-r--r--textproc/libwbxml/pkg-plist37
8 files changed, 149 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7b6f0957383e..36c3022abe5e 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -262,6 +262,7 @@
SUBDIR += libtranslate
SUBDIR += libtre
SUBDIR += libuninameslist
+ SUBDIR += libwbxml
SUBDIR += libwpd
SUBDIR += libxdiff
SUBDIR += libxml
diff --git a/textproc/libwbxml/Makefile b/textproc/libwbxml/Makefile
new file mode 100644
index 000000000000..b2bf6d972d6c
--- /dev/null
+++ b/textproc/libwbxml/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libwbxml
+# Date created: 19 April 2007
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libwbxml
+PORTVERSION= 0.9.2
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= wbxmllib
+DISTNAME= wbxml2-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+COMMENT= Library and tools to parse, encode and handle WBXML documents
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+USE_GMAKE= yes
+USE_AUTOTOOLS= aclocal:19 autoconf:259 autoheader:259 automake:19 libtool:15
+AUTOMAKE_ARGS= --add-missing
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+INSTALLS_SHLIB= yes
+
+post-extract:
+ @${CP} ${LOCALBASE}/share/libtool/ltmain.sh ${WRKSRC}/ltmain.sh
+ @${TOUCH} ${WRKSRC}/config.h.in
+ @${REINPLACE_CMD} 's|^.*install_prog.*instname.*destdir.*$$||' ${WRKSRC}/ltmain.sh
+
+patch-autotools:
+ @${TRUE}
+
+.include <bsd.port.mk>
diff --git a/textproc/libwbxml/distinfo b/textproc/libwbxml/distinfo
new file mode 100644
index 000000000000..c3b4891a5ef3
--- /dev/null
+++ b/textproc/libwbxml/distinfo
@@ -0,0 +1,3 @@
+MD5 (wbxml2-0.9.2.tar.gz) = 67a48fd9b69db8818a4dca5375c7993a
+SHA256 (wbxml2-0.9.2.tar.gz) = cb4909d8753dff7f6ac90a62a61ed1ae68e49ead2dbc60c22673c55bb0e14a36
+SIZE (wbxml2-0.9.2.tar.gz) = 304115
diff --git a/textproc/libwbxml/files/patch-Makefile.am b/textproc/libwbxml/files/patch-Makefile.am
new file mode 100644
index 000000000000..a4c52267d042
--- /dev/null
+++ b/textproc/libwbxml/files/patch-Makefile.am
@@ -0,0 +1,25 @@
+
+$FreeBSD$
+
+--- Makefile.am.orig
++++ Makefile.am
+@@ -8,7 +8,7 @@
+ pkgconfigdir=$(libdir)/pkgconfig
+ pkgconfig_DATA = libwbxml2.pc
+
+-wbxmldocdir = ${prefix}/share/doc/wbxml2-${VERSION}
++wbxmldocdir = ${prefix}/share/doc/wbxml2
+ wbxmldoc_DATA = \
+ AUTHORS\
+ bootstrap\
+@@ -25,8 +25,8 @@
+ doxygen.h
+
+ install-data-local:
+- $(mkinstalldirs) $(DESTDIR)$(wbxmldocdir)/manual
+- cp -Rp doc/* $(DESTDIR)$(wbxmldocdir)/manual
++# $(mkinstalldirs) $(DESTDIR)$(wbxmldocdir)/manual
++# cp -Rp doc/* $(DESTDIR)$(wbxmldocdir)/manual
+
+ dist-bz2: distdir
+ sed -e "s/tar.gz/tar.bz2/g" $(distdir)/wbxml2.spec > $(distdir)/wbxml2.spec.aux
diff --git a/textproc/libwbxml/files/patch-src_Makefile.am b/textproc/libwbxml/files/patch-src_Makefile.am
new file mode 100644
index 000000000000..aeeb60cdc382
--- /dev/null
+++ b/textproc/libwbxml/files/patch-src_Makefile.am
@@ -0,0 +1,25 @@
+
+$FreeBSD$
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -3,7 +3,7 @@
+ INCLUDES =\
+ -I. -I/usr/include
+
+-CFLAGS =\
++CFLAGS +=\
+ -DHAVE_CONFIG_H\
+ -DHAVE_EXPAT\
+ -D_REENTRANT\
+@@ -20,9 +20,7 @@
+ -DWBXML_SUPPORT_SYNCML\
+ -DWBXML_SUPPORT_WV\
+ -DWBXML_SUPPORT_AIRSYNC\
+- -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes\
+- -O3\
+- -g
++ -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes
+
+ lib_LTLIBRARIES = libwbxml2.la
+
diff --git a/textproc/libwbxml/files/patch-tools_Makefile.am b/textproc/libwbxml/files/patch-tools_Makefile.am
new file mode 100644
index 000000000000..622f4647654b
--- /dev/null
+++ b/textproc/libwbxml/files/patch-tools_Makefile.am
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- tools/Makefile.am
++++ tools/Makefile.am
+@@ -20,9 +20,7 @@
+ -DWBXML_SUPPORT_SYNCML\
+ -DWBXML_SUPPORT_WV\
+ -DWBXML_SUPPORT_AIRSYNC\
+- -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes\
+- -O3\
+- -g
++ -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes
+
+ bin_PROGRAMS = wbxml2xml xml2wbxml
+
diff --git a/textproc/libwbxml/pkg-descr b/textproc/libwbxml/pkg-descr
new file mode 100644
index 000000000000..762066fa1a46
--- /dev/null
+++ b/textproc/libwbxml/pkg-descr
@@ -0,0 +1,7 @@
+The WBXML Library (aka libwbxml) contains a library and its associated tools
+to Parse, Encode and Handle WBXML documents.
+
+The WBXML format is a binary representation of XML, defined by the Wap Forum,
+and used to reduce bandwidth in mobile communications.
+
+WWW: http://libwbxml.aymerick.com
diff --git a/textproc/libwbxml/pkg-plist b/textproc/libwbxml/pkg-plist
new file mode 100644
index 000000000000..e699e4ee7265
--- /dev/null
+++ b/textproc/libwbxml/pkg-plist
@@ -0,0 +1,37 @@
+bin/wbxml2xml
+bin/xml2wbxml
+include/wbxml.h
+include/wbxml_base64.h
+include/wbxml_buffers.h
+include/wbxml_charset.h
+include/wbxml_conv.h
+include/wbxml_elt.h
+include/wbxml_encoder.h
+include/wbxml_errors.h
+include/wbxml_handlers.h
+include/wbxml_lists.h
+include/wbxml_log.h
+include/wbxml_mem.h
+include/wbxml_parser.h
+include/wbxml_tables.h
+include/wbxml_tree.h
+include/wbxml_tree_clb_wbxml.h
+include/wbxml_tree_clb_xml.h
+lib/libwbxml2.a
+lib/libwbxml2.so
+lib/libwbxml2.so.0
+lib/pkgconfig/libwbxml2.pc
+share/doc/wbxml2/AUTHORS
+share/doc/wbxml2/BUGS
+share/doc/wbxml2/COPYING
+share/doc/wbxml2/ChangeLog
+share/doc/wbxml2/GNU-LGPL
+share/doc/wbxml2/INSTALL
+share/doc/wbxml2/NEWS
+share/doc/wbxml2/README
+share/doc/wbxml2/References
+share/doc/wbxml2/THANKS
+share/doc/wbxml2/TODO
+share/doc/wbxml2/bootstrap
+share/doc/wbxml2/doxygen.h
+@dirrm share/doc/wbxml2