aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-26 00:08:19 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-26 00:08:19 +0800
commitc67befb6bb7c1ae2a8aea53dc45c843cae8a634f (patch)
treef508a68f274d37b01a795b824384fb0af8104209 /textproc
parentc7421152a4ae7797083a5c6ec4ac00de9e8c1a06 (diff)
downloadfreebsd-ports-gnome-c67befb6bb7c1ae2a8aea53dc45c843cae8a634f.tar.gz
freebsd-ports-gnome-c67befb6bb7c1ae2a8aea53dc45c843cae8a634f.tar.zst
freebsd-ports-gnome-c67befb6bb7c1ae2a8aea53dc45c843cae8a634f.zip
- Support staging
- Don't install VCS files - Use COPYTREE_SHARE instead of CP
Diffstat (limited to 'textproc')
-rw-r--r--textproc/mathml-xsd/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/textproc/mathml-xsd/Makefile b/textproc/mathml-xsd/Makefile
index c8779e359a9b..9efe3644d8e1 100644
--- a/textproc/mathml-xsd/Makefile
+++ b/textproc/mathml-xsd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mathml-xsd
PORTVERSION= 2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= http://www.w3.org/Math/XMLSchema/
DISTNAME= mathml${PORTVERSION}
@@ -14,16 +14,12 @@ COMMENT= The MathML XML Schema
NO_BUILD= yes
-NO_STAGE= yes
post-extract:
- @${FIND} ${WRKSRC} -name "CVS" -type d -delete
+ @${FIND} ${WRKSRC} -name "CVS" -type d -exec rm -rf {} +;
+ @${RM} ${WRKSRC}/content/tokens.xsd.~1.3.~
do-install:
- @${MKDIR} ${DATADIR}
- @${CP} -R ${WRKSRC}/* ${DATADIR}
- @${FIND} ${DATADIR} -type f | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${DATADIR} -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>