aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-05-20 17:24:04 +0800
committerpav <pav@FreeBSD.org>2005-05-20 17:24:04 +0800
commitc98625c2b92eb677b0255aef541fc2bf6b33e15f (patch)
treebc59e4f8d8824795b33a175e51bd2e7129c9c846 /textproc
parent2df859e946375908e63d80d5ff0bde36d0a3fcc7 (diff)
downloadfreebsd-ports-gnome-c98625c2b92eb677b0255aef541fc2bf6b33e15f.tar.gz
freebsd-ports-gnome-c98625c2b92eb677b0255aef541fc2bf6b33e15f.tar.zst
freebsd-ports-gnome-c98625c2b92eb677b0255aef541fc2bf6b33e15f.zip
RefDB is a client-server database system for storing, retrieving and
formatting bibliographic references. It is a front-end for an SQL database backend---either SQLite, MySQL, or PostgreSQL. PR: ports/81251 Submitted by: Paul A. Hoadley <paulh@logicsquad.net>
Diffstat (limited to 'textproc')
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/refdb/Makefile119
-rw-r--r--textproc/refdb/distinfo2
-rw-r--r--textproc/refdb/files/patch-scripts-refdb19
-rw-r--r--textproc/refdb/pkg-descr7
-rw-r--r--textproc/refdb/pkg-plist127
6 files changed, 275 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4976e7522b3e..7d55820fea01 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -563,6 +563,7 @@
SUBDIR += re_graph
SUBDIR += redland
SUBDIR += redland-bindings
+ SUBDIR += refdb
SUBDIR += replaceit
SUBDIR += resume
SUBDIR += resume-extensions
diff --git a/textproc/refdb/Makefile b/textproc/refdb/Makefile
new file mode 100644
index 000000000000..294e7a1dd47e
--- /dev/null
+++ b/textproc/refdb/Makefile
@@ -0,0 +1,119 @@
+# New ports collection makefile for: refdb
+# Date created: 28 Apr 2005
+# Whom: paulh@logicsquad.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= refdb
+PORTVERSION= 0.9.5a
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= paulh@logicsquad.net
+COMMENT= Bibliographic reference database
+
+LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
+
+WRKSRC= ${WRKDIR}/refdb-0.9.5
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+ALL_TARGET=
+
+CFLAGS+= -I${LOCALBASE}/include
+# Change these:
+CONFIGURE_ARGS+= --with-expat-lib=${LOCALBASE}/lib
+CONFIGURE_ARGS+= --with-classpath-root=${PREFIX}/share/java/classes
+CONFIGURE_ARGS+= --with-refdb-url=http://localhost/refdb
+
+XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
+
+# For testing:
+#CONFIGURE_ARGS+= --prefix=/home/paulh/ports/textproc/refdb/install
+
+OPTIONS= MYSQL "Use MySQL" on \
+ PGSQL "Use PostgreSQL" off \
+ SQLITE "Use SQLite" off \
+ CATALOG "Install SGML catalog" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_MYSQL) && !defined(WITH_PGSQL) && !defined(WITH_SQLITE)
+IGNORE= You must choose a back-end database
+.endif
+
+.if !defined(WITHOUT_MYSQL)
+USE_MYSQL= yes
+# If libdbi-drivers has been built without MySQL driver, abort
+.if exists(${LOCALBASE}/lib/dbd) && !exists(${LOCALBASE}/lib/dbd/libmysql.so)
+IGNORE= Rebuild databases/libdbi-drivers with MySQL support
+.elif !exists(${LOCALBASE}/lib/dbd)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/dbd:${PORTSDIR}/databases/libdbi-drivers
+.endif
+CONFIGURE_ARGS+= --with-db-server=mysql
+
+.elif defined(WITH_PGSQL)
+USE_PGSQL= yes
+# If libdbi-drivers has been built without PostgreSQL driver, abort
+.if exists(${LOCALBASE}/lib/dbd) && !exists(${LOCALBASE}/lib/dbd/libpgsql.so)
+IGNORE= Rebuild databases/libdbi-drivers with PostgreSQL support
+.elif !exists(${LOCALBASE}/lib/dbd)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/dbd:${PORTSDIR}/databases/libdbi-drivers
+.endif
+CONFIGURE_ARGS+= --with-db-server=pgsql
+
+.elif defined(WITH_SQLITE)
+LIB_DEPENDS+= sqlite.2:${PORTSDIR}/databases/sqlite2
+# If libdbi-drivers has been built without SQLite driver, abort
+.if exists(${LOCALBASE}/lib/dbd) && !exists(${LOCALBASE}/lib/dbd/libsqlite.so)
+IGNORE= Rebuild databases/libdbi-drivers with SQLite support
+.elif !exists(${LOCALBASE}/lib/dbd)
+BUILD_DEPENDS+= ${LOCALBASE}/lib/dbd:${PORTSDIR}/databases/libdbi-drivers
+.endif
+CONFIGURE_ARGS+= --with-db-server=sqlite
+.endif
+
+.if defined(WITH_CATALOG)
+RUN_DEPENDS+= xmlcatmgr:${PORTSDIR}/textproc/xmlcatmgr
+.endif
+
+post-install:
+.if defined(WITH_CATALOG)
+ @[ -f ${PREFIX}/share/sgml/catalog.ports ] || ${TOUCH} ${PREFIX}/share/sgml/catalog.ports
+ @${XMLCATMGR} -s -c ${PREFIX}/share/sgml/catalog.ports lookup "${PREFIX}/share/refdb/refdb.cat" > /dev/null || ${XMLCATMGR} -s -c ${PREFIX}/share/sgml/catalog.ports add CATALOG "${PREFIX}/share/refdb/refdb.cat" -- > /dev/null
+.endif
+ @${ECHO_MSG} "To complete RefDB installation:"
+.if defined(WITH_MYSQL)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "1. To initialise MySQL, run the following commands:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " mysql -u root -e \"CREATE DATABASE refdb\""
+ @${ECHO_MSG} " mysql -u root refdb < ${PREFIX}/share/refdb/sql/refdb.dump"
+ @${ECHO_MSG} ""
+.elif defined(WITH_PGSQL)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "1. To initialise PostgreSQL, run the following commands:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " createdb -U pgsql -E UNICODE refdb"
+ @${ECHO_MSG} " psql -U pgsql refdb < ${PREFIX}/share/refdb/sql/refdb.dump.pgsql"
+ @${ECHO_MSG} ""
+.elif defined(WITH_SQLITE)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "1. To initialise SQLite, run the following commands:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " cd ${PREFIX}/share/refdb/db"
+ @${ECHO_MSG} " sqlite refdb < ${PREFIX}/share/refdb/sql/refdb.dump.sqlite"
+ @${ECHO_MSG} ""
+.endif
+ @${INSTALL_SCRIPT} -m 755 ${WRKSRC}/scripts/refdb ${PREFIX}/etc/rc.d/refdb.sh.dist
+ @${ECHO_MSG} "2. To run refdbd at system startup, rename the startup script:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " mv ${PREFIX}/etc/rc.d/refdb.sh.dist ${PREFIX}/etc/rc.d/refdb.sh"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "3. Customise the configuration scripts in ${PREFIX}/etc/refdb,"
+ @${ECHO_MSG} " as described in the RefDB documentation at:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " http://refdb.sourceforge.net/manual/x1390.html#AEN1484"
+
+.include <bsd.port.post.mk>
diff --git a/textproc/refdb/distinfo b/textproc/refdb/distinfo
new file mode 100644
index 000000000000..febb4c9a4874
--- /dev/null
+++ b/textproc/refdb/distinfo
@@ -0,0 +1,2 @@
+MD5 (refdb-0.9.5a.tar.gz) = cc8dde53bd1e483c260a6e92d570e610
+SIZE (refdb-0.9.5a.tar.gz) = 1035533
diff --git a/textproc/refdb/files/patch-scripts-refdb b/textproc/refdb/files/patch-scripts-refdb
new file mode 100644
index 000000000000..7ac4ff1d40cd
--- /dev/null
+++ b/textproc/refdb/files/patch-scripts-refdb
@@ -0,0 +1,19 @@
+*** scripts/refdb.orig Sat Apr 30 16:45:49 2005
+--- scripts/refdb Sat Apr 30 16:46:18 2005
+***************
+*** 43,49 ****
+ # set to 'YES' if the OS uses a BSD-style daemon startup system (this is
+ # true for BSD-UNIX and Unices derived thereof, as well as for the
+ # Slackware Linux distribution)
+! BSDSTYLE=NO
+
+ # don't get interrupted
+ trap "" 1
+--- 43,49 ----
+ # set to 'YES' if the OS uses a BSD-style daemon startup system (this is
+ # true for BSD-UNIX and Unices derived thereof, as well as for the
+ # Slackware Linux distribution)
+! BSDSTYLE=YES
+
+ # don't get interrupted
+ trap "" 1
diff --git a/textproc/refdb/pkg-descr b/textproc/refdb/pkg-descr
new file mode 100644
index 000000000000..40d7476ce2e3
--- /dev/null
+++ b/textproc/refdb/pkg-descr
@@ -0,0 +1,7 @@
+RefDB is a client-server database system for storing, retrieving and
+formatting bibliographic references.
+
+WWW: http://refdb.sourceforge.net/
+
+- Paul A. Hoadley
+paulh@logicsquad.net
diff --git a/textproc/refdb/pkg-plist b/textproc/refdb/pkg-plist
new file mode 100644
index 000000000000..a709aa947bdd
--- /dev/null
+++ b/textproc/refdb/pkg-plist
@@ -0,0 +1,127 @@
+%%DATADIR%%/declarations/xml.dcl
+%%DATADIR%%/declarations/docbook.dcl
+%%DATADIR%%/dsssl/html/docbook-refdb.dsl
+%%DATADIR%%/dsssl/lib/refdblib.dsl
+%%DATADIR%%/dsssl/lib/refdbvar.dsl
+%%DATADIR%%/dsssl/print/docbook-refdb.dsl
+%%DATADIR%%/dsssl/bibdb2tei.dsl
+%%DATADIR%%/dsssl/citations.dsl
+%%DATADIR%%/dsssl/db2ris.dsl
+%%DATADIR%%/dsssl/makecss.dsl
+%%DATADIR%%/dsssl/catalog
+%%DATADIR%%/refdb.cat
+%%DATADIR%%/dtd/catalog
+%%DATADIR%%/dtd/citestylex.dtd
+%%DATADIR%%/dtd/citationlistx.dtd
+%%DATADIR%%/dtd/risx.dtd
+%%DATADIR%%/dtd/xnote.dtd
+%%DATADIR%%/styles/Eur.J.Pharmacol.xml
+%%DATADIR%%/styles/J.Biol.Chem.xml
+%%DATADIR%%/styles/bibtex-abbrev.xml
+%%DATADIR%%/styles/bibtex-full.xml
+%%DATADIR%%/xsl/common-refdb/refdbvar.xsl
+%%DATADIR%%/xsl/docbk-refdb-xsl/docbk-fo/docbk-refdb-fo.xsl
+%%DATADIR%%/xsl/docbk-refdb-xsl/docbk-html/docbk-refdb-html.xsl
+%%DATADIR%%/xsl/docbk-refdb-xsl/docbk-xhtml/docbk-refdb-xhtml.xsl
+%%DATADIR%%/xsl/docbk-refdb-xsl/docbk-lib/docbk-refdblib.xsl
+%%DATADIR%%/xsl/tei-refdb-xsl/tei-fo/tei-refdb-fo.xsl
+%%DATADIR%%/xsl/tei-refdb-xsl/tei-html/tei-refdb-html.xsl
+%%DATADIR%%/xsl/tei-refdb-xsl/tei-lib/tei-refdblib.xsl
+%%DATADIR%%/xsl/citations.xsl
+%%DATADIR%%/xsl/bibdb2tei.xsl
+%%DATADIR%%/xsl/makecss.xsl
+%%DATADIR%%/templates/refdbq_foot.html
+%%DATADIR%%/templates/refdbqp_foot.html
+%%DATADIR%%/templates/refdbq_head.html
+%%DATADIR%%/templates/refdbqp_head.html
+%%DATADIR%%/templates/refdbadd_foot.html
+%%DATADIR%%/templates/refdbadd_head.html
+%%DATADIR%%/www/refdbadd.html
+%%DATADIR%%/www/refdbdbquery.html
+%%DATADIR%%/www/refdbkajquery.html
+%%DATADIR%%/www/refdblogout.html
+%%DATADIR%%/www/refdbquery.html
+%%DATADIR%%/www/refdbquerynl.html
+%%DATADIR%%/www/refdbq.css
+%%DATADIR%%/www/access.js
+%%DATADIR%%/www/index.html
+%%DATADIR%%/css/refdb.css
+%%DATADIR%%/examples/readme.examples
+%%DATADIR%%/examples/dbtest.short.sgml
+%%DATADIR%%/examples/dbtest.sgml
+%%DATADIR%%/examples/dbxtest.short.xml
+%%DATADIR%%/examples/dbxtest.xml
+%%DATADIR%%/examples/serif.bib
+%%DATADIR%%/examples/teitest.short.xml
+%%DATADIR%%/examples/teitest.xml
+%%DATADIR%%/examples/testrefs.ris
+%%DATADIR%%/examples/testrefs.xml
+%%DATADIR%%/examples/testrefs.usmarc
+%%DATADIR%%/examples/Makefile.template
+%%DATADIR%%/examples/xnoteset.xml
+%%DATADIR%%/sql/refdb.dump
+%%DATADIR%%/sql/refdb.dump.pgsql
+%%DATADIR%%/sql/refdb.dump.sqlite
+%%DATADIR%%/sql/empty.mysql.dump
+%%DATADIR%%/sql/empty.pgsql.dump.in
+%%DATADIR%%/sql/refdb-upgrade.sql
+etc/rc.d/refdb.sh.dist
+etc/refdb/bib2risrc.example
+etc/refdb/bib2riscgirc.example
+etc/refdb/db2risrc.example
+etc/refdb/nmed2risrc.example
+etc/refdb/nmed2riscgirc.example
+etc/refdb/refdbarc.example
+etc/refdb/refdbcrc.example
+etc/refdb/refdbcgirc.example
+etc/refdb/refdbibrc.example
+etc/refdb/med2risrc.example
+etc/refdb/med2riscgirc.example
+etc/refdb/marc2risrc.example
+etc/refdb/refdbxmlrc.example
+etc/refdb/refdbdrc.example
+bin/refdb-bug
+bin/refdbctl
+bin/refdbjade
+bin/runbib
+bin/tex2mail
+bin/db2ris
+bin/refdbxml
+bin/marc2ris.pl
+bin/med2ris.pl
+bin/en2ris.pl
+bin/refdbnd
+bin/dos2unix
+bin/refdbd
+bin/refdbib
+bin/refdbc
+bin/refdba
+bin/refdbxp
+bin/nmed2ris
+bin/eenc
+@dirrm share/refdb/declarations
+@dirrm share/refdb/dsssl/html
+@dirrm share/refdb/dsssl/lib
+@dirrm share/refdb/dsssl/print
+@dirrm share/refdb/dsssl
+@dirrm share/refdb/dtd
+@dirrm share/refdb/styles
+@dirrm share/refdb/xsl/common-refdb
+@dirrm share/refdb/xsl/docbk-refdb-xsl/docbk-fo
+@dirrm share/refdb/xsl/docbk-refdb-xsl/docbk-html
+@dirrm share/refdb/xsl/docbk-refdb-xsl/docbk-xhtml
+@dirrm share/refdb/xsl/docbk-refdb-xsl/docbk-lib
+@dirrm share/refdb/xsl/docbk-refdb-xsl
+@dirrm share/refdb/xsl/tei-refdb-xsl/tei-fo
+@dirrm share/refdb/xsl/tei-refdb-xsl/tei-html
+@dirrm share/refdb/xsl/tei-refdb-xsl/tei-lib
+@dirrm share/refdb/xsl/tei-refdb-xsl
+@dirrm share/refdb/xsl
+@dirrm share/refdb/templates
+@dirrm share/refdb/www
+@dirrm share/refdb/css
+@dirrm share/refdb/db
+@dirrm share/refdb/examples
+@dirrm share/refdb/sql
+@dirrm share/refdb
+@dirrm etc/refdb