aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2004-01-15 07:43:51 +0800
committerale <ale@FreeBSD.org>2004-01-15 07:43:51 +0800
commitcb03bae3c20459acba58a9c4c1e161dc49ce9f83 (patch)
tree3cd9c3029323b00efddc8c55a9cecfa105d37c15 /textproc
parentbe864a0f1925266f8efde8640f0303371ed589c4 (diff)
downloadfreebsd-ports-gnome-cb03bae3c20459acba58a9c4c1e161dc49ce9f83.tar.gz
freebsd-ports-gnome-cb03bae3c20459acba58a9c4c1e161dc49ce9f83.tar.zst
freebsd-ports-gnome-cb03bae3c20459acba58a9c4c1e161dc49ce9f83.zip
Add workaround to correctly install the docbook-xsl port.
A new release will come asap. Submitted by: Mike Harding (bug), hrs (fix) Approved by: nork (mentor/implicitly)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xmlcatmgr/Makefile1
-rw-r--r--textproc/xmlcatmgr/files/patch-bin::xml.c10
2 files changed, 11 insertions, 0 deletions
diff --git a/textproc/xmlcatmgr/Makefile b/textproc/xmlcatmgr/Makefile
index 621b1b9b65fa..a64d5bce152c 100644
--- a/textproc/xmlcatmgr/Makefile
+++ b/textproc/xmlcatmgr/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xmlcatmgr
PORTVERSION= 2.0.a1
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/textproc/xmlcatmgr/files/patch-bin::xml.c b/textproc/xmlcatmgr/files/patch-bin::xml.c
new file mode 100644
index 000000000000..59aa6c2daaed
--- /dev/null
+++ b/textproc/xmlcatmgr/files/patch-bin::xml.c
@@ -0,0 +1,10 @@
+--- bin/xml.c.orig Tue Dec 23 11:27:37 2003
++++ bin/xml.c Thu Jan 15 00:31:14 2004
+@@ -270,7 +270,6 @@
+
+ if (search_entry(XMLDOC_ROOT(c), orig) != NULL) {
+ warnx("entry already exists for `%s'", orig);
+- return false;
+ }
+
+ xn = xmlnode_new(XMLNODE_TYPE_ELEMENT, strdup(type));