aboutsummaryrefslogtreecommitdiffstats
path: root/textproc
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-11 00:48:41 +0800
committeraz <az@FreeBSD.org>2013-09-11 00:48:41 +0800
commitcb1b4f21585b776814b2c35b627c22cf48069973 (patch)
treec630c097210c894bc317e215eb9cc67d9b481252 /textproc
parent54cc75be0fc6c11b967da56cdc4878e39c874a80 (diff)
downloadfreebsd-ports-gnome-cb1b4f21585b776814b2c35b627c22cf48069973.tar.gz
freebsd-ports-gnome-cb1b4f21585b776814b2c35b627c22cf48069973.tar.zst
freebsd-ports-gnome-cb1b4f21585b776814b2c35b627c22cf48069973.zip
- convert to the new perl5 framework
- trim Makefile header Approved by: portmgr (bapt@, blanket)
Diffstat (limited to 'textproc')
-rw-r--r--textproc/p5-File-Inplace/Makefile9
-rw-r--r--textproc/p5-HTML-HTMLDoc/Makefile9
-rw-r--r--textproc/p5-Lingua-EN-Number-IsOrdinal/Makefile3
-rw-r--r--textproc/p5-PDF-Writer/Makefile9
-rw-r--r--textproc/p5-Regexp-DefaultFlags/Makefile9
-rw-r--r--textproc/p5-String-CamelCase/Makefile9
-rw-r--r--textproc/p5-String-RewritePrefix/Makefile9
-rw-r--r--textproc/p5-Text-CSV-Hashify/Makefile3
-rw-r--r--textproc/p5-Text-Emoticon-MSN/Makefile9
-rw-r--r--textproc/p5-Text-Sass/Makefile3
-rw-r--r--textproc/p5-Text-Table/Makefile3
-rw-r--r--textproc/p5-Tiffany/Makefile3
-rw-r--r--textproc/p5-Vroom/Makefile9
-rw-r--r--textproc/p5-XML-DOM-XPath/Makefile9
-rw-r--r--textproc/p5-XML-Parser/Makefile3
-rw-r--r--textproc/p5-XML-TreeBuilder/Makefile3
-rw-r--r--textproc/p5-YAML-LibYAML/Makefile3
-rw-r--r--textproc/p5-YAML-Tiny/Makefile9
-rw-r--r--textproc/txt2html/Makefile9
19 files changed, 49 insertions, 74 deletions
diff --git a/textproc/p5-File-Inplace/Makefile b/textproc/p5-File-Inplace/Makefile
index a7b3b589adef..c4bc95c63614 100644
--- a/textproc/p5-File-Inplace/Makefile
+++ b/textproc/p5-File-Inplace/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: File-Inplace
-# Date created: 2010-12-08
-# Whom: Greg Larkin <glarkin@FreeBSD.org>
-#
+# Created by: Greg Larkin <glarkin@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= File-Inplace
PORTVERSION= 0.20
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= glarkin@FreeBSD.org
COMMENT= Perl module for in-place editing of files
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= File::Inplace.3
diff --git a/textproc/p5-HTML-HTMLDoc/Makefile b/textproc/p5-HTML-HTMLDoc/Makefile
index 14744763ac5b..7ea986da063b 100644
--- a/textproc/p5-HTML-HTMLDoc/Makefile
+++ b/textproc/p5-HTML-HTMLDoc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-HTML-HTMLDoc
-# Date created: 13 January 2010
-# Whom: Konstantin Menshikov <kostjnspb@yandex.ru>
-#
+# Created by: Konstantin Menshikov <kostjnspb@yandex.ru>
# $FreeBSD$
-#
PORTNAME= HTML-HTMLDoc
PORTVERSION= 0.10
@@ -19,7 +15,8 @@ COMMENT= Perl interface to the htmldoc program
BUILD_DEPENDS= htmldoc>0:${PORTSDIR}/textproc/htmldoc
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::HTMLDoc.3 HTML::HTMLDoc::PDF.3
diff --git a/textproc/p5-Lingua-EN-Number-IsOrdinal/Makefile b/textproc/p5-Lingua-EN-Number-IsOrdinal/Makefile
index 22b30879e824..67dfc2ce63fd 100644
--- a/textproc/p5-Lingua-EN-Number-IsOrdinal/Makefile
+++ b/textproc/p5-Lingua-EN-Number-IsOrdinal/Makefile
@@ -16,7 +16,8 @@ TEST_DEPENDS= \
p5-Test-Fatal>0:${PORTSDIR}/devel/p5-Test-Fatal \
p5-Try-Tiny:${PORTSDIR}/lang/p5-Try-Tiny
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Lingua::EN::Number::IsOrdinal.3
diff --git a/textproc/p5-PDF-Writer/Makefile b/textproc/p5-PDF-Writer/Makefile
index 985d72c66434..85dc3583fa66 100644
--- a/textproc/p5-PDF-Writer/Makefile
+++ b/textproc/p5-PDF-Writer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-PDF-Writer
-# Date created: 2006-07-11
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= PDF-Writer
PORTVERSION= 0.06
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= PDF writer abstraction layer
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= PDF::Writer.3 PDF::Writer::pdfapi2.3 PDF::Writer::pdflib.3
diff --git a/textproc/p5-Regexp-DefaultFlags/Makefile b/textproc/p5-Regexp-DefaultFlags/Makefile
index c20204462a55..217f2dfb9b3a 100644
--- a/textproc/p5-Regexp-DefaultFlags/Makefile
+++ b/textproc/p5-Regexp-DefaultFlags/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Regexp-DefaultFlags
-# Date created: 2006-09-18
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= Regexp-DefaultFlags
PORTVERSION= 0.01
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Set default flags on regular expressions
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Regexp::DefaultFlags.3
diff --git a/textproc/p5-String-CamelCase/Makefile b/textproc/p5-String-CamelCase/Makefile
index 68e8714de652..a5806be893b7 100644
--- a/textproc/p5-String-CamelCase/Makefile
+++ b/textproc/p5-String-CamelCase/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-String-CamelCase
-# Date created: 2007-10-30
-# Whom: TAKAHASHI Kaoru <kaoru@kaisei.org>
-#
+# Created by: TAKAHASHI Kaoru <kaoru@kaisei.org>
# $FreeBSD$
-#
PORTNAME= String-CamelCase
PORTVERSION= 0.02
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kaoru@kaisei.org
COMMENT= Perl module for camelcase, de-camelcase
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= String::CamelCase.3
diff --git a/textproc/p5-String-RewritePrefix/Makefile b/textproc/p5-String-RewritePrefix/Makefile
index c46a1f07b9b7..fb7d3e443d40 100644
--- a/textproc/p5-String-RewritePrefix/Makefile
+++ b/textproc/p5-String-RewritePrefix/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: textproc/p5-String-RewritePrefix
-# Date created: 25 July 2009
-# Whom: Bill Brinzer <bill.brinzer@gmail.com>
-#
+# Created by: Bill Brinzer <bill.brinzer@gmail.com>
# $FreeBSD$
-#
PORTNAME= String-RewritePrefix
PORTVERSION= 0.006
@@ -17,7 +13,8 @@ COMMENT= Rewrite strings based on a set of known prefixes
TEST_DEPENDS= p5-Sub-Exporter>0:${PORTSDIR}/devel/p5-Sub-Exporter
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= String::RewritePrefix.3
diff --git a/textproc/p5-Text-CSV-Hashify/Makefile b/textproc/p5-Text-CSV-Hashify/Makefile
index d953bcada91c..205621b58892 100644
--- a/textproc/p5-Text-CSV-Hashify/Makefile
+++ b/textproc/p5-Text-CSV-Hashify/Makefile
@@ -14,7 +14,8 @@ COMMENT= Composition and decomposition of comma-separated values into hashes
BUILD_DEPENDS= p5-Text-CSV>=0:${PORTSDIR}/textproc/p5-Text-CSV
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::CSV::Hashify.3
diff --git a/textproc/p5-Text-Emoticon-MSN/Makefile b/textproc/p5-Text-Emoticon-MSN/Makefile
index 97eff82aa2b9..15c6eb965792 100644
--- a/textproc/p5-Text-Emoticon-MSN/Makefile
+++ b/textproc/p5-Text-Emoticon-MSN/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: textproc/p5-Text-Emoticon-MSN
-# Date created: 26 December 2009
-# Whom: Alex Deiter <Alex.Deiter@Gmail.COM>
-#
+# Created by: Alex Deiter <Alex.Deiter@Gmail.COM>
# $FreeBSD$
-#
PORTNAME= Text-Emoticon-MSN
PORTVERSION= 0.04
@@ -20,7 +16,8 @@ EXPIRATION_DATE=2013-10-31
BUILD_DEPENDS= p5-Text-Emoticon>=0.02:${PORTSDIR}/textproc/p5-Text-Emoticon
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::Emoticon::MSN.3
diff --git a/textproc/p5-Text-Sass/Makefile b/textproc/p5-Text-Sass/Makefile
index c6ba983b3b70..06aaf0cb98fe 100644
--- a/textproc/p5-Text-Sass/Makefile
+++ b/textproc/p5-Text-Sass/Makefile
@@ -16,7 +16,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Text::Sass.3 \
Text::Sass::Expr.3 \
diff --git a/textproc/p5-Text-Table/Makefile b/textproc/p5-Text-Table/Makefile
index 995193335fea..40be6d854576 100644
--- a/textproc/p5-Text-Table/Makefile
+++ b/textproc/p5-Text-Table/Makefile
@@ -13,7 +13,8 @@ COMMENT= Organize Data in Tables
BUILD_DEPENDS= p5-Text-Aligner>=0.05:${PORTSDIR}/textproc/p5-Text-Aligner
RUN_DEPENDS= p5-Text-Aligner>=0.05:${PORTSDIR}/textproc/p5-Text-Aligner
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::Table.3
diff --git a/textproc/p5-Tiffany/Makefile b/textproc/p5-Tiffany/Makefile
index 45608764fc05..35cbe1ae6484 100644
--- a/textproc/p5-Tiffany/Makefile
+++ b/textproc/p5-Tiffany/Makefile
@@ -23,7 +23,8 @@ TEST_DEPENDS= \
p5-Text-ClearSilver>0:${PORTSDIR}/textproc/p5-Text-ClearSilver \
p5-HTML-Template-Pro>0:${PORTSDIR}/www/p5-HTML-Template-Pro
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Tiffany.3 \
Tiffany::HTML::Template.3 \
diff --git a/textproc/p5-Vroom/Makefile b/textproc/p5-Vroom/Makefile
index 769ab52b803b..c61145018674 100644
--- a/textproc/p5-Vroom/Makefile
+++ b/textproc/p5-Vroom/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Vroom
-# Date created: 2010-04-24
-# Whom: Li-Wen Hsu <lwhsu@FreeBSD.org>
-#
+# Created by: Li-Wen Hsu <lwhsu@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Vroom
PORTVERSION= 0.27
@@ -22,7 +18,8 @@ BUILD_DEPENDS= p5-File-HomeDir>=0:${PORTSDIR}/devel/p5-File-HomeDir \
p5-YAML-LibYAML>=0:${PORTSDIR}/textproc/p5-YAML-LibYAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Vroom.3 Vroom::Vroom.3
diff --git a/textproc/p5-XML-DOM-XPath/Makefile b/textproc/p5-XML-DOM-XPath/Makefile
index 04968a1068eb..37d5c31f94e0 100644
--- a/textproc/p5-XML-DOM-XPath/Makefile
+++ b/textproc/p5-XML-DOM-XPath/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: textproc/p5-XML-DOM-XPath
-# Date created: 8 September 2005
-# Whom: Mauricio Herrera Cuadra <mauricio@arareko.net>
-#
+# Created by: Mauricio Herrera Cuadra <mauricio@arareko.net>
# $FreeBSD$
-#
PORTNAME= XML-DOM-XPath
PORTVERSION= 0.14
@@ -17,7 +13,8 @@ COMMENT= Adds XPath support to XML::DOM, using XML::XPath engine
RUN_DEPENDS= p5-XML-DOM>=0:${PORTSDIR}/textproc/p5-XML-DOM \
p5-XML-XPathEngine>=0:${PORTSDIR}/textproc/p5-XML-XPathEngine
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= XML::DOM::XPath.3
diff --git a/textproc/p5-XML-Parser/Makefile b/textproc/p5-XML-Parser/Makefile
index c06244927a8b..524e61b6c4cf 100644
--- a/textproc/p5-XML-Parser/Makefile
+++ b/textproc/p5-XML-Parser/Makefile
@@ -12,7 +12,8 @@ COMMENT= Perl extension interface to James Clark's XML parser, expat
LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
CONFIGURE_ARGS= EXPATLIBPATH=${LOCALBASE}/lib EXPATINCPATH=${LOCALBASE}/include
MAN3= XML::Parser.3 XML::Parser::Expat.3 \
diff --git a/textproc/p5-XML-TreeBuilder/Makefile b/textproc/p5-XML-TreeBuilder/Makefile
index 36f108a06480..08b1a1e0c4b0 100644
--- a/textproc/p5-XML-TreeBuilder/Makefile
+++ b/textproc/p5-XML-TreeBuilder/Makefile
@@ -22,7 +22,8 @@ TEST_DEPENDS= p5-Devel-Cover>0:${PORTSDIR}/devel/p5-Devel-Cover \
p5-Test-Perl-Critic>0:${PORTSDIR}/textproc/p5-Test-Perl-Critic \
p5-Test-Pod-Coverage>0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= XML::TreeBuilder.3 XML::Element.3
diff --git a/textproc/p5-YAML-LibYAML/Makefile b/textproc/p5-YAML-LibYAML/Makefile
index 506b143e619d..127be1dc1620 100644
--- a/textproc/p5-YAML-LibYAML/Makefile
+++ b/textproc/p5-YAML-LibYAML/Makefile
@@ -16,7 +16,8 @@ LICENSE_COMB= dual
BUILD_DEPENDS= p5-Filter>0:${PORTSDIR}/devel/p5-Filter
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= YAML::XS::LibYAML.3 \
YAML::XS.3
diff --git a/textproc/p5-YAML-Tiny/Makefile b/textproc/p5-YAML-Tiny/Makefile
index 17dde25c1967..35ed8407e4a7 100644
--- a/textproc/p5-YAML-Tiny/Makefile
+++ b/textproc/p5-YAML-Tiny/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-YAML-Tiny
-# Date created: 2006-07-17
-# Whom: Yuan-Chung Hsiao <ychsiao@ychsiao.org>
-#
+# Created by: Yuan-Chung Hsiao <ychsiao@ychsiao.org>
# $FreeBSD$
-#
PORTNAME= YAML-Tiny
PORTVERSION= 1.51
@@ -16,7 +12,8 @@ COMMENT= Read/Write YAML files with as little code as possible
TEST_DEPENDS= p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= YAML::Tiny.3
diff --git a/textproc/txt2html/Makefile b/textproc/txt2html/Makefile
index 404feca49aa0..aa40019bb228 100644
--- a/textproc/txt2html/Makefile
+++ b/textproc/txt2html/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: txt2html
-# Date created: 29 Jun 1998
-# Whom: Don Croyle <croyle@gelemna.org>
-#
+# Created by: Don Croyle <croyle@gelemna.org>
# $FreeBSD$
-#
PORTNAME= txt2html
PORTVERSION= 2.51
@@ -17,7 +13,8 @@ BUILD_DEPENDS= p5-Getopt-ArgvFile>=0:${PORTSDIR}/devel/p5-Getopt-ArgvFile \
p5-YAML-Syck>=0:${PORTSDIR}/textproc/p5-YAML-Syck
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN1= txt2html.1
MAN3= HTML::TextToHTML.3